Force WLM to Open *.eml Attachments

Discussion in 'Windows Live Mail' started by Shawn Sheridan, Apr 3, 2008.

  1. For some reason, e-mail received in WLM with a forwarded e-mail attachment
    (*.eml) opens the attachment in Outlook Express.

    Is there a way to have WLM open these attachments natively, and not use
    Outlook Express?

    I tried changing the File Association for *.eml from Outlook Express to WLM;
    however, when I double click an attachment nothing happens, as in WLM will
    not open it.

    Any help is appreciated.
     
    Shawn Sheridan, Apr 3, 2008
    #1
    1. Advertisements


  2. Looks like you have OE still as the default mail client?
    That's odd because I find WLMail even more tenacious than OE.


    If you would like to have WLMail as the default mail client instead
    One way to change it might be to use the Add/Remove Programs
    Control Panel applet and its Set Program Access and Defaults tool.

    That probably didn't give the correct command line parameters
    for the Open Action.

    <cmd_output OS="XPsp2">
    F:\>assoc .eml
    ..eml=Microsoft Internet Mail Message

    F:\>ftype "Microsoft Internet Mail Message"
    File type '"Microsoft Internet Mail' not found or no open command associated with it.

    F:\>ftype | find /i "mail"
    contact_vcard_file="F:\Program Files\Windows Live\Mail\wlmail.exe" /VCard %1
    mailto="%ProgramFiles%\Outlook Express\msimn.exe" /mailurl:%1
    Microsoft Internet Mail Message="F:\Program Files\Windows Live\Mail\wlmail.exe" /eml:%1
    Microsoft Internet News Message="F:\Program Files\Windows Live\Mail\wlmail.exe" /nws:%1
    Windows Live Contact="F:\Program Files\Windows Live\Mail\wlmail.exe" /contact:%1
    Windows Live Group="F:\Program Files\Windows Live\Mail\wlmail.exe" /group:%1
    </cmd_output>

    In spite of the bug with the ftype command and the stated
    filetype name I think that the filtered list may be more what
    you are looking for anyway.

    See what you get when you try that last command
    both before and after you use the Set Program... tool?


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Apr 10, 2008
    #2
    1. Advertisements

  3. Well, actually my default e-mail client is Outlook 2007. Surely there is a
    fix for this.
     
    Shawn Sheridan, Apr 11, 2008
    #3

  4. Did you try using my suggestions?


    ---
     
    Robert Aldwinckle, Apr 11, 2008
    #4
  5. Robert,

    Somehow I missed your suggestions.

    To clarify, Outlook 2007 is my default e-mail client, and I do not want to
    change that, as this is a corporate laptop configured for domain use.

    That said, when I do launch WLM, and I have an e-mail with an *.eml
    attachment, I expect WLM to open the attachment, not OE. In summary, I have
    no use whatsoever for OE.

    Now, Under program Access Defaults; Microsoft Windows; E-mail Program:, the
    only two choices are Microsoft Office Outlook and Outlook Express. WLM is
    not listed as a choice and it is set for Outlook 2007.

    As for the command line commands, here is what was returned:

    C:\Documents and Settings\ss09546>assoc.eml
    ..eml=Microsoft Internet Mail Message

    C:\Documents and Settings\ss09546>ftype "Microsoft Internet Mail Message"
    File type '"Microsoft Internet Mail' not found or no open command associated
    with it.

    C:\Documents and Settings\ss09546>ftype | find /i "mail"
    mailto="C:\PROGRA~1\MICROS~2\Office12\OUTLOOK.EXE" -c IPM.Note /m "%1"
    Microsoft Internet Mail Message="%ProgramFiles%\Outlook Express\msimn.exe"
    /eml:%1
    news="C:\Program Files\Windows Live\Mail\wlmail.exe" /newsurl:"%1"
    nntp="C:\Program Files\Windows Live\Mail\wlmail.exe" /newsurl:"%1"
    Outlook.URL.mailto="C:\PROGRA~1\MICROS~2\Office12\OUTLOOK.EXE" -c IPM.Note
    /m "%1"
    snews="C:\Program Files\Windows Live\Mail\wlmail.exe" /newsurl:"%1"
    Static Windows Live Mail Backup Archive="C:\Program Files\Windows Live Mail
    Backup\WinLiveMailBak.exe" "%1"
    Windows Live Contact="C:\Program Files\Windows Live\Mail\wlmail.exe"
    /contact:%1
    Windows Live Group="C:\Program Files\Windows Live\Mail\wlmail.exe" /group:%1
    WinZipCompanion.RegFile=rundll32 "C:\Program Files\WinZip E-Mail
    Companion\wzofcsvc.dll",mureg "%1"

    This doesn't mean much to me as a novice; however, it would seem that the
    following line:

    Microsoft Internet Mail Message="%ProgramFiles%\Outlook Express\msimn.exe"
    /eml:%1

    Should be:

    Microsoft Internet Mail Message="%ProgramFiles%\Windows
    Live\Mail\wlmail.exe" /eml:%1

    If that's the case though, I do not know how to set it as such.

    Thanks for your help.

    Shawn
     
    Shawn Sheridan, Apr 13, 2008
    #5
  6. Robert,

    Based on my last e-mail below, I changed the following Registry Key, and it
    corrected the problem:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Microsoft Internet Mail
    Message\shell\open\command
    "%ProgramFiles%\Windows Live\Mail\wlmail.exe" /eml:%1

    It was set for OE before I changed it to WLM. Now it works properly.

    Thanks for your help.

    Shawn



     
    Shawn Sheridan, Apr 13, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.