Freezing mouse pointer - cause and solution

Discussion in 'Windows Vista General Discussion' started by Steve Thackery, May 3, 2007.

  1. This had me going for ages, so I thought I'd share the solution with you.

    System: newly built homebrew with Duo 6600 processor, 2G RAM and 7600GS
    graphics, running Vista Home Premium. It's been running fine for the past
    three months until a few days ago.

    The symptoms were intermittent, brief "freezes" of the mouse pointer,
    typically from a fraction of a second to perhaps two or three seconds. The
    computer would fail to respond to double clicks during these freezes, as
    well.

    It may be that the whole computer was freezing for these brief periods, but
    I didn't get chance to play any sound or video files to see if they were
    stuttering.

    Close monitoring of the processor loading revealed nothing untoward, nor did
    the Event Viewer. Rebooting had no effect.

    I shut the machine down with a view to looking inside, and noticed that the
    little LED inside my Readyboost USB stick was flashing away rapidly. With
    the PC switched off! Presumably this USB port remains powered even when the
    PC is shut down. (It powers down only when you actually use the switch on
    the back of the PSU, or unplug the mains lead, of course).

    Anyway, I unplugged the USB stick, started up my machine and the problem was
    instantly cured.

    Clearly the USB stick had got into some kind of internal muddle, presumably
    generating lots of interrupts and stealing processor time. Whether it's an
    internal fault, or Vista sending it something which upsets it, I've no idea.

    Whatever, I found it worked fine when I plugged it back in, so obviously
    unplugging and replugging is all that would have been necessary to reset it.

    So, if your machine has these odd stutters and freezes, try unplugging your
    Readyboost USB stick!

    Steve
     
    Steve Thackery, May 3, 2007
    #1
    1. Advertisements

  2. Steve Thackery

    Don Guest

    I have the exact situation and continue to have that problem. Mouse is
    unresponsive for two to 5 seconds. My only issue is that I don't have a USB
    stick plugged in. Done everything that has been suggested on this board to
    no avail.
     
    Don, May 4, 2007
    #2
    1. Advertisements

  3. Steve Thackery

    Dave Horne Guest

    I had a similar problem. My mouse, an optical 'laser' kind, was acting as a
    ball mouse that was dirty - sporadic, I couldn't control it. There's really
    nothing to clean and after spending some time with Logitech on the phone it
    was determined that the optical part was bad. I did learn something that I
    will pass on. I extended the usability of that mouse by shining a
    flashlight in the hole underneath - the opening for the optical part. That
    gave me another three days of use until the replacement arrived. That
    'boost' of the flashlight returned the mouse to normal though only for a few
    days.
     
    Dave Horne, May 7, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.