Frustrated User

Discussion in 'Windows Vista Security' started by Tammy, May 18, 2007.

  1. Tammy

    Tammy Guest

    I just got my new Pc with Vista Basic on it. I connected an external hard
    drive to this nice pc. I am a web designer so today I access the data on the
    external drive to update a website and go to save the changes and it denies
    me. Now I have seached every where for help on how to change the permissions
    on this PC i am the sole use and my user settings say i am the administrator.
    Please help me. I had to save my info on my desktop in order to trabfer to
    the website. I would rather keep all my files together. if there is anyone
    out there that is bored and would like to eplain to me how to fix this issue
    I would deeply appriciate it.
     
    Tammy, May 18, 2007
    #1
    1. Advertisements

  2. Tammy

    Neil Harley Guest

    Right click the drive
    Properties
    Security
    Advanced
    Edit
    Configure permissions
    check the 'Replace all inheritable permissions on all descendants ....... '
    Apply

    That should grant you access and allow you to update your files. If you have
    any problems then go through the process again but change the Ownership on
    all objects before changing the permissions. I had to do this when a
    directory on my external drive wouldn't allow me to delete a directory even
    though I was admin.

    hth
     
    Neil Harley, May 18, 2007
    #2
    1. Advertisements

  3. Tammy

    Jimmy Brush Guest

    Hello,

    You are experiencing this problem because the files on your external
    hard drive were created in another installation of Windows, and so
    Windows Vista does not recognize that you are the creator of the
    files.

    To tell Windows Vista that you own the files on Home Basic, you can
    follow these steps:

    - Click Start
    - Type: cmd
    - Right-click cmd when it appears
    - Click Run As Administrator
    - Change location to your drive (e.g., type e:<enter> for drive e)
    - Type: icacls . /grant USER:(OI)(CI)(F) /L /T /Q
    (Where USER is your username)

    If you get any errors, post them as a reply and we will work from
    there.
     
    Jimmy Brush, May 18, 2007
    #3
  4. Tammy

    Tammy Guest

    OK I went to cmd, I have not used this one in a long time :eek:) brings back old
    memories of PERL.... But ok I typed in what you said. How when I click start
    and type cmd the screen just pops up. How do I run as Admin? Then I typed
    exactly what you said with the user as Tammy it said access is denied,
    successfully processed 0 files: Filed processing 1 files.

    icacls . /grant Tammy:(OI)(CI)(F) /L /T /Q

    Thank you for help me i look forward to your reply
     
    Tammy, May 19, 2007
    #4
  5. Tammy

    Neil Harley Guest

    Start / All Programs / Accessories / <right click> Command Prompt / Run As
    Administrator

    hth
     
    Neil Harley, May 19, 2007
    #5
  6. Tammy

    Tammy Guest

    IT WORKED!!! Woohoo! Thank you sooo much.

     
    Tammy, May 19, 2007
    #6
  7. Tammy

    kezhu Guest

    Hello:

    This thread is very helpful. Thanks.

    My problem is a little bit different. Please help. I am the only user of a
    Dell laptop- 1501 with Windows Vista Home Basic. But under Security settings,
    I found that following items are not checked:

    Full Control
    Delete Subfolders & files
    Delete
    Change Permissions
    Take Ownership

    (I don't know why these items are unchecked. I might have wrongly made
    mistakes while playing the laptop as I am new to Vista got it several days
    ago)

    So when I typed in icals . /grant my_username:(OI)(CI)(F) /L /T /Q and
    pressed enter button as suggested by Jimmy, I got the following message

    ..:Access is denied.
    Successfully processed 0 files; Failed processing 1 files" message.

    I have an application which temporarily created some files while running. It
    works OK on WinXP computers. But it doesn't work on this Vista PC. With the
    help of VC6 Debugger, I found that the error message for creating temporary
    file is "Permission Denied".

    Can anyone give me some advice on

    1. How can I have the full control of the system with above items checked ?
    (I've tried to go to Advanced - Edit under Security but these items are
    grayed and I could not change anything).

    2. How to make the application running without "Permission Denied" error?

    Thanks for your help.

    Cheers,


    Ke
     
    kezhu, May 29, 2007
    #7
  8. Tammy

    Cal Bear '66 Guest

    Did you try to run icals . /grant my_username:(OI)(CI)(F) /L /T /Q from an
    elevated (Run as Administrator) command prompt?
     
    Cal Bear '66, May 29, 2007
    #8
  9. Tammy

    Jimmy Brush Guest

    Hello,

    1)

    To which folder are you referring that has these security settings?

    Unless you have a very good reason, you should only use the command I
    mentioned on files and folders that you created yourself.

    In Windows Vista, sensitive operating-system files, such as most files
    in \windows\system32\, can only be modified by Windows Installer -
    which would be when you install or uninstall a patch or service pack.

    You can still put files in this location and have control over them as
    an administrator - this is not restricted... you just can't modify
    system files that are already there.

    This is an added security feature of Windows Vista. Since you normally
    never modify system files directly, only through installing/removing
    service packs and hotfixes, this "locks down" your computer by not
    allowing the unlikely scenario.

    If you change these default security settings, you make your computer
    less secure by allowing more programs access to these sensitive files.

    In order to change the security settings, you need to first take
    ownership of the files. I would recommend only doing this if you
    intend to manually remove some files, and only take ownership of &
    change the permissions on the specific files that you need to remove.

    2)

    - Have you located the specific folder that the application is
    attempting to write to? If so, what is it?

    - Have you turned UAC off?

    - JB
     
    Jimmy Brush, May 29, 2007
    #9
  10. Tammy

    kezhu Guest

    Thanks Jimmy for your quick reply.

    Regarding Jimmy's question 1)
    It is referring to C:\ as when my application is running some temporary
    files are created on c:\.

    The Dell Laptop was installed Vista Home Basic when I got it. I am the only
    user of it (In fact, I added another testuser and give it all rights of
    Administrative Group and it is the same as the first user. I guess this is
    because the first user doesn't have some of the rights as mentioned in my
    last message). My main purpose is to make my application work. And I am
    trying to understand how these security issues affect the application to run
    under Vista. The application could be installed to a Vista PC without any
    problem with files put to System32 and writing to Registry.

    Because the Take ownership check box was grayed out, What I can do to get
    that one work?

    Regarding Jimmy's question 2:
    I partly replied Jimmy's question 2 above.
    How can I turn off UAC? Sorry for this silly question as I am new to vista.

    Thank you again for your help.


    Cheers,


    Ke
     
    kezhu, May 29, 2007
    #10
  11. Tammy

    kezhu Guest

    Thanks Jimmy for your help.

    After turning off UAC, my application works alright and also all security of
    items not checked now are now checked.

    First, I changed the ownership from Administrator to kezhu a member of
    administrators group. Then all check box could be checked or unchecked.
    Checked all boxes wanted. Switch ownership back to Administrator.

    Is it possible to run my application with UAC on?

    Thank you again for your help.

    Cheers,

    Ke
     
    kezhu, May 29, 2007
    #11
  12. Tammy

    Jimmy Brush Guest

    Hello,

    UAC helps to secure Windows Vista by differentiating between "admin"
    programs and "non-admin" programs.

    Only "admin" programs are allowed to use the user's administrative
    power.

    "non-admin" programs are prevented from doing things that could affect
    the system or other users on the system.

    UAC insures that only "admin" programs that the user is running are
    given admin power by asking the user if they are the one starting an
    admin program when it runs.

    This prevents "non-admin" programs from running "admin" programs
    without the user's consent.

    Creating files in the root of drive c:\ is restricted by default for
    non-admin programs, which is why your program is failing with UAC on.

    In order to fix this, you have three choices:

    1) (Best) There is a system folder that is made specifically for
    programs to use for temporary files. Have your program use it.

    2) Change the permissions on drive c:\ to allow your username to
    create files. In essense, this is telling the computer that "creating
    files in drive c:\ is NOT an admin action, so let non-admin programs
    that I run do it). WARNING: This will allow ANY program that runs on
    your computer to do this. (Also, you must not do this programatically
    if you distribute your application to other people).

    3) Mark your program as being an "admin" program by including a UAC
    manifest with it. This will cause it to prompt the user for their
    permission whenever it is run, thus allowing it to have admin power.

    - JB
     
    Jimmy Brush, May 31, 2007
    #12
  13. Tammy

    kezhu Guest

    Thanks Jimmy for your very helpful information.

    I will make use of the system temporary folder in the future.

    Regards,

    Ke
     
    kezhu, Jun 5, 2007
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.