Giving "Run As Administrator" Rights To A Program

Discussion in 'Windows Vista Security' started by Bob H, Jun 22, 2007.

  1. Bob H

    Bob H Guest

    I've been using the Intel Thermal Analysis tool to measure my CPU core
    temperatures. It works fine, but I find that UAC stops it starting up and
    requires me to give it access rights each time I start it.
    I've gone to the Properties dialogue of both the program executable file,
    plus the shortcut - and in the compatability tab have ticked the "Run As
    Administrator" box - which hasn't fully solved the problem. I still get a "An
    unidentified program wants access to your computer" dialogue box and have to
    accept in that instead. Is there a way of permanently allowing this program
    to bypass this UAC check.
     
    Bob H, Jun 22, 2007
    #1
    1. Advertisements

  2. Bob H

    Jimmy Brush Guest

    Hello,

    No, there is no way to allow a specific program to always open with
    administrator privileges without prompting.

    The prompt is not just asking you if you trust a program, but also
    asking you if you opened the program in that specific instance.

    This keeps programs that do not prompt from being able to run the
    trusted administrative tools on your computer without your knowledge,
    which would kind of defeat the purpose of the prompt in the first place.

    The actual issue here seems to be "Why does the Intel Thermal Analysis
    Tool require admin privileges". I've never used the tool, but it doesn't
    sound like it does anything that should need administrator privileges.

    In any case, as a workaround, you can have the tool run automatically at
    startup with admin privileges without prompting, if you are using an
    administrator account. (This is "OK" because a non-admin program has no
    control over this process, so there is no potential for abuse).

    Just go to the task scheduler and create a new task specifying to run
    that tool when you log in, and make sure you check the box that allows
    it to run with 'highest privilege'.
     
    Jimmy Brush, Jun 22, 2007
    #2
    1. Advertisements

  3. If the account you typical use is an "administrator" account, you can
    eliminate the prompt by editing the local security policy.

    In the Start Search box, type local, and local security policy should be the
    first choice. Once it loads, expand local policies, and then select
    Security Options. You want to change the setting for the User Account
    Control: Behavior of the elevation prompt for administrators in Admin
    Approval Mode to Elevate without prompting.

    That should take care of your issue, and many others as well :)
     
    Hurricane Andrew, Jun 22, 2007
    #3
  4. Bob H

    Bob H Guest

    Thanks for the replies - I'll try them out now.

    Bob,
     
    Bob H, Jun 23, 2007
    #4
  5. Bob H

    Diane Walker Guest

    JB,

    Vista still prompted me for the UAC check after I setup a task in Task
    Scheduler. Do you have any suggestions?

    Thanks.

    Diane
     
    Diane Walker, Jun 25, 2007
    #5
  6. Bob H

    Jimmy Brush Guest

     
    Jimmy Brush, Jun 26, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.