Google Earth issue with Vista and Firewalls

Discussion in 'Windows Vista Security' started by Pantherfan69, Apr 2, 2009.

  1. Pantherfan69

    Pantherfan69 Guest

    Hmm, think the malicious toolbar name description in the body of my message is causing it to not get posted

    I posted this earlier, will try and edit the hotbar name in RED just substitute IST for it.

    __________________________________________________________________________________________________________________________

    I was having trouble getting google earth to work for our CIO on his vista machine behind our firewall, the error "We were unable to connect to the Google Earth servers to authenticate your account" kept popping up, even though I verified the hosts were reachable via the built in test app, and manual browsing.

    After many hours of troubleshooting, and discovering that there are a LOT of posts out there with no solution to the problem, I thought I would share my findings on making google earth on vista work behind a corporate firewall.

    If you go to googles support site, they say to make sure port 80 is open for the following hosts

    kh.google.com
    maps.google.com
    auth.keyhole.com

    Typically this isnt the problem, as everyone seems to be able to get to those locations successfully.

    The problem that I discovered was that when google earth goes out to the internet it uses a user-agent similar to:

    GoogleEarth/5.0.11337.1968(Windows;Microsoft Windows Vista (Service Pack 1);en;kml:2.2;client:Free;type:default)


    Unfortunately most firewalls (such as Checkpoint Firewall-1) as well as many spyware/malware scanners are enabling protection against a malicious hotbar called eye sss tea Bar which used IST in its user agent header.

    This meant my firewall was blocking any outbound web browsing if the user agent had vISTa in it, like the google earth app had. Once I discovered this, and changed the default protection for that hotbar I was able to get to google earth from behind my firewall using vista.

    I hope this helps some folks out there :)
     
    Pantherfan69, Apr 2, 2009
    #1
    1. Advertisements

  2. You need to create an account for Google earth.
     
    James Matthews, Apr 26, 2009
    #2
    1. Advertisements

  3. Pantherfan69

    Ramsteren Guest

    Create an account in Google Earth forums? or with Google Earth itself.
    Message error says, "we were unable to connect to the servers *to
    activate your account.*"

    FYI: I have a Google Earth forum account too, and a lot of people
    having the same problem.

    I tried to give IE explicit permission to google earth servers.



    +-------------------------------------------------------------------+
    |Filename: 2009-05-08_231653.jpg |
    |Download: http://www.vistax64.com/attachment.php?attachmentid=12723|
    +-------------------------------------------------------------------+
     
    Ramsteren, May 9, 2009
    #3
  4. Pantherfan69

    Ramsteren Guest

    I did did several things and I'm not sure which fixed it.

    1) uninstalled google earth
    2) opened regedit and deleted all folders to google earth.
    3) deleted all cookies and temp files
    4) discovered that I had an additional firewall from Sphinx for Vista
    64 that when I went to go uninstall some programs. I uninstalled it
    which was most likely the problem, but on the Google Earth websites,
    everyone said they lost connection upon upgrading to higher versions of
    google earth. That's why I cleaned every trace of google earth off my
    computer before reinstalling.
    5) Reinstalled Google Earth 5 and it works. SHOCK!

    Not only that, but I didn't have to re-setup the permissions in vista's
    firewall. It works fine without the exceptions. It worked before and I
    never had to give exceptions and reconfigure a rule in the router itself
    (as some suggested).

    Well, I will tell you what I did know, and that was that unless it was
    a browser (IE or Firefox) on Port 80, no other type of connection
    worked. I still can't get my e-mail, and have to use browser to go to
    e-mail website to get it.

    I still have AVG going.
     
    Ramsteren, May 19, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.