Group Policy Preferences not applying on Vista with Service Pack2

Discussion in 'Windows Vista Networking' started by Jostein Klemmetsrud, May 8, 2009.

  1. Hi,

    I'm in the process of deploying Vista with Service Pack 2, and I'm using
    the ISO which has SP2 integrated.

    But now Group Policy Preferences doesn't work anymore.

    The client side extensions (KB943729) are included in SP2 according to this:

    http://www.microsoft.com/downloads/...21-3D31-4A10-B8ED-E1BB770E3212&displaylang=en

    How do I fix this problem?

    BTW: KB943729 won't install on Vista SP2 ("This update does not apply to
    this system").

    Jostein Klemmetsrud
     
    Jostein Klemmetsrud, May 8, 2009
    #1
    1. Advertisements

  2. Hello Jostein,

    What error message is displayed or in the event viewer? What exact does not
    work?

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], May 8, 2009
    #2
    1. Advertisements

  3. Drive Maps and Files (the only things in preferences I currently use)
    does not work.

    Where should I look in the event viewer?

    On a Vista SP1 machine (with KB943729 installed) I get messages in
    Microsoft / GroupPolicy / Operational, like:

    "Starting Group Policy Drive Maps Extension Processing"

    and

    "Starting Group Policy Files Extension Processing"

    But on my SP2 machine these messages do not appear (or any error
    messages related to these extensions for that matter).
     
    Jostein Klemmetsrud, May 8, 2009
    #3
  4. Howdie!

    Can you check whether the Preference Client Side Extensions (CSEs) are
    installed on the SP2 machine - or whether they're removed?

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
    NT\CurrentVersion\Winlogon\GPExtensions\

    It should have these subfolders:

    Files Extension: {7150F9BF-48AD-4da4-A49C-29EF4A8369BA}
    Drive Maps Extension: {5794DAFD-BE60-433f-88A2-1A31939AC01F}

    Cheers,
    Florian
     
    Florian Frommherz [MVP], May 8, 2009
    #4
  5. These are missing on my SP2 machine. Here's a list of the ones I have:

    {0ACDD40C-75AC-47ab-BAA0-BF6DE7E7FE63}
    {25537BA6-77A8-11D2-9B6C-0000F8080861}
    {35378EAC-683F-11D2-A89A-00C04FBBCFA2}
    {3610eda5-77ef-11d2-8dc5-00c04fa31a66}
    {426031c0-0b47-4852-b0ca-ac3d37bfcb39}
    {42B5FAAE-6536-11d2-AE5A-0000F87571E3}
    {4CFB60C1-FAA6-47f1-89AA-0B18730C9FD3}
    {7933F41E-56F8-41d6-A31C-4148A711EE93}
    {7B849a69-220F-451E-B3FE-2CB811AF94AE}
    {827D319E-6EAC-11D2-A4EA-00C04F79F83A}
    {8A28E2C5-8D06-49A4-A08C-632DAA493E17}
    {A2E30F80-D7DE-11d2-BBDE-00C04F86AE3B}
    {B1BE8D72-6EAC-11D2-A4EA-00C04F79F83A}
    {B587E2B1-4D59-4e7e-AED9-22B9DF11D053}
    {C631DF4C-088F-4156-B058-4375F0853CD8}
    {CF7639F3-ABA2-41DB-97F2-81E2C5DBFC5D}
    {FB2CA36D-0B40-4307-821B-A13B252DE56C}
    {c6dc5466-785a-11d2-84d0-00c04fb169f7}
    {e437bc1c-aa7d-11d2-a382-00c04f991e27}
     
    Jostein Klemmetsrud, May 8, 2009
    #5
  6. Howdie!

    Can you try to re-install the CSEs?

    http://www.microsoft.com/downloads/...87-884c-46d5-82cd-f3c299dac7cc&DisplayLang=en

    Cheers,
    Florian
     
    Florian Frommherz [MVP], May 8, 2009
    #6
  7. When I try to install this update I get this message: "This update does
    not apply to this system".

    It also says on the page:

    Supported Operating Systems: Windows Vista; Windows Vista Service Pack 1

    So I guess that's why I get the message.

    I have managed to install the update by first extracting it and then
    installing it with pkgmkr.exe. And then of course, everything works as
    it should.

    It seems the list of updates included in SP2 is incorrect or that
    something is broken in SP2.
     
    Jostein Klemmetsrud, May 8, 2009
    #7
  8. Howdie!

    Well, those Preferences are for Windows Vista SP1 - the setup for SP2
    seems to wipe them for some matter.

    Let me ask once again: was that a Vista SP1 machine with Preferences
    installed/working before and you installed SP2 or was that a clean SP2
    install (slipstreamed) DVD-install?

    Cheers,
    Florian
     
    Florian Frommherz [MVP], May 8, 2009
    #8
  9. Installed from an untouched ISO of Windows Vista with SP2
    integrated/slipstreamed (downloaded from Microsoft).
     
    Jostein Klemmetsrud, May 8, 2009
    #9
  10. Jostein Klemmetsrud, May 13, 2009
    #10
  11. Jostein Klemmetsrud

    QS-Bhavin Guest

    I've had the same issue also. Its obviously a bug.

    In my case, I had done a fresh install of Vista SP1, but did not install any
    updates and installed SP2 straight after.
     
    QS-Bhavin, May 13, 2009
    #11
  12. Howdie!

    The installers for GP Preferences will be updated once Vista SP2 gets
    RTM'd. If the "hack" (= unpacking the MSU file) works for you, you of
    course can stick with that.

    Cheers,
    Florian
     
    Florian Frommherz [MVP], May 14, 2009
    #12
  13. Here is how I got around it.

    download the CSE from here.
    http://support.microsoft.com/kb/943729

    (*Note you will obviously need to modify the commands below if your on
    x64*)

    Open command prompt and run the following:

    mkdir MSU\KB943729\
    expand Windows6.0-KB943729-x86.msu -F:* MSU\KB943729\ start /w
    %SystemRoot%\system32\pkgmgr.exe /ip
    /m:MSU\KB943729\Windows6.0-KB943729-x86.cab

    Reboot your computer and CSE should be working fine :)
     
    Jake Paternoster, May 26, 2009
    #13
  14. Jake,

    Thanks for sharing. As I see thise here, your solution pretty much
    matches with what Jostein posted
    (http://blog.tiensivu.com/aaron/arch...g-a-.MSU-package-in-Vista-or-Server-2008.html).

    I expect the GP Team to have an updated version of the GPP-CSE by the
    time SP2 gets RTM'ed.

    Cheers,
    Florian
     
    Florian Frommherz [MVP], May 26, 2009
    #14
  15. Sadly, SP2 RTM has been and gone, and no updated installers for the CSEs.
    This means Windows Update and WSUS also doesn't install it.

    Frankly, I'm very disappointed. This is the exact same problem that occurred
    with Windows XP SP3. For this to occur once was irritating; twice is
    shameful. Someone at Microsoft has really dropped the ball on this.
     
    AngryTechnician, Jun 16, 2009
    #15
  16. Jostein Klemmetsrud

    Dave Warren Guest

    In message <>
    You can load GPP-CSEs into WSUS from Microsoft Catalog, no?
     
    Dave Warren, Jun 16, 2009
    #16
  17. Microsoft released an update to the KB943729 patch for Vista on June 23rd and
    updated the Supported Operating Systems listing under System Requirements to
    reflect that it would install on Vista Business, Enterprise, and Ultimate
    with Service Pack 2 installed, but upon downloading I still get the same
    message on both Business and Enterprise systems with Service Pack 2
    installed.

    I also attempted to install the update using the trick mentioned above and
    it worked before they updated the file, but now it does something horrid to
    the user side of Group Policy and causes it to time out when attempting to
    update.

    I would absolutely love a fix for this as I am trying to set up an automated
    printer deployment solution using GPO preferences. I agree to the point that
    it feels like the ball was dropped on this one.
     
    Thomas Rhoads, Jun 25, 2009
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.