Half-Life 2 failed to load and crashing once loaded [RESOLVED]

Discussion in 'Windows Vista Games' started by ltspicoli, Dec 23, 2008.

  1. ltspicoli

    ltspicoli Guest

    So I just built a new system, installing Vista Business 64bit to tak
    full advantage of DX10 and large amounts of memory. Not having man
    games lying around, I decided to download steam and install Half Life 2

    If you are reading this, and using a 64bit edition of windows, then m
    guess is you are having problems with Half Life 2. I encountered tw
    problems, and after a few hours was able to solve both of them

    PROBLEM 1: GAME HANGS ON INITIAL LOAD (BLURRY IMAGE SCREEN

    - Symptoms

    - "64-bit" message was at top of scree
    - game never loade


    - Potential cause

    - It seems that while steam intended HL2 to have a 64bit edition
    with an update along the line (maybe with the release of Left4Dea
    according to others) the support was broken and the game doesn'
    load


    - Fix

    - Unfortunately, the fix removes the 64bit potential. In steam
    right click half life 2, and select <Properties>
    - From the dialogue box, click <Set Launch Options...
    - Enter "-32bit" and select <OK



    This got HL2 to load, where upon playing I encountered problem numbe
    2

    PROBLEM 2: GAMEPLAY CAUSES FULL SYSTEM HAN

    - Symptoms

    - After playing for less than 5 minutes, the game would crash an
    the three fingered salute (ctrl+alt+del) couldn't get me out of it
    The crash caused a full system hang that required a hard-reboo


    - Potential Causes

    - While from Problem 1 we are running in 32bit mode instead o
    64bit, we are still running Vista


    - Fix

    - Go to the HL2 executable, by default [-Program File
    (x86)\Steam\steamapps\<your user name>\half-life 2-
    - right click on hl2.exe and select <Properties
    - select the second tab, "Compatibility
    - check the box for <Run this program in compatibility mode for:
    - select <Windows XP (Service Pack 2)> from the drop down men
    - select <Apply> then <OK



    This means that we are taking a 64bit Vista compatible game, an
    running it as a 32bit XP game

    After these two fixes, I was able to set my video settings to max (
    thought this was the original problem) and play the game withou
    interruption. Hopefully steam and/or windows will fix this bug and I ca
    return to the intended game settings, but do note that steam says o
    their website that 64bit save files are not compatible with 32bit gam
    mode. While mathematically, you should be able to load a 32bit save fil
    into the 64bit game (as long as it substitutes 0x0 for the upper 32bits
    I have no idea if they will support it. Oh well, another excuse to pla
    through one of the greatest games to date (in my opinion!
     
    ltspicoli, Dec 23, 2008
    #1
    1. Advertisements

  2. ltspicoli

    Mark Guest

    Well done solving the problems!


    Mark
     
    Mark, Dec 24, 2008
    #2
    1. Advertisements

  3. ltspicoli

    David B. Guest

    He didn't solve them, I found this fix months ago, likely he was just
    posting what he found for the benefit of others.





     
    David B., Dec 24, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.