Halo 2 Asking for disk everytime I finish the Quarantine Zone

Discussion in 'Windows Vista Games' started by Kefner, Jun 21, 2007.

  1. Kefner

    Kefner Guest

    Everytime I finish the Quarantine Zone level, and the cut scene plays where
    the brutes shoot you off the edge, it comes up with a message "Please insert
    your original Halo 2 disk". What I have done so far is uninstall/reinstall
    of Halo 2, no luck. Decided I could use a fresh install of Windows anyway,
    so reinstalled that, and then Halo 2, still no luck. Figured maybe there was
    a problem with my disk, returned it to the store and exchanged for a new one.
    Again, did a fresh install, played through to this point, and get the
    message at the same point. I don't even get an option to do anything but say
    ok, and it takes me back to the main menu. I've tried playing with and
    without the disk in the drive. Inserting the disk only when it asks, and
    ejecting and closing the drive, and it will not do anything with the disk,
    even though it asks. I have tried everything I can think of, 2 installs of
    Vista, and multiple fresh installs of Halo 2, and still no luck!
     
    Kefner, Jun 21, 2007
    #1
    1. Advertisements

  2. Kefner

    CVScorp Guest

    Kefner,

    This is happening to me and many others as well. I thought that maybe since
    I got my CD early from Circuit City before the recall that the files on the
    CD are corrupt. Since you said you returned yours for a new copy that might
    not be the case. Whatever the problem is Microsoft needs to put out a fix
    since this is not an isolated problem.
     
    CVScorp, Jun 21, 2007
    #2
    1. Advertisements

  3. Kefner

    Andy Guest

    Not isolated to my system. When you say "many" others, do you mean everyone
    that's having the problem and posting about it online? Because that's
    usually a lower percentage than you think it is. ;)
     
    Andy, Jun 21, 2007
    #3
  4. Kefner

    Kefner Guest

    Well the thing is, when I got a new copy, it has the "sticker" on it warning
    of partial nudity, so it is probably still one of the first runs. I guess I
    will just hold off and see if the next patch fixes this. Im tired of trying
    to figure it out. If anyone can help though, please let me know.

    Keith
     
    Kefner, Jun 21, 2007
    #4
  5. Kefner

    Andy Guest

    The "Nudity" in Halo 2 was some guy showing his ass in an error screen on
    the map editor. Other than that there's no difference between the 2 versions
    of Halo 2 PC. You might want to poke around the Bungie forums.
    (http://www.bungie.net/forums/topics.aspx?forumID=2) maybe someone has a fix
    posted. I looked, couldn't find one in the first 2 topics I looked at, but
    people are talking about the problem.

    Don't think a patch is planned right away, you could be waiting a while, and
    the patch might not address your problem. Might as well keep pluggin away.

    -a.
     
    Andy, Jun 22, 2007
    #5
  6. Kefner

    Chris Hagler Guest

    This is a common problem and has been posted on the Halo 2 Vista forums.

    The work around is....start your game up in campaign mode, and SELECT LEVEL.
    I believe the next level is called GRAVEMIND or something like that...

    Now you can finish the campaign.

    Later...
     
    Chris Hagler, Jun 22, 2007
    #6
  7. Kefner

    Kefner Guest

    That worked! Thanks man!!!!!!!!!!

     
    Kefner, Jun 23, 2007
    #7
  8. Kefner

    Andy Guest

    I take it back, second time through I got it. I think it has something to do
    with Live for Windows. I wasn't logged in the first time. Well ain't that a
    bitch. Damn doesn't Redmond test their crappy titles. :)
     
    Andy, Jun 23, 2007
    #8
  9. Kefner

    Andy Guest

    Odd, didn't work for me, was giving me errors, like your achievements don't
    match what's on windows live and it won't let me play the next level, only
    one it'll let me do is the level like 2 parts back. weird.

    Anyone know if there's a forum post at bungie.net about this? I couldn't
    find anything.
     
    Andy, Jun 23, 2007
    #9
  10. Kefner

    RiverDog Guest

    Do this. It worked for me.

    "Because the insert disc message appears at the transition between two
    levels, you can start the new level and abandon your previous checkpoint.

    To do this:
    1) Restart Halo 2
    2) Select Campaign
    3) DO NOT select continue, select to choose the level
    4) Find the latest level and start it, skipping over the transition between
    the level before it and that which seems to cause the problem"


    Regards

    RiverDog

    Note: Achievements will not be lost through this fix, so don't worry
     
    RiverDog, Jun 25, 2007
    #10
  11. Kefner

    Wolf Lahti Guest

    This does not work for me. When I select the Gravemind level, I just get the
    "insert disc" message (even though it's already inserted) and get booted back
    out to the main menu. I can run scenarios earlier than Gravemind, but of
    course that doesn't do me any good.

    I have also gotten the message, "The procedure entry point
    CreateProcessWithTokenW could not be located in the dynamic link library
    ADVAPI32.dll." There are two instances of ADVAPI32 in my system - one in
    WINDOWS\system32 and one in WINDOWS\SoftwareDistribution\Download\...
     
    Wolf Lahti, May 4, 2010
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.