HDCD logo not displayed in media player 10 or 11, not supported??

Discussion in 'Windows Media Player' started by LukeS, Nov 3, 2009.

  1. LukeS

    LukeS Guest

    Hi,
    The HDCD logo does not appear in windows media player 11.0.6002.18111 when
    playing a HDCD. I have a vista computer with a 24-bit creative sound card.

    The HDCD logo shows up in the bottom left corner of media player 9, which I
    have running on my windows XP desktop with a 24-bit soundcard. I have not
    upgraded to a later version on that machine because I want to keep HDCD
    playback.

    Did Microsoft remove HDCD playback in media player 10 and 11?

    I have enabled 24-bit output under options -> devices -> speakers.

    Any ideas? Thanks
    - Luke
     
    LukeS, Nov 3, 2009
    #1
    1. Advertisements

  2. LukeS

    LukeS Guest

    Update: There is definitely a bug in windows media player that need
    correcting..

    If I turn OFF 24-bit output under options -> devices -> speakers which is
    required for HDCD playback and restart media player the HDCD logo will appear
    when playing a HDCD, if I then turn 24-bit playback back on and restart
    windows media player the logo will not be shown during HDCD playback.

    How do I submit this issue to Microsoft developers for fixing?
     
    LukeS, Nov 3, 2009
    #2
    1. Advertisements

  3. LukeS

    Vincent Guest

    I don’t think this is a bug.
    HDCD is a special type of CD.
    It uses the LSB (Last Significant Bit) of the 16 available to store some
    extra information.
    The moment you tell WMP to generate 24 bit output, 8 zero’s will be padded
    to the file so the LSB is always zero.
    But it is a CD so 16 bits and should be played as such.
    If it was 24 bits, no CD player could play it.
    http://en.wikipedia.org/wiki/High_Definition_Compatible_Digital
     
    Vincent, Nov 3, 2009
    #3
  4. LukeS

    LukeS Guest

    Hi Vincent,
    I respectfully disagree, this is definitely a bug, no doubt about it. It
    clearly states in options -> devices -> speakers -> properties

    "This option enables higher-quality audio CDs, such as HDCDs, to play back
    at their full audio quality." Thus this must be checked too allow HDCD
    playback.

    You must have a 24-bit audio card to play the 20-bit HDCD audio data. Many
    standard 16-bit audio cards found in most computers will not support this so
    windows media player do not decode the HDCD data and sends the CD PCM data to
    the sound card at the standard 16-bit. Since there are no 20-bit DAC \
    soundcards when HDCD decoding is enabled the 20-bit decoded data is padded
    out to 24-bit and then sent to the sound card (the sound card then sends the
    24-bit audio data to the DAC at 24-bits).

    How do we get a developers attention on this issue?
     
    LukeS, Nov 4, 2009
    #4
  5. LukeS

    Panzy Guest

    Hi
    I have to first say that I don't actually have any HDCD's.
    And all I can gather is that for playback of such HDCD's requires
    compatible hardware (which you have), or playback defaults to
    the red book sixteen binary digits and bandlimited (16bit/44khz)
    This seems to be so that such disc's are also compatible with
    all cd players and media players etc.
    Regardless if the logo displays, I'd assume one could easily discern
    if playback is actually the HDCD encoded content or 16 bit
    red book content.
    It's not clear if the problem is that when you have correctly configured
    your hardware + software, that playback defaults to red book 16bit
    playback or if HDCD content playback is achieved in all it's glory
    but just that the logo dosen't display?
    If it is defaulting to 16 bit playback, I'd first suspect configuration
    settings to be the prime culprit, double check you have it all configured
    correctly. But it could also be a number of issues causing to default to
    16 bit - copy protection or DRM of some sort maybe? A soundcard driver
    update? Or a visit to the support/troubleshooter/FAQ of the manufacturer
    of your soundcard - it maybe an issue known to them?
    If it is just the logo fails to display but HDCD playback is achieved
    then that would indicate it is indeed a bug with WMP?

    As for reporting it as a bug, well a brief search engine scout reveals
    it to be a longstanding annoyance with many, and reported many times.
    Just one example which you may like to try, turn on Hardware acceleration
    (though that didn't work for that HDCD devotee)
    http://www.atforumz.com/archive/index.php/t-304147.html

    From the same thread as above was this link:
    http://www.hydrogenaudio.org/forums/index.php?showtopic=30999&st=25
    Though at first it may not seem relevent to your problem, the issue
    seems to be copying HDCD content. It seems from other results that
    HDCD content cannot be fed via the digital outputs of standalone players -
    the output from coax and fibre optic outputs of such players to off board
    DAC's will be 16bit only, not the higher sampling 20bit HDCD content?
    Again, this may not be relevent to you, but a search revealed that owners
    of standalone HDCD capable cd players found that they had to disable
    the digital outputs of their machines to achieve HDCD playback on those
    machines? This would seem to be a token gesture to prevent HDCD copying.
    This shouldn't be an issue with a PC as the drive would be iDE or SATA and
    capable of of full bandwidth transfer amyway, but you could try disabling
    the digital outputs of your soundcard to see if that is the reason HDCD
    refuses
    to play ball?

    But, your problem caught my attention, though I don't have a solution nor
    experiance of HDCD, your problem seems to be a longstanding known issue.
    You could try wading through all the results a search produces as somewhere
    in there someone may have a solution or had received an explaination from
    Microsoft. Try these search terms in google, ask, etc:
    HDCD media playback (also try adding OS and version of WMP in serach term)
    HDCD logo problem
    HDCD problem
     
    Panzy, Nov 4, 2009
    #5
  6. LukeS

    Vincent Guest

    Hi LukeS

    I obvious misinterpreted your post
    Sorry.
    Vincent
     
    Vincent, Nov 4, 2009
    #6
  7. LukeS

    zachd [MSFT] Guest

    HDCD is supported. You don't mention the precise sound card, but if the
    system is constant (same system, same sound card), I'd potentially check if
    they're running the same driver version.
     
    zachd [MSFT], Nov 24, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.