Help - Can't use Windows update

Discussion in 'Windows Vista Talk' started by Trent Rowe, Dec 5, 2007.

  1. Trent Rowe

    Trent Rowe Guest

    I just got a new computer and had Vista Ultimate loaded onto it. I'm
    having trouble getting Windows update to work though.

    I keep getting the message that Windows needs to install new Windows
    Update Software(7.0.6000.381 I believe). I click on the install now
    button then after a bit get the message that Windows could not search
    for new updates and get the error code 80070643. The help for this
    message indicates that this has something to do with the Office Source
    Engine Service. I did what it said and made sure the service was
    started. That didn't help. The version of Office on the system seemed to
    be a fully functional demo of Office 2007. I didn't plan on using this
    so uninstalled Office 2007 and anything else that had to do with Office
    in the add/remove programs. Rebooted and still got the same error
    message even though there was no copy of MSoffice on my system.

    I installed my copy of Office 2003, made sure the service was set to
    properly start and was indeed started, but still get the same error message.

    In investigating this a bit, one thing I tried was renaming the
    Windows\SoftwareDistribution\SelfUpdate folder and creating a new one
    thinking the information in that folder may be corrupt in some way.
    Tried Windows Update am still getting the same error message.

    I'm stuck! How do get this new Windows Update Software installed so I
    can get updates? I don't know why it keeps giving me the 80070643 error
    code as I've had two different versions of office installed at a time
    and even no version of windows installed.

    Any help would be greatly appreciated. Nothing I do seems to fix this.

    Thanks!

    Trent Rowe
     
    Trent Rowe, Dec 5, 2007
    #1
    1. Advertisements

  2. Mike Hall - MVP, Dec 5, 2007
    #2
    1. Advertisements

  3. Trent Rowe

    Trent Rowe Guest

    Hi Mike,

    I tried all the recommendations outlined there, but am still having the
    same problem and error message. Could something else besides office be
    causing this error. Windows Defender maybe or perhaps there are still
    registry keys or leftover files causing this.

    Thanks for your help!
     
    Trent Rowe, Dec 8, 2007
    #3
  4. Trent Rowe

    Trent Rowe Guest

    Yo Mike Hall, you still there?

    Anyone else have any ideas. This is very frustrating.
     
    Trent Rowe, Dec 13, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.