Help! Dependency service or group failed to start

Discussion in 'Windows Vista General Discussion' started by Tony K, Dec 13, 2007.

  1. Tony K

    Tony K Guest

    Windows Vista Ultimate. New Dell D630 (O.S. factory installed). Sudden
    inability to communicate with network either by Wi-Fi, ethernet card, or
    Verizon Broadband wireless service. The message on the WiFi indicator says
    Dependency service or group failed to start. The diagnosis utility says the
    computer doesn't have a network card installed or configured. Everything was
    working fine until all three stopped working. The Bluetooth module is still
    working. Any help (and solutions) much appreciated.

    Tony
     
    Tony K, Dec 13, 2007
    #1
    1. Advertisements

  2. Tony K

    Tony K Guest

    I spent some time with Dell talking about this issue. System restore didn't
    correct the problem. We checked out services and their dependencies. Before
    going to the ultimate (and worst case) solution which would be to re-install
    the O.S., I ran cmd/sfc /scannow which is the Windows file checker. It
    corrected some errors and now things are working again.

    I commend Dell for helping me fix what was clearly a problem caused by
    faulty Microsoft software.

    As someone who's used computers for almost 30 years, it still very
    frustrating that errors like system file corruptions occur in a brand new
    O.S., and that the system isn't capable of automatically identifying faults
    and correcting them itself. Users should not have to dig around in Windows
    services. Ideally, a computer would identify that all is not well and either
    fix it itself, or connect to a Microsoft website for a comprehensive
    diagnosis and repair of all damaged files.

    Tony
     
    Tony K, Dec 13, 2007
    #2
    1. Advertisements

  3. Tony K

    Slaws Guest

    Hi Tony,

    I am having the same problem -- only with a new Toshiba Satellite. I have
    been unable to run the file checker, i.e., I can't seem to find it. Can you
    give me the entire sequence or tell me how to find it? Thanks loads!
     
    Slaws, Dec 16, 2007
    #3
  4. Tony K

    Tony K Guest

    Sorry for not seeing your reply and question until now.

    Begin with Start (bottom left of your desktop). Where is stays ''Start
    search', enter 'cmd'. A new window opens. Type 'sfc /scannow' and that
    begins the scan and repair process. This is what I did and it worked for me.
    No guarantees it's going to fix your problem. As I said, it's crazy that this
    kind of software error can occur in 2008.

    Good luck.
     
    Tony K, Jan 19, 2008
    #4
  5. Tony K

    PaulDrake Guest

    That helped SO MUCH!!!! Thank you!!!
     
    PaulDrake, May 29, 2008
    #5
  6. Tony K

    xpect2lose Guest

    I don't know if anyone will see this at all, but I have been having th
    same "Dependency service or group failed to start" problem. It jus
    occurred the other night

    I did try the cmd sfc/scannow, but it told me that I must be a
    administrator running a console session and I'm not sure what they ar
    telling me to do.

    Any help would be appreciated

    Also, I feel like part of this problem is stemming from a problem wit
    my Dell not recognizing my charger. It will keep the laptop powered, bu
    it won't charge the laptop. I'm sitting at 0% charge whenever I'
    working on my laptop and am on Power Saver power plan which makes thing
    run slowly and less efficiently.

    Any solution for that problem would be appreciated as well

    Thank you
     
    xpect2lose, Jun 29, 2008
    #6
  7. Tony K

    supasonic85 Guest

    You may be more fortunate than me. I have had the same error too, and as a
    result, I haven't been able to connect to the Internet. Is this the same with
    you.

    As for the sfc/scannow command, you can temporarily designate yourself as an
    administrator. If you click on the Start Orb and type in 'cmd' in the search
    box, one of the results should be the Command Prompt shell. Right click on
    that and choose 'Run as administrator' and then you will be able to use that
    command. Perhaps it will work for you. When I ran it, it said that one file
    was corrupted and this file doesn't seem like it can be fixed (npmproxy.dll).
     
    supasonic85, Jun 30, 2008
    #7
  8. Tony K

    pylnik Guest

    I have problems with services which seems like yours.
    After installing SP1 I can't use network services. It says "dependency
    service failed to start" etc.
    I cant rollback the SP1 setup (coz I haven't made restore point before,
    haven't Vista DVD).
    What should I do? :(
     
    pylnik, Aug 26, 2008
    #8
  9. Tony K

    newtech Guest

    Go to Start>Run and type in services.msc then press Enter. In th
    window that opens find Print Spooler on the right, right-click it an
    select Properties. Go to the Recovery tab and change all 3 drop-dow
    boxes to Restart The Service. Make sure the 2 text boxes underneath sa
    1 in them. Click Ok until you are back at the Services window, close i
    and you're good to go.

    Now when ever your Print Spooler craps out, it will automatically rese
    itself
     
    newtech, Sep 11, 2008
    #9
  10. Tony K

    Arisley Guest

    I've been having problems with my computer giving me the dependenc
    service or group failed to start on my internet. I'm connected to th
    internet but it claims that the connection status is unknown and when
    try to run the sfc/scannow it says "there is a system repair pendin
    which requires reboot to complete. restart windows and run sfc again"
    When I restarted my computer and tried again, it gave me the sam
    message. My computer has also been unable to check for updates or t
    actually install them. I have windows vista and my computer is
    Gateway
     
    Arisley, Sep 12, 2008
    #10
  11. Tony K

    Brucew Guest

    Like the others, I too am having the problem. I can connect to the
    internet and can print to a networked printer, but I cannot access other
    computers on the network and they cannot access the portable that is the
    source of the problem. I tried to do the things suggested in the
    thread, i.e. restore and then sfc /scannow. As suggested by one of the
    notes, when the scan was complete I was told that there were some
    corrupt files, but unlike others, I still had the same problem. Now
    what? Any suggestions would be greatly appreciated. Thank you.
    Brucew
     
    Brucew, Sep 15, 2008
    #11
  12. Tony K

    s_mamdani Guest

    I've got the same problem described here--I've run the file scanner, but
    the results state that there are files that have not been repaired, and
    I get directed to a log file that is a 15MB txt file--I can't make heads
    or tails of it. Anyone have further suggestions?
     
    s_mamdani, Sep 15, 2008
    #12
  13. Tony K

    Stilgar02 Guest

    I am having the same problem as everyone else here. When I run the
    sfc/scannow command it comes back saying "Windows Resource Protection
    found corrupt files but was unable to fix some of the problem." When I
    attempt to start the services manually I get back "Error 5:Access is
    denied." A list of the automatic services that are not starting is:
    Base Filtering Engine, DHCP Client, Diagnostic Policy Service, Ike and
    AuthIP IPsec Keying Modules, IPsec Policy Agent, Network List Service,
    Network Location Awareness, TPM Base Services, and Windows Firewall. MY
    anti-virus software (Trend Micro) cannot find any viruses. It seems
    like the root service problem is the Base Filtering Engine. Any help
    would be greatly appreciated!
     
    Stilgar02, Sep 15, 2008
    #13
  14. Tony K

    vanilla Guest

    Update Trend Micro on all of your computers that you can. On the one that
    you can't, go to the Quarantine folder and see if it has files from the
    Windows folder, especially NLA Service, wextract ... IF you had received an
    alert or Trend Micro scan alert concerning a Trojan.Generic or Trojan.ADV,
    and these files are in the Quarantine folder, restore the files. DO NOT
    delete the files. If they have already been deleted, use another computer to
    go to the Trend Micro website and look for Home Support ... this is a known
    problem that occurred recently.

    If you have not yet installed Windows Vista Service Pack 1, and you can get
    Windows Update to work, you might try installing the Service Pack. Good luck
    .... vanilla
     
    vanilla, Sep 16, 2008
    #14
  15. Tony K

    MStrong Guest

    Hello All,
    I've been reviewing all of your posts and have the same problem myself
    on a laptop OEM installed w/ vista. I recently updated to SP1 to
    attempt to correct these issues and had not prior, but had post SP1 run
    the sfc /scannow command which returned to me that there were no errors
    found.
    I know that a discrepency existed with earlier versions of windows
    where if you ran sfc /scannow after having a service pack installed that
    the sfc module would find an issue with system files (updated by the sp)
    and attempt to replace them, causing other issues and requiring
    re-installation fo the sp.
    I'm wondering if this contingency still exists, or if sfc recognizes
    system files updated by the sp and looks for the updated versions.

    Also, FYI: In researching this issue, among the dozens of individuals
    who have given up and re-installed to fix this issue, I stumbled upon
    this other possible solution which seems to be more of a manual way to
    address the issue rather than relying on windows (seemingly not always
    accurate) 'system file checker'.

    Check out this thread:
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PageIndex=0&SiteID=17&PageID=0&PostID=3842969

    I hope this info helps someone else. I have yet to attempt to apply
    this to my individual situation, as the laptop belongs to someone else
    (so glad I didn't buy vista yet )

    I'll be watching for thread updates, I hope we can identify a
    _difinitive_ solution
     
    MStrong, Sep 18, 2008
    #15
  16. Tony K

    Louweezzz Guest

    Ok, i have decided to post something in relation to this thread as
    'think' its relevent and i need HELP
    im not a comp nerd...but try really hard to understand what goes on i
    my laptop (HP Pavilion dv 6700
    Ok, so this is what the deal...bottom right in the notifcation bar th
    2 computer screens have a red cross through it...as i hold the mous
    over it, it says,
    "connection status: unknow
    The dependency service or group failed to start

    (i no thats not right, there should be a signal showing a world symbo
    flashing and all...

    i CAN connect to the net, browse the net...but when trying to downloa
    a 'patch' thingy (not me, my boyfriend was trying to download the Wo
    new patch) it kept saying that there is a firewall preventing the patc
    being downloaded.
    ok, so im thinking it had something to do with the net status as wel
    saying "unknown"

    not sure what else to post here to describe what the problem is... bu
    yeah..

    CAN ANYONE HELP?

    thanks so much :
     
    Louweezzz, Oct 20, 2008
    #16
  17. Tony K

    mjbarrow Guest

    Basically a friend of mine is having problems with a new Dell lapto
    preinstalled with Vista.

    As of Saturday, internet connection has gone from within the Universit
    network. She can access the network but the OS wont recognise th
    gateway and defaults to a 169.x.x.x IP address.

    Having looked at the events etc, a Windows update occurred on th
    afternoon of Friday 17th - possibly SP1 - and since the reboot ove
    night it wont connect.

    Error showing is "Dependency service or group failed to start" on th
    network icon in the tray. Have tried "sfc /scannow" as recommended b
    various individuals on the net but certain files that are identified a
    corrupt can not be fixed and a log some 15mb is created in the process
    Print Spooler is running fine but am unable to start a number o
    services that are set to automatic (DHCP, Diagnostic Policy and a fe
    others).

    Event viewer isnt showing much and there are a few other things I nee
    to check including, "unable to gain access to user store" which i
    associated to a network orientated (possibly WiFi) driver.

    Any ideas?

    Thanks in advance for all and any assistance!

    Regards

    Matthew
     
    mjbarrow, Oct 22, 2008
    #17
  18. Tony K

    sharkymatei Guest

    hi everyone...I had the same problem and this seemed to work for me an
    a few computers

    go to start menu and type cmd in the search bar and open cmd wit
    administrator right

    1.type netsh winsock reset and hit enter....nevermind if it sai
    something about an erro
    2.type netsh int ip reset and hit enter...
    3. restart you computer...and the error should be gone and the interne
    workin

    what you just did was a TCP/IP stack repai
     
    sharkymatei, Dec 4, 2008
    #18
  19. Tony K

    Fuego Allure Guest

    Sharkymatei, you are a great individual. I rely on threads like these, and awesome people like yourself. I lack computer education. Thank You for being who you are, and to all of you out there, who help people like me out with great advise, its incredible to have your existence on this planet. Thanks Again.
     
    Fuego Allure, Dec 8, 2008
    #19
  20. Tony K

    Gordon Guest


    Posted and mailed

    To whom are you talking and about what?
    The "forum" that you are posting in leaches off the Microsoft News servers
    in order to make it look far busier than it really is. Everyone who uses the
    MS News servers sees your post on it's own - we have NO IDEA what you are
    talking about and to whom you are talking.

    If you MUST continue to post in this "forum" then please at least quote the
    post you are replying to, and do NOT change the subject line.

    You would be far better off however, using a news reader and subscribing to
    these news groups direct.

    Setting up Outlook Express/Windows Mail to access Microsoft newsgroups
    http://www.michaelstevenstech.com/outlookexpressnewreader.htm

    Accessing the MS newsgroups in Outlook Express/Windows Mail Newsreader
    http://www.microsoft.com/windowsxp/expertzone/newsgroupsetup.mspx


    Thank you
     
    Gordon, Dec 8, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.