HELP! I Can't install IE7

Discussion in 'Internet Explorer' started by Chinese Boy, Feb 1, 2006.

  1. Chinese Boy

    PDailey Guest

    There seems to be two common problems with IE7B2 installation. First many
    people get the error about msfeeds.dll. The registry permissions change for
    ..tif and .tff fix this problems but I now get the same error you get. I have
    shut eveything down, NAV, firewall, etc but get the same error each time. It
    installed clean on my home machine on XP Home, but my work machine running XP
    Pro cannon seem to handle it.
    ie7bet2p.log entry

    CabinetBuild complete
    11.056: Num Ticks for Cabinet build : 40
    11.056: DynamicStrings section not defined or empty.
    11.106: FileInUse:: Detection disabled.
    11.106: LoadFileQueues: UpdSpGetSourceFileLocation for halacpi.dll failed:
    0xe0000102
    14.030: Num Ticks for Backup : 2974
    14.151: ArchiveRegistrySettings: ArchiveRegistryNode failed
    14.151: DoInstallation: ArchiveRegistrySettings failed
    16.694: DeRegistering the Uninstall Program -> ie7bet2p, 2
    16.694: Internet Explorer 7 Setup canceled.
    16.694: Update.exe extended error code = 0xf00d
     
    PDailey, Feb 7, 2006
    #21
    1. Advertisements

  2. Chinese Boy

    Jim Guest

    I had the same issue as everyone else seemed to have, but was able to
    successfully resolve it by setting the permissions on certain keys in the
    registry.

    There is a file in your system folder called "updspapi.log".

    In this file I found multiple Error 5: Access Denied entires for keys in the
    registry.

    I had to reboot my machine four different times. Basically, each time I
    tried to install, it came up with a new error. That's when I made the change
    in the registry. I then rebooted my machine and try the install again. If
    it still did not succeed, I would check the "updspapi.log" file for the next
    error and change the permissions on the next registry key.

    Mine were .tif, .tiff .hta and htafile. These are all found in the
    HKEY_CLASSES_ROOT folder in the registry.

    I had to right click on them and change the permissions to Full Access for
    the Administrator group. It also helped that I was logged in as a user from
    the administrator group.

    I have seen multiple different keys from various people so don't count on
    someone else's explanation. You must see which keys are giving YOU the issue
    and change the permissions for ONLY those keys.

    It seems as if those keys need Full Access for the Administrator group
    because they are adding entries to those keys.

    Hopefully a Microsoft rep will see this post and confirm what I am saying.
    It would be nice if the IE Blog would be updated as well since the keys that
    are listed there are not the same for everyone else's situation.

    Good luck!
    Jim
     
    Jim, Feb 7, 2006
    #22
    1. Advertisements

  3. Chinese Boy

    Jim Guest

    Sandi,

    The post you referred to is fine, but there may be more to it than just the
    ..tif and .tiff keys.

    I was also required to change the permissions on my .hta and htafile keys.
    Other people were required to change other keys different than mine.

    The trick is to look at the "updspapi.log" file and check which keys are
    giving the error. Each time you change the key, you must reboot the system
    and try the install again. If you still cannot install, check that same file
    again for the next Error 5: Access Denied message which will tell you the
    next key that needs to have the permissions changed. Then reboot and try
    again until IE 7 finally installs completely.

    It is strange that different people have to change different keys, but the
    ..tif and .tiff are usually the least set of keys which need permission
    changes. If those two are changed and you still cannot install, the
    "updspapi.log" should tell you what the next error and key is that needs to
    be changed.

    Good luck!
    Jim
     
    Jim, Feb 7, 2006
    #23
  4. Chinese Boy

    Artsr3 Guest

    When trying to install I get the following log error;

    ZoneAlarm Logging Client v6.1.737.000
    Windows XP-5.1.2600-Service Pack 2-SP
    type,date,time,source,destination,transport (Security)
    type,date,time,virus name,file name,mode,e-mail id (Anti-Virus)
    type,date,time,source,destination,action,service (IM Security)
    type,date,time,source,destination,program,action (Malicious Code Protection)
    type,date,time,action,product,file,event,subevent,class,data,data,...
    (OSFirewall)
    type,date,time,name,type,mode (Anti-Spyware)
    OSFW,2006/02/07,20:47:22 -5:00 GMT,UNKNOWN(0),Microsoft Windows Malicious
    Software Removal
    Tool,C:\WINDOWS\system32\MRT.exe,PROCESS,OPENPROCESS,SRC,\SystemRoot\System32\smss.exe
    OSFW,2006/02/07,20:52:38 -5:00 GMT,UNKNOWN(0),Windows Service Pack
    Uninstall,C:\WINDOWS\$NtUninstallie7bet2p$\spuninst\spuninst.exe,PROCESS,SPAWNPROCESS,SRC,C:\WINDOWS\system32\rundll32.exe,da285490-bbd8a1d0-ce662357-7d5ba1ff,ff,45093
     
    Artsr3, Feb 8, 2006
    #24
  5. Chinese Boy

    Jim Guest

    In your case, I would try disabling ZoneAlarm during your install and see if
    you still get errors.
     
    Jim, Feb 8, 2006
    #25
  6. Chinese Boy

    PDailey Guest

    The reboot in safe mode method did not work. Thanks for the pointer to the
    updspapi.log file. I found that I need to alter the .hta as well as the .tif
    and .tiff keys.
     
    PDailey, Feb 8, 2006
    #26
  7. Chinese Boy

    PDailey Guest

    No joy. I changed the .tif, .tiff, and the .hta permissions that were
    indicated in the log file, but I get the same problem. The install says it
    cannot complete. The ie7bet2.log entry is the same, but now the updspapi.log
    has no new updates.

    LoadFileQueues: UpdSpGetSourceFileLocation for halacpi.dll failed: 0xe0000102
    16.614: Num Ticks for Backup : 2874
    16.734: ArchiveRegistrySettings: ArchiveRegistryNode failed
    16.734: DoInstallation: ArchiveRegistrySettings failed
    19.118: DeRegistering the Uninstall Program -> ie7bet2p, 2
    19.118: Internet Explorer 7 Setup canceled.
    19.118: Update.exe extended error code = 0xf00d
     
    PDailey, Feb 8, 2006
    #27
  8. Chinese Boy

    Jim Guest

    Ok. Let's be sure we're on the same page so I don't give you unnecessary
    advice.

    After you made these changes, did you reboot your machine and try the
    install again? If not, the install will not work. Rebooting the machine
    will allow the changes you made to the registry to become effective.

    If you have rebooted and tried installing again, check to make sure there
    are no other Error 5 or Access Denied errors in the updspapi.log file.

    I had an error on the key htafile. There was no "." in front of htafile
    which threw me off at first, but I found the key and made the change. Be
    sure to check that you don't have a similar situation happening with that key
    or any other key in the log file.

    If it still doesn't work, please copy and paste the log file contents in a
    reply and I will look through it to try and help out.

    I am no expert, but I will do my best to help you.

    Thanks.
     
    Jim, Feb 8, 2006
    #28
  9. Chinese Boy

    Artsr3 Guest

    Disabled ZA, Nortons Antivirus, and averything in the task bar. Same
    error/problem seem to be hard wired, even after pwr down re-boot.

    art
     
    Artsr3, Feb 8, 2006
    #29
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.