Help with error message: DFS root NOT found in local node...

Discussion in 'Clustering' started by Paulaner, Feb 14, 2007.

  1. Paulaner

    Paulaner Guest

    I have a legacy application installed on a Windows 2003 Server 2003 R2
    Enterprise Edition. I am running into issues with the required File
    Share resources on this machine. The shares are supposed to look
    similar to this:

    ShareName Path
    TOP d:\top
    ONE d:\top\one
    TWO d:\top\two

    I have created all the shares in cluster administrator, verified
    permissions, set dependencies (drive d: & clustername) and put them
    all in the same group.

    The problem occurs when I reboot a server. After that, I get an error
    message in the cluster logs like this:

    File Share <TOP>: SmbpHandleDfsRoot: DFS root TOP NOT found in local

    I really didn't intend for TOP to be a DFS directory, but it seems
    that the cluster is treating it as such. So, I tried setting TOP to
    a "Dfs root" in Advanced File Share Properties (as described in
    Q301588). This seems to solve the problem for TOP, but now I cannot
    create the shares for ONE and TWO because these are subdirectories of

    Any suggestions? I just want to make some file shares on my
    Paulaner, Feb 14, 2007
    1. Advertisements

  2. Paulaner

    Paulaner Guest

    Ok, here's the workaround, but I don't understand why a simple server
    configuration requires a registry hack. We are only trying to share a
    few directories on a clustered server. There are not a lot of files
    on this new system.

    The system event log reports:
    Event 1055 Cluster File Share resource 'ONE' has failed a status
    check. The error code is 1130.
    Event 2011 The server's configuration parameter "irpstacksize" is too
    small for the server to use a local device. Please increase the value
    of this parameter.

    So, following the MS recommendations for EVENT_SRV_IRP_STACK_SIZE we
    created the following registry key:
    and set the value to 32 on both nodes.

    Has anyone else had to do this? Anyone have a good explanation why
    the default values of 15 were not adequate?
    Paulaner, Feb 14, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.