Help with Restore point creation

Discussion in 'Windows Vista Performance' started by William Beard, Apr 1, 2007.

  1. I have the Vista Home Premium. When I go to the "Control Panel...System and
    Maintenance...System" and click on the "System protection" Task, at the
    bottom of the System Protection window it says "Restore point creation
    disabled by Group Policy."

    What do I do to fix this? Vista recoveries seems to be based on
    automatically creating Restore points...Thanks.
     
    William Beard, Apr 1, 2007
    #1
    1. Advertisements

  2. Are you a home user with a single computer? Or are you working in a business
    that has IT administration?
     
    Jill Zoeller [MSFT], Apr 2, 2007
    #2
    1. Advertisements

  3. Jill, as you say, I am a home user. I teach English overseas. I have a
    stand alone Dual Core ACPl x86-based PC running the Vista Home Premium OS.
    I am behind a router to a DSL or Broadband Internet connection (being
    overseas I'm not sure which). If you need further clarification, I'll be
    happy to reply.

    The system restore function has never functioned correctly from the first
    day I got the computer (it's new just like the OS). When attempting a
    System Restore, it kept telling me that there must have been a power
    interruption (or such). When I found the System Protection tab, everything
    looked fine until the window stops searching for the computer's drives, then
    the System Protection tab changes to say the "Group Policy" will not allow
    me to create a System Backup and of course the HP version of Vista won't let
    me look at the Group Policy even with a gpedit.msc file. Hope that helps
    with your diagnostics, Jill. I need your help very much.
     
    William Beard, Apr 3, 2007
    #3
  4. I just wanted to make sure that your computer isn't part of a domain where
    System Restore is disabled via group policy. :)

    OK, can you give me the exact wording of the error you get about the power
    interruption? Is there also an error code? Are you connected to a UPS
    (uninterruptible power supply) by chance?

    Finally, here is the registry location of the System Restore group policy
    setting. Can you check whether this key is present? (Also, if you need
    instructions on accessing the regsitry, let me know).


    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows
    NT\SystemRestore\DisableSR

    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Want to learn more about Windows file and storage technologies? Visit our
    team blog at http://blogs.technet.com/filecab/default.aspx.
     
    Jill Zoeller [MSFT], Apr 3, 2007
    #4
  5. Jill,
    NO such listing. But, there is a ...

    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows
    NT\SystemRestore\DisableConfig REG_DWORD 0

    There is also a ...
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceInstall\Settings\DisableSystemRestore
    REG_DWORD 0

    If that helps.

    No, on the UPS.

    As for the exact wording, I'll have to get back to you on that.
    I have my computer doing something now and I can't interrupt it and shutdown
    to get you your exact wording in the System Restore.
     
    William Beard, Apr 3, 2007
    #5
  6. Jill,

    The message details you wanted are these:

    System Restore failed due to an unspecified error. Transaction support
    within the specific file system resource manager is not started or was
    shutdown due to an error (0x80071A91).

    There was some other verbiage, but this is the meat of the error report.
    This is not the same verbiage I got before, because I probably changed the
    status of a service or something in the interim. I would have to remove and
    reinstall Vista to put it back to where it was. I'm will to do that, if you
    say so. That was what I would have done back in the days before Microsoft
    started counting the number of times you reloaded Windows. It was real fun
    back then. Feeding thirty for forty disks into the A: drive to get Windows
    back up. What fun!
     
    William Beard, Apr 4, 2007
    #6
  7. William, it sounds like you've got a number of problems going on here. I
    could collect some logs from you and ask the System Restore team for
    troubleshooting advice, but this could take some time. If doing a clean
    install is an option, you might want to consider this. I've seen a couple
    customers report some really obscure errors like this and reinstalling fixed
    the problem for them. This of course wouldn't help us find the root cause,
    but it sounds like you've done some uninstalling of AV tools and the like
    and I wonder if your computer is just in an unstable state right now.


    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    Want to learn more about Windows file and storage technologies? Visit our
    team blog at http://blogs.technet.com/filecab/default.aspx.
     
    Jill Zoeller [MSFT], Apr 4, 2007
    #7
  8. Jill,

    Unstable is a good word for it. OK, on your advise, I'll start over. I
    just hope Microsoft doesn't freak-out. They don't seem to understand about
    users starting over. They tend to think you're trying to cheat them. I'll
    see you on the flipside and let you know if it worked. This may take a
    couple of days. Thanks for working with me. Later, later..
     
    William Beard, Apr 5, 2007
    #8
  9. OK Jill...

    It's done. I reinstalled Vista. In fact, the drive had been partitioned
    (by the seller) so I removed the partition to insure a new clean drive C:.
    The problem with the Group Policy is GONE. I can and did do a system
    restore from a CD boot.

    One problem, though!
    I created three restore points myself, not counting the points the system
    created. They all reported as successful completion. When the Window
    opened to select the point to restore from, there were only four (4) points
    listed. Both, from the selection from the System properties window, and
    from the CD (reboot), only four choices were available.

    I just now created a new point then checked the System properties and it
    showed the new point in the queue and the count was five. I think that upon
    rebooting (or shutting down), the system only keeps four of the latest
    points and at least does not SHOW any others (I don't know if the system
    actually deletes them or just doesn't show them.) even though there is room
    in the window listing for maybe a dozen point to be displayed. I do not
    know what the criteria is, but I have Vista a 232 (usable) GB Hard Drive.
    I'm sure there is room for more than four or five restore points. In fact,
    if nothing else, the system should have kept my original system point. So,
    if need be, I could have returned the system files to their original
    condition. Thereby, eliminating the need to reinstall in order to get the
    system files back to their starting point.

    Firstly, there should be space reserved for system backups just as the MFT
    has non-movable continuous reserved disk space, so to should the system
    backups have the same consideration. As for the size, it can be a
    percentage of the disk space available (even user adjustable).

    Secondly, if the queue for the points are restricted to four (for whatever
    reason), then it would be a relatively simple programming job to keep the
    first point and cycle the next three points.

    Jill, I think this is an important point for all users who doesn't want to,
    at some point, have to buy a new copy of Vista just because Microsoft put a
    cap on reinstalls.

    Lastly, if you would like me to post any of the Event Logs error that are
    reoccurring, let me know. Oh, and by the way, I have NAV reinstalled and it
    does not affect the system restore point function at all.
     
    William Beard, Apr 5, 2007
    #9
  10. William, glad to hear the reinstall worked for you. I hate to recommend
    that, but in your case that's what I would've done myself.

    You ask good questions about restore points. We've written up how this works
    in our blog at
    http://blogs.technet.com/filecab/ar...used-for-restore-points-in-windows-vista.aspx
    (sorry for the long URL). This will tell you how to see how many restore
    points you have, how much space they use, etc.

    Are you using Ultimate version? If so, you could take a Complete PC Backup
    of your newly configured computer and save it on DVD. This is a kind of
    "point in time" image of your computer. Note that you could also save this
    to hard disk, but we use incrementals for all but the newest image, so
    eventually your very first Complete PC Backup will be purged as the restore
    points age. See the above article for more info.
     
    Jill Zoeller [MSFT], Apr 5, 2007
    #10
  11. No, Jill. I have Home Premium. But I'll checkout your blogs.
    Thanks again for the advise.
     
    William Beard, Apr 6, 2007
    #11
  12. For anyone reading this chain and went to the referenced blog
    http://blogs.technet.com/filecab/ar...used-for-restore-points-in-windows-vista.aspx,
    you found a reference to an "elevated command prompt". If this phrase was
    new to you as it was to me, this is not accessed from the "Run..." Start
    menu link. If you are running in the Classic mode, then, from the Start
    button, the path is Programs...Accessories...Command Prompt. With the
    cursor over the Command Prompt link, press the right mouse button and use
    the "Run as administrator" function or else the command you enter will tell
    you that you do not have permission (Yea, Microsoft). -----Has anyone
    noticed that the Help and Support function is more of a "What is" rather
    than a "How to"!

    Jill, if your still with me, I ran your "vssadmin list shadowstorage".
    Mine basically said, Used 5 GB, Allocated space 6 GB, and Max space 35 GB.
    I can see that the 35 GB is the 15% you mentioned. But, only 6 GB is
    Allocated? Microsoft keeps the system backup a "Microsoft thing", but only
    allocates 6 GB for it?

    A funny anecdote: Long, long ago, in a land far, far away...back in the
    days when hard drives were 10 and 20 MB (YES, Mega), I had bought a 60 MB
    and everyone told me, "You'll never use all THAT space!"

    I don't suppose the "shadowstorage" area is Administrator adjustable (I mean
    on the HP model). I know, dumb question. I'm just a stupid user.

    By-the-by, thanks for the feedback on the "good questions". But, as a
    former boss of mine used to tell me, "That will never happen, because it
    makes to much sense".

    Keep smiling...it makes them worry!
     
    William Beard, Apr 6, 2007
    #12
  13. William Beard

    Rock Guest

    William, I'm glad you hung in there and got things resolved.
     
    Rock, Apr 6, 2007
    #13
  14. Hi Jill, Rock...
    I found a Vista supported BeLarc Advisor online.
    http://belarc.com/free_download.html
    It told me a lot about my computer and the software in it.
    It even told my about thirteen patches from MS that I was missing.
    When I shutdown, the patches were there to be installed during the shutdown
    process.
    I found that a little odd, but neither NAV, the Defender, or the Vista
    security complained.
    Check it out...it's FREE.
     
    William Beard, Apr 6, 2007
    #14
  15. William,

    We only allocate as much space as is needed, up to the maximum. The
    allocation is done in chunks, so it's always a bit more than what is
    actually used. By doing this allocation on demand, you don't have to
    permanently give up that 35 GB.

    The shadow storage space is adjustable using the vssadmin resize
    shadowstorage command. I've seen cases where the new setting doesn't stick,
    though. You could give this a try if you'd like, but there is probably no
    need since you are well under the maximum.

    Sorry about the elevated command prompt confusion--I should've been more
    explicit about that in the article.
     
    Jill Zoeller [MSFT], Apr 6, 2007
    #15
  16. William Beard

    Rock Guest

    Thanks, I have used Belarc in XP, just haven't gotten around to it in Vista
    yet. I will give it a go. Interesting what you pointed out about updates.
     
    Rock, Apr 7, 2007
    #16
  17. William Beard

    Baz Guest

    This 'Restore point creation disabled by Group Policy' issue has only just
    been noticed on my computer. I've had no problem in the past doing a manual
    Restore Point (usually prior to any new software installation - and nothing
    much recently) but today I discovered I don't have access to highlighting the
    C: Drive and the above quote is next to 'Create'.

    Before coming to this site I tried rolling back my computer a week and still
    nothing - so either its firmly embedded or was an issue earlier. Can't help
    feel its something in a Windows Update (or, perhaps, a Firefox update) that
    has buggered things up.

    As above with William, I am sole user, the Administrator, on a stand alone
    computer - and again, until not too long ago, manual System Restore Points
    were not a problem.

    Bigger concern is that if Group Policy is set on this (without my input)
    what other programs are going to fail to work as I've been 'locked out' of
    control? No way MS can advise home Administrators on how to control Group
    Policy?

    A complete reinstall (First Refuge of Confused Techs Everywhere) is hardly a
    solution.....

    Real solution anyone?
     
    Baz, Jun 3, 2007
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.