Hidden folder not showing in Vista Home Premium

Discussion in 'Windows Vista General Discussion' started by Shocky, Sep 15, 2008.

  1. Shocky

    Shocky Guest

    Hi there,
    I had marked one of my folders (G:/Personal) as hidden sometime back.
    Now, when i want to see the hidden folder, i am not able to do so,
    even after doing the following.
    1) Went to Folder Options--> View
    2) Checked the "Show hidden files and folders" option.
    3) Press "Apply" then "Ok"

    But the folder does not appear at all.
    The strange part is : after doing the above when i again open the
    Folder Options dialog box, i see that the "Do not show hidden files
    and folders" option is checked on its own.


    After reading up on the net, i also tried after unchecking the "Hide
    protected operating system files (Recommended)" option.

    Not that, i think it should have anything to do with a user created
    hidden folder... but still.. tried it out.
    That does not work either.

    Please help me resolve this.

    Thanks a lot.
     
    Shocky, Sep 15, 2008
    #1
    1. Advertisements

  2. Shocky

    Jon Guest

    I hate to break the 'shocky-ing' news but it sounds like it's been deleted.
     
    Jon, Sep 15, 2008
    #2
    1. Advertisements

  3. Shocky

    Shocky Guest

    :) no sir jon
    Its not been deleted..
    i removed the hidden attribute using command prompt "attrib -h"
    command .. and the folder appears!!!

    The problem here again is.. in this folder.. i have many sub folders
    and sub sub folders whose names i may not know..
    so doing the same for all these sub folders using command prompt
    attrib -h command seems too far fetched..
    (using attrib -h command with the wildcard "*" works only for files,
    not for sub folders)

    Any clues??
     
    Shocky, Sep 15, 2008
    #3
  4. Shocky

    Shocky Guest

    ... and how does one explain the behaviour that when i open the Folder
    Options dialog box again (after checking the "Show hidden files and
    Folders" option), the changes are reverted back.. i.e. i see that the
    "Do not show.." option is checked again???

    Any clues?
     
    Shocky, Sep 15, 2008
    #4
  5. Shocky

    Jon Guest

    Cool. I'm glad you proved me wrong and your files survived!

    You can use '/s' with the attrib command also to process subfolders as well
    in one fail swoop ie so that you don't have to type the command for each
    folder.

    Also via explorer you could right-click the top level folder > Properties >
    Uncheck the 'hidden' attribute. You may get the option to apply it to all
    subfolders at the same time. Worth a try.

    --
    Jon


    :) no sir jon
    Its not been deleted..
    i removed the hidden attribute using command prompt "attrib -h"
    command .. and the folder appears!!!

    The problem here again is.. in this folder.. i have many sub folders
    and sub sub folders whose names i may not know..
    so doing the same for all these sub folders using command prompt
    attrib -h command seems too far fetched..
    (using attrib -h command with the wildcard "*" works only for files,
    not for sub folders)

    Any clues??
     
    Jon, Sep 15, 2008
    #5
  6. Shocky

    Jon Guest

    Yeah, that's an odd one. Not sure what would cause that, other than a piece
    of malware on your system. Might be worth doing a virus scan.

    --
    Jon


    ... and how does one explain the behaviour that when i open the Folder
    Options dialog box again (after checking the "Show hidden files and
    Folders" option), the changes are reverted back.. i.e. i see that the
    "Do not show.." option is checked again???

    Any clues?
     
    Jon, Sep 15, 2008
    #6
  7. Shocky

    Jon Guest


    Also attrib has a '/D' option to process folders as well
     
    Jon, Sep 15, 2008
    #7
  8. Shocky

    Shocky Guest

    Thnks Jon..

    did not know about the /D switch...
    i guessed too tht it could be some malware restricting hidden folders/
    files from being shown.
    had run a virus scan recently and it had come out clean.. but u never
    know.

    Thanks anyways for the replies.
     
    Shocky, Sep 15, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.