Hl2.exe has stopped working, cod2_mp has stopped working

Discussion in 'Windows Vista Games' started by Healthy, Oct 13, 2007.

  1. Healthy

    Healthy Guest

    There seems to be a problem with any online multiplayer game on my new Vista
    PC.
    Both Counter Strike and Call of Duty 2 give a similar response when each
    fail to start up. Half Life 2 Deathmatch does this aswell. I tried patching
    and using compatibility mode with CoD 2 which worked for a couple days, but
    that doesn't explain why Counter Strike: Source began to act up. Supposedly
    it functions fine for Vista and it did until recently. Furthermore, I turned
    my firewall off and re-added the programs to the exceptions list. None of
    these have worked. Is there something I can do?

    If you can help it would be greatly appreciated. Also, it is most likely not
    to have anything to do with my hardware.

    E6600 2.4 Ghz Dual core Processor
    2gb of RAM
    8800GTX Video Card
    Windows Vista
     
    Healthy, Oct 13, 2007
    #1
    1. Advertisements

  2. Healthy

    Frenchy Guest

    Do you have the latest NVIDIA drivers for your card?? (I think 163.69, or
    that's what I have with identical card and the games work fine, including
    COD2).

    If you do have that driver, try a newer Beta version (create a restore point
    to go back to, in case it doesn't work).

    What about sound drivers? Do you have Realtek sound icon in the tray? They
    keep coming out with updated drivers.

    Frenchy
     
    Frenchy, Oct 13, 2007
    #2
    1. Advertisements

  3. Healthy

    healthy Guest

    I used the beta drivers and it fixed Call of Duty 2, but i still get the same response from Counter-Strike: Source. Thanks Frenchy!

    Please post if you have a solution to my other problem though.

    As for the drivers, I don't believe i have Realtek. I believe i have Sigmatel. If that makes a difference.

    EggHeadCafe - .NET Developer Portal of Choice
    http://www.eggheadcafe.com
     
    healthy, Oct 15, 2007
    #3
  4. Healthy

    Andy [YaYa] Guest

    I've been getting HL2.exe has stopped responding messages when playing
    orange box (portal, hl2:2, and tf2), but I just close the program and run it
    again and it works.

    Audio card shouldn't matter too much, most integrated audio cards work good
    with Vista (It's creative labs sound blasters that are having driver
    issues), but still you might check to see if there's a driver update
    available online for your sound card, motherboard chipset and motherboard
    BIOS, the last one (the bios) probably is not the problem, and be careful
    when you upgrade the BIOS, if you mess up you'll kill your motherboard. (in
    other words, don't do it unless you know what you're doing)

    CS:S is pretty much Vista ready, you should not have to change your firewall
    settings or add the program to any exceptions lists, might see if there's
    anything posted on the valve forums, check their support site too.

    Good luck,
    A.
     
    Andy [YaYa], Oct 15, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.