How can I uncheck the "Always ask before opening this type of file"

Discussion in 'Windows Vista Security' started by Tom, Jan 13, 2007.

  1. Tom

    Tom Guest

    How can I enable the checkbox (so I can remove the checkmark) next to
    "Always ask before opening this type of file" that Outlook 2007 prompts when
    clicking on an attachment? I'd like to enable the opening of .doc files,
    etc. to happen without the prompt.

    I'm running Outlook 2007 to an Exchange Server.
     
    Tom, Jan 13, 2007
    #1
    1. Advertisements

  2. Tom

    Jesper Guest

    You really do not want to do this. Exploits are still borne by doc files,
    although they are usually not macro viruses any more. Outlook prompts you,
    lest you accidentally open a file you did not intend to open.

    If you are absolutely dead set against protecting yourself from one of the
    most serious threats of our age, one increasingly used by criminal
    syndicates, then you can do the following:
    Open a Windows Explorer window
    Hit the Alt key and select the Tools menu
    Select folder options
    Select the File Types tab
    Scroll down to DOC files and select it
    Click Advanced
    Uncheck the "Confirm open after download" box and click OK to close all the
    dialogs.
     
    Jesper, Jan 13, 2007
    #2
    1. Advertisements

  3. Tom

    Tom Guest

    Jeeper:

    1. I agree attachments are a big risk. I trust myself (and most any other
    user who is technically saavy enough to be reading this group) not to double
    click on a file that is from someone suspect. However, since 99.9% of the
    ..doc files many of receive are from colleagues, and since we're just going
    to race past the pop-up warning anyway, and since "accidentally" clicking on
    a .doc file is unlikely, the warning is just a nuisance, IMO. Thanks for
    your warning though.

    2. That being said, I had googled up your answer to use the File Types tab
    in the Windows Explorer before I posted. But, there is no such tab visible
    on my machine. (The only tabs visible are Geneal, View, and Search) In
    Vista, I thought File Assocations were only done in the Control Panel. Does
    your copy of Vista RTM show a File Types tab?

    Thanks!
     
    Tom, Jan 13, 2007
    #3
  4. Tom

    Jesper Guest

    You misunderstand. This dialog stops documents from automatically opening
    when you are doing something that you had no idea would open a document, like
    going to a web page. A web page can redirect you to another web page, which
    automatically opens a document, that exploits one of the recent or
    forthcoming Word vulnerabilities. You would get NO warning that this was
    happening if you uncheck that box.

    And, my directions were wrong. They were for XP (typed from memory). That
    setting has been moved to the Default Programs control panel. Click on Set
    Association, and you get the same dialog you're used to from six prior
    versions of Windows.
     
    Jesper, Jan 14, 2007
    #4
  5. Tom

    Tom Guest

    Thanks for the clarification, Jesper. I agree that when surfing the web,
    this protection is important.


    Does the option you describe (if I can find it!) control whether Outlook
    2007 pops up a dialog when I click on an attached file. THAT'S the place
    that's bothering me. I've found that in previous versions of outlook there
    were registry variables that controlled this, but apparently not with
    Vista's increased security.
     
    Tom, Jan 14, 2007
    #5
  6. Tom

    Tom Guest

    <Accidentally hit <Send> before completing my previous response.

    I can't find an Advanced tab or any way to set a "Confirm after download"
    option on the default programs control panel applet.
     
    Tom, Jan 14, 2007
    #6
  7. Tom

    Jesper Guest

    Grumble. Grumble. <moronic UX designers> Grumble. <changing dialogs that have
    stayed the same for 12 years> Grumble.

    I can't find it either. Don't know where they put it. If you can't find the
    UI, let's go to the registry.
    Save this to a .reg file:
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.8]
    @="Microsoft Word Document"
    "EditFlags"=dword:00010000

    When you import that it will configure the warning to go away. If you want
    it back, import this .reg file:
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.8]
    @="Microsoft Word Document"
    "EditFlags"=dword:00000000

    This works for .DOC files only. It will do nothing for .DOX (Word 2007)
    files. Sorry, but I don't have any of those to test with and I thought after
    making assumptions about how things worked twice, and being wrong both times,
    I'd better limit my recommendation to what I could test.
     
    Jesper, Jan 14, 2007
    #7
  8. Tom

    Tom Guest

    Thanks, Jesper. I'll try your registry solution.

    Of course, I've got other file types that I want to do this on and, frankly,
    I'd rather not use the registry on them.

    I'm SURE there's a way in Vista to enable my being able to uncheck "Always
    ask before opening this type of file"

    Do you have any suggestions on other newsgroups or sources of on-line
    assistance on this kind of thing?

    Thanks again for your having stuck with me through our handful of exchanges!

    Tom
     
    Tom, Jan 15, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.