How do I get automatic Windows updates if that feature is greyed out in Automatic Updates in System

Discussion in 'Windows Update' started by Guest, Aug 21, 2008.

  1. Guest

    Guest Guest

    My office computer(XP, SP3) is of course part of a network.

    Through mid-June, it always received Windows updates, which I would
    then mostly approve for installation (like 98% of them).

    This week I noticed that the June 13 or whatever the date was update
    was the last series I'd had. So I went to Windows Update and
    downloaded (guessing) 20 updates in three different stages, with
    reboots necessary after each stage.

    I cannot reset my computer for automatic updates. Those settings are
    greyed out in the Automatic Updates tab of the system properties. And
    whether I use Windows Update or Microsoft Update, I don't have an
    option shown to select any flavor of automatic updates.

    I'm geek enough that I don't mind just checking for updates manually
    (a process made kind of easy by the fact that my home XP computers all
    get automatic updates that I manually install, reminding me to do it
    at work). But I'd love to know how to restore the auotmatic update
    download/reminder system I had previously.

    http://www.kellys-korner-xp.com/regs_edits/updaterestore.reg and other
    references suggest some registry tweaks to try to alleviate this, but
    none have worked.
     
    Guest, Aug 21, 2008
    #1
    1. Advertisements

  2. Guest

    TaurArian Guest

    1. Check the Service Manager for "Automatic Update" service
    Click Start, select Run and type: Services.msc
    Press Enter
    Locate the - "Automatic Update"
    Make sure the service is not disabled and started.

    2. If the service is disabled and cannot be started:

    Go to START, Select RUN
    Type: regsvr32 wuaueng.dll
    Press Ok

    3. If all else fails:-

    Automatic Updates options are grayed out?:
    http://windowsxp.mvps.org/aupolicy.htm
     
    TaurArian, Aug 21, 2008
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    This did it for me. Everything on the computer was as it should have
    been, except for

    HKEY_LOCAL_MACHINE \ SOFTWARE \ Policies \ Microsoft \ Windows \
    WindowsUpdate \ AU

    * In the right-pane, delete the two values AUOptions and
    NoAutoUpdate

    When I deleted those two values, I could again set an automatic update
    preference and everything worked fine. Didn't even need to reboot.

    Thanks.
     
    Guest, Aug 22, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.