how to connect to share on server as anonymous user (this works onwinXP, but having trouble on serve

Discussion in 'Windows Small Business Server' started by ms support, Oct 6, 2006.

  1. ms support

    ms support Guest

    hello,
    I have to make an application from a unix server connect to a shared
    folder on a windows server. I tried this as a test on a windowsXP box
    and it works. It lets me connect to a shared folder with permissions
    for everyone with full control.

    Now, when I try it on the windows server, it rejects me.

    I've put the permissions on the share folder with anonymous having full
    control but it still rejects me from the unix box.

    What else can I do so I can connect to this share as anonymous user?

    Like I said, when connecting to a winXP box this works fine.


    Thanks,

    Oskar
     
    ms support, Oct 6, 2006
    #1
    1. Advertisements

  2. You'll need to grant the Everyone group appropriate permissions to the
    share and disable SMB Signing on the server.

    Here's one way to disable SMB Signing.
    http://simultaneouspancakes.com/Int/archive/2004/06/how_to_disable_1.shtml

    Chris Puckett, MCSE
    Microsoft Small Business Server Support


    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Chris Puckett [MSFT], Oct 6, 2006
    #2
    1. Advertisements

  3. ms support

    ms support Guest

    wow!!
    this looks like it might fix it.
    I'll try this and get back to the list.

    Thanks!!

    Oskar
     
    ms support, Oct 6, 2006
    #3
  4. ms support

    ms support Guest

    bad news!
    I still get access denied. What else can I try??
    I rebooted the server after disabling the smb signing via policy. I
    checked the registry settings and they also confirm smb signing is disabled.
     
    ms support, Oct 6, 2006
    #4
  5. ms support

    ms support Guest

    yes, the everyone account has 'full control'.
     
    ms support, Oct 7, 2006
    #5
  6. ms support

    ms support Guest

    how now, I've added a mapped drive the the shared folder on the winXP
    workstation. I've made the application run from the mapped drive going
    to the winXP workstation so the unix box can connect to the winXP shared
    folder.

    For now I give up on the problem, but i'd like to know how to resolve
    this for future reference. This isn't a proper way to resolve this problem.

    I've also posted to the samba newsgroup to see what they say. Usually
    unix/linux people are very technical and extremely aware of the inner
    workings of system protocols, ports, etc. May they know something I
    haven't thought of.

    The samba server connects to other systems just fine, from the windows
    boxes (winxp workstations or the server) you can connect to the solaris
    samba share perfectly.

    The problem is only from the samba server to the shared folder on the
    windows server.
     
    ms support, Oct 7, 2006
    #6
  7. Users will have to log off and back on to the domain to have their new
    permissions in effect, that has bitten me more than once. Not sure if that's
    your issue here, though.
     
    Les Connor [SBS Community Member - SBS MVP], Oct 7, 2006
    #7
  8. ms support

    ms support Guest

    I restarted samba and logged off/in again to the unix box.

    I also restarted the windows server after disabling the smb signing via
    policy (also confirmed it via registry).
     
    ms support, Oct 7, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.