How to ensure login script runs on client?

Discussion in 'Scripting' started by Richth, Apr 20, 2007.

  1. Richth

    Richth Guest

    Need help understanding what security setting prevents my client login
    scripts from running on WinXP SP2 workstations. When I run it manually I get
    a security window that warns it cannot determine if it should be run, and
    prompts me whether to allow it to run or not.

    What setting do I clear to allow my login scripts to run?
    TIA
    rich
     
    Richth, Apr 20, 2007
    #1
    1. Advertisements

  2. Richth

    Marty List Guest

    That's unusual, how did the file get copied to the domain controller? Maybe
    it was "downloaded" through IE and the security zone is stored in an
    alternate data stream?

    Try the freeware tool STREAMS.EXE:
    http://www.microsoft.com/technet/sysinternals/FileAndDisk/Streams.mspx

    To view the alternate data streams of a file:
    C:\>streams.exe \\server\share\scriptname.ext

    To delete the alternate data streams of a file:
    C:\>streams.exe -d \\server\share\scriptname.ext
     
    Marty List, Apr 20, 2007
    #2
    1. Advertisements

  3. Richth

    Richth Guest

    Not sure we're talking about the same thing, but thanks. I'll look into this.
     
    Richth, Apr 20, 2007
    #3
  4. Some virus software blocks scripts from running. Could the security message
    come from your virus software?

    When you say you manually run the script, I assume you run it at a command
    prompt, perhaps with the cscript host, and you get the security warning, not
    an error message (with a line number) from WSH. I know I had to modify a
    setting in Norton AntiVirus to allow VBScript programs to run. I can't
    remember the setting now.
     
    Richard Mueller [MVP], Apr 20, 2007
    #4
  5. Richth

    Marty List Guest

    When the security warning is displayed, open Task Manager and highlight the
    window in the Applications tab. Right-click the app and choose "Go To
    Process". This might help you determine where the security warning is
    coming from.
     
    Marty List, Apr 20, 2007
    #5
  6. Short version...
    Add the server/domain to your Internet Options -> Security tab -> Local
    Intranet -> sites.. -> advanced area..

    "Internet Explorer" --> "Tools" --> "Internet Options" --> "Security"
    tab --> "Local Intranet" --> "Sites" button --> "Advanced" --> add the
    server's domain name *.my.domain.com and OK your way out.

    This can also be done by group policy *if* everyone is on a domain.
     
    Shenan Stanley, Apr 20, 2007
    #6
  7. Richth

    Richth Guest

    Thanks Shenan and Richard,
    This is exactly along the lines of what I'm experiencing. It is a Windows
    Security dialog that displays with the prompt instead of my anti-virus
    software. I'm guessing this all changed when SP2 was installed as they
    worked prior to that. I'll try your suggestions and post results.

    I will need to do this for 30 clients, so knowing how to do this via group
    policy would be great. I'll look through the knowledge base. Thanks.

    Rich
     
    Richth, Apr 20, 2007
    #7
  8. Richth

    Richth Guest

    Shenan, thx, that solved the Security Warning dialog issue for when I run the
    script manually from Run cmd line.

    Now however, I still see that the login script is not getting executed when
    the user logs in. This is a separate issue, so I'll create a new thread for
    it. Thx again!

    Rich
     
    Richth, Apr 20, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.