How to revert a USB 1.1 port to USB 2.0 port.

Discussion in 'Windows Vista Hardware' started by satadru, Sep 10, 2008.

  1. satadru

    satadru Guest

    Dear All,

    I need your help. Following are the facts of the case in seriatim, to
    facilitate in easier understanding of the situation:

    1. You see I have Vista OS installed on my PC.

    2. My PC has 4 USB ports on the rear-side, which I know for sure are USB 2.0
    Hi-Speed Ports. Before facing this issue, I could connect any Hi-Speed USB
    device to any of these ports and have data transferred at high speed rates,
    normally.

    3. Yesterday, I had attached a cheap Chinese-make USB hub to one of those
    rear ports. The device installed itself quite normally and messages to the
    effect that drivers for the same had been installed, were given.

    4. Soon after I had removed the USB hub and had my 8GB pendrive attached to
    the same USB port, I was given a message which stated that "the device could
    perform better if I had connected to a higher speed port".

    5. Despite umpteen number of reboots, shutdowns, uninstalling of USB devices
    from the Device Manager, etc., all the 4 rear-side USB ports behave as if
    they are USB 1.1 type ports only.

    6. Incidentally, the Device Manager displays that there is an enhanced USB
    host controller.

    Please help as to how I could have them revert to their normal USB 2.0 format.

    Thanks in advance.
     
    satadru, Sep 10, 2008
    #1
    1. Advertisements

  2. Got a System Restore point that precedes the problem?

    If so, use it.
     
    Paul Montgomery, Sep 10, 2008
    #2
    1. Advertisements

  3. satadru

    J Guest

    Wednesday eve

    This happened to me a few months ago.

    Not sure exactly because all appeared to be working OK until I attached a
    thumb-drive to use for ready-boost.

    I have removed all of the usb instances from the device manager about once a
    week. No joy.

    And also:
    Advise please

    J
     
    J, Sep 11, 2008
    #3
  4. satadru

    satadru Guest

    Did not work at all. Any other suggestions please? I am left banging my head
    against the wall!
     
    satadru, Sep 11, 2008
    #4
  5. Delete the host controller(s) and restart.
     
    Paul Montgomery, Sep 11, 2008
    #5
  6. satadru

    satadru Guest

    Deleted, restarted, failed to work.
     
    satadru, Sep 11, 2008
    #6
  7. I'm fresh out of ideas.
     
    Paul Montgomery, Sep 11, 2008
    #7
  8. satadru

    satadru Guest

    I suppose the only other viable alternative would be to install a Hi-Speed
    USB PCI card, now. I think the mainboard may have given up on the USB 2.0
    feature, itself.
     
    satadru, Sep 11, 2008
    #8
  9. Speaking of which... have you checked the settings in the BIOS on the
    odd chance that something in there needs changing?
     
    Paul Montgomery, Sep 11, 2008
    #9
  10. satadru

    J Guest

    For me: I have also tried ALL of the suggestions.
    BIOS is correct.

    A number of articles found through google identify some problems with an win
    update in the spring.

    For me the problem started at the end of June, or so.

    The hub is identified as fast, but the connections are not.

    I have a printer, mouse, ready boost disk, and a couple of thumb-disks I use
    for utilities. When any are first connected the message about choosing a
    fast port is displayed.
     
    J, Sep 11, 2008
    #10
  11. satadru

    satadru Guest

    I have tried every which way with the BIOS settings. The main board of my PC
    is of Biostar-make with the latest in BIOS version installed.

    Besides trying out all the possible permutations and combinations of USB
    Fast/Low speeds and Hi-Speed options, I also invoked the "Optimized BIOS
    defaults". All without result.

    The only other option which still remains, is to have a USB 2.0 PCI card
    installed and hope that it works.
     
    satadru, Sep 12, 2008
    #11
  12. satadru

    satadru Guest

    UPDATES:
    1. Installed a USB 2.0 PCI card. Results remain the same. (I was really
    surprised to see this.)

    2. I normally use a Transcend 8GB flash drive. All the problems hovered
    around this flash drive. Just for controlled experimentation purposes, I took
    this flash drive to my office and had it connected to one of the Hi-Speed USB
    ports of my Dell PC. I was shocked to see that my office PC came out with the
    same message.

    3. I, therefore, concluded that the problem probably lay with the Transcend
    8GB flash drive. My doubts were further fortified when I inserted another 1
    GB Transcend flash drive onto my home PC and found that no such message was
    being reported and the transfer rates were really as fast as a Hi-Speed
    transmission ought to be.

    4. Over the weekend, I plan to do the following to narrow down the
    possibilities:
    (a) Install the recovery software from Transcend website and carry out
    recovery procedures on the Transcend 8GB flash drive.
    (b) Download the latest version of BIOS for my Biostar mainboard and install
    it.

    I will keep posting the developments as and when they happen per the above
    plans.

    Thanks in advance.
     
    satadru, Sep 13, 2008
    #12
  13. NICE GOING!!!
     
    Paul Montgomery, Sep 13, 2008
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.