How to set default keyboard layout in Welcome screen to English?

Discussion in 'Windows Vista General Discussion' started by Alek Davis, Sep 20, 2007.

  1. Alek Davis

    Alek Davis Guest

    When I configured Windows Vista Home Basic on a new laptop, I picked Russian
    regional setting (language, keyboard, etc) wrongly assuming that it would
    localize Vista. Now that I know that it would not work like this, I need to
    switch all settings back to English. I modified all regional settings leaving
    just English (US) keyboard layout, but when I power on the system, the
    default language in the Welcome screen is Russian (with RU showing in the
    corner). I can change it by clicking the RU button and selecting EN, but it's
    a hassle to do it every time I log in. Is there a way to set the default
    keyboard layout back to English? I don't quite understand why both languages
    show up even if the Russian keyboard is not installed. Thanks.
     
    Alek Davis, Sep 20, 2007
    #1
    1. Advertisements

  2. Alek Davis

    Saucy Guest


    Use Regional and Language settings to remove the Russian keyboard.

    Saucy
     
    Saucy, Sep 20, 2007
    #2
    1. Advertisements

  3. Alek Davis

    Alek Davis Guest

    Saucy,

    As I mentioned in the original post, I had already removed Russian keyboard
    (from Regional Settings), so after logging on, I do not see the keyboard
    switch or anything related to local languages. But for some reason, the
    default keyboard on the Welcome screen is set to Russian and I cannot figure
    out how to switch it back to English.

    Regards,
    Alek
     
    Alek Davis, Sep 20, 2007
    #3

  4. There is a setting somewhere on the Regional Settings tabs, to make the
    current settings the default for all users. Try that.

    ss.
     
    Synapse Syndrome, Sep 20, 2007
    #4
  5. Alek Davis

    Alek Davis Guest

    I spent almost an hour yesterday looking all over Regional Settings for
    something like this and I gave up. There is a a button which applies the
    currently defined settings to future accounts, but the documentation says
    that it does not apply to the already existing accounts. This makes sense
    assuming that the current settings are applied to the immediate account
    (under which I'm making changes). And they do, but only after logging in.
    What I can't figure out is how to make them take effect on the Welcome
    screen, i.e. before I log in.
     
    Alek Davis, Sep 20, 2007
    #5
  6. Alek Davis

    Saucy Guest


    Control Panel (classic view) > Regional and Language Settings > Keyboards
    and Languages tab > Change keyboards... button > the Text Services and Input
    Languages dialogue box pops up

    Is it set to Russian (Russia) with a only US keyboard listed underneath? Or
    describe what's listed?

    My default input language is set to English (Canada) -US , but I removed all
    the keyboards but the US keyboard so it looks like:

    EN English (Canada)
    -Keyboard
    -- - US

    -Other
    -- - Ink Correction

    Saucy
     
    Saucy, Sep 20, 2007
    #6
  7. Alek Davis

    Alek Davis Guest

    In the Default input languages, I see English (United States) - US; there is
    nothing else present in the drop-down list box. Under Installed services, I
    see just English (United States) - Keyboard - US. That's it.
     
    Alek Davis, Sep 21, 2007
    #7
  8. Alek Davis

    brink Guest

    Hi Alek,

    Check these settings in Regional and Language Options:

    1. Click the Administrative tab.
    2. Under "Language for non-Unicode programs", make sure that you have
    "English (United States)" selected.
    3. Under "Reserved accounts", click the "Copy to reserved accounts"
    button.
    A) Click Continue for UAC prompt.
    B) Check "System accounts....." and click OK.


    Shawn


    --
    brink

    *There are no dumb questions, just the people that do not ask them.*
    WWW.VISTAX64.COM (\"HTTP://WWW.VISTAX64.COM\")
    *Please post feedback to help others.*
     
    brink, Sep 21, 2007
    #8
  9. Alek Davis

    Alek Davis Guest

    Brink,

    I have already done this with the exception of System Accounts. Will try it
    for System Accounts when I get home. Thanks.

    Alek
     
    Alek Davis, Sep 21, 2007
    #9
  10. Alek Davis

    Alek Davis Guest

    Thank you, brink. The "System accounts" option did it. I had to click the
    "System accounts" button for the keyboard to take affect. I appreciate the
    help.

    Alek
     
    Alek Davis, Sep 25, 2007
    #10
  11. Alek Davis

    Saucy Guest

    Cool.

    Saucy
     
    Saucy, Sep 25, 2007
    #11
  12. Alek Davis

    brink Guest

    Your welcome Alek,

    Glad to hear that it helped. Thank you for the feedback.

    Shawn


    --
    brink

    *There are no dumb questions, just the people that do not ask them.*
    WWW.VISTAX64.COM (\"HTTP://WWW.VISTAX64.COM\")
    *Please post feedback to help others.*
     
    brink, Sep 25, 2007
    #12
  13. Alek Davis

    Nasho23 Guest

    Sorry to cut in on this Vista thread.
    Is there a similar fix for XP SP3.
    When I bootup, I get a Russian "Welcome" and when I shutdown the text is in
    Russian. All working screen text is now in English after changing it in
    Regional and Language Settings.
     
    Nasho23, Mar 22, 2010
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.