How to stop automatic search engine redirection from address bar?

Discussion in 'Internet Explorer' started by Malay Thakershi, Jan 28, 2007.

  1. Hello,

    I have a dell computer and when I type something in my address bar that
    doesn't resolve to a proper URL, it loads a page that has google embedded but
    the page is called dell home. Is there any way I can disable this? I would
    like the browser to give a message that the page was not found or it is
    invalid.

    Thank you,
    Malay
     
    Malay Thakershi, Jan 28, 2007
    #1
    1. Advertisements

  2. Malay Thakershi

    BillD Guest

    yes:

    When a website address cannot be found, Internet Explorer automatically
    searches the web to try to find that site by using your default search
    provider. Follow these steps to set your preferences for how this is done.

    In Internet Explorer, click the Tools button, and then click Internet
    Options.
    Click the Advanced tab.
    In the Settings list, scroll down until you find Search from the Address bar.
    Do one of the following:
    To view a list of likely matches in the main window so that you can choose
    which webpage to display, select Just display the results in the main window.
    To turn off searching from the Address bar, select Do not search from the
    Address bar.
    When you have made your selection, click OK.
     
    BillD, Jan 28, 2007
    #2
    1. Advertisements

  3. Sandi Hardmeier, Jan 28, 2007
    #3
  4. Hi,

    Does the redirect page look something like this?

    http://www.webmasterworld.com/rv4.c...ll/afe?hl=en&s=http://www.webmasterworld.com/

    With new Dell machines every typo in the Address bar, every DNS that does
    not resolve, every domain that doesn't load quickly enough redirects to
    google's sponsored links page, co-branded by dell with dell's product line
    on the top

    Gateway also has a deal with Google for a Branded redirect page that looks
    like this:
    http://www.webmasterworld.com/rv4.c...ay/afe?hl=en&s=http://www.webmasterworld.com/

    To remove this, go to the Control Panel ADD||Remove programs and look for a
    program called "GoogleAFE" and uninstall it.

    If that fails to remove it for any reason, use the Registry Editor and
    remove the following key:

    [HKEY_CURRENT_USER\Software\Google\AFE]
    "AfeUrl"="http://www.google.com/hws/dell/afe?hl=en&s="

    Reference:
    http://www.dellcommunity.com/supportforums/board/message?board.id=si_virus&message.id=48440

    Good luck,

    Donald Anadell
     
    Donald Anadell, Jan 28, 2007
    #4
  5. Malay Thakershi

    Muggs Guest

    Unfortunately, this procedure doesn't work. I've tried it.

    Internet Explorer
    Tools
    Internet Options
    Advanced
    Search from the Address bar
    Do not search from the Address bar

    I'm using IE 7.0.5730.11 and specifying "Do not search from the Address bar"
    has no effect on the behavior. The darn thing still searches from the address
    bar.

    I tried deleting all "Search Providers":

    Internet Explorer
    Tools
    Internet Options
    Change Search Defaults
    "Remove" the "Search Providers" entry

    No luck. IE won't let you delete all of the Search Providers.

    This is a bug I'd love to see fixed.
     
    Muggs, Apr 5, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.