How to uninstall WSS 2,0, WSS 3.0, MOSS 2007?

Discussion in 'Windows Small Business Server' started by Tony Girgenti, Jun 16, 2008.

  1. Hello.

    We have an SBS2003, SP2 server with ISA2004, SQL2005.

    I asked this in SharePoint Services and Mike Walsh suggested that i ask it
    here.

    I want to uninstall WSS 2.0, WSS 3.0 and MOSS2007 so that we can reinstall
    just
    WSS 3.0.

    Is there a way to uninstall all that stuff and get rid of the databases as
    well?

    When i remove MOSS in add/remove programs, it goes through the procedure,
    but it stays in the add/remove programs.

    When i uninstall WSS 3.0 and reinstall it, it gives a configuration failed
    error of "An exception of type System.Data.SqlClient.SqlException was
    thrown. DDL Statement is not allowed".

    Any help would be gratefully appreciated.

    Thanks,
    Tony
     
    Tony Girgenti, Jun 16, 2008
    #1
    1. Advertisements

  2. Hello Tony,

    Thank you for posting here.

    According to your description, I understand that you want to install WSS
    3.0 on SBS 2003. If I have misunderstood the problem, please don't hesitate
    to let me know.

    Based on my research, we do not need to uninstall WSS 2.0 before we install
    the WSS 3.0. I suggest we try the following steps to see if we can resolve
    this issue:

    Step 1: uninstall WSS 3.0

    To delete the Windows SharePoint Services 3.0 default Web site
    1. Click Start, point to All Programs, point to Administrative Tools, and
    then click SharePoint 3.0 Central Administration.

    2. On the Application Management tab, in SharePoint Web Application
    Management, click Delete Web Application.

    3. On the Delete Web Application page, complete the following:

    a. In Web Application, from the drop-down menu, click Change Web
    Application. On the Select Web Application page, select the Windows
    SharePoint Services 3.0 default Web site (http://ServerName).

    Note: Make sure that you delete the default Web site (http://ServerName)
    and not the site that you just created in the preceding step.

    b. In Delete options, delete the content databases and the IIS Web sites.

    c. Click Delete.

    d. In the warning message box, click Yes.

    4. Wait for the Application Management tab to appear, and then close the
    Windows SharePoint Services Central Administration site.

    Step 2: reinstall .net 3.0

    1. Download the following tool at link below
    http://www.microsoft.com/downloads/details.aspx?familyid=AAE7FC63-D405-4E13-
    909F-E85AA9E66146&displaylang=en

    2. Run the tool to uninstall previous version .net 3.0

    3. Please download .net 3.0 from the following link
    http://go.microsoft.com/fwlink/?LinkId=77799

    4. Then re-install .net 3.0

    Step 3: reinstall WSS 3.0

    Please go through the following document and perform the WSS 3.0
    installation steps (step 2 to step 4)

    Installing Windows SharePoint Services 3.0 on a Server Running Windows
    Small Business Server 2003
    http://www.microsoft.com/downloads/details.aspx?FamilyID=0daafc81-efff-4f5b-
    a28a-8265f1e99f5b&displaylang=en

    Additional info:

    Windows SharePoint Services Administrator's Guide
    http://www.microsoft.com/downloads/details.aspx?FamilyID=a637eff6-8224-4b19-
    a6a4-3e33fa13d230&DisplayLang=en

    SharePoint Portal Server 2003 Administrator's Guide
    http://www.microsoft.com/downloads/details.aspx?familyid=47405143-F586-4941-
    92F5-048BF00CF332&displaylang=en

    If we cannot resolve the issue after we perform the steps above, please
    help me collect some information for further investigation:

    1. Please capture screenshot on the error message and send the picture to
    me at

    2. Download the Setup Edition of MPS_Report tool from
    http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
    15706/MPSRPT_SETUPPerf.EXE, run it on the SBS Server. Email me the
    %COMPUTERNAME%_MPSReports_.CAB file which is under the
    %systemroot%\MPSReports\Setup\Lite\Cab directory.

    3. Provide me with the WSS installation log based on the following steps:
    a. Click Start, and then click Run.
    b. Type "%temp%" (without quotation marks), and then click OK.
    c. In the %temp% folder, look for a file or files with the name Microsoft
    Windows SharePoint Services 3.0 Setup(000n)_Task(0001).txt.

    4. Compress and email me with the C:\Program Files\Microsoft
    Integration\Windows Small Business Server 2003\Logs folder.

    I hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
     
    Terence Liu [MSFT], Jun 18, 2008
    #2
    1. Advertisements

  3. Email from customer:
    ========================

    Hello Terence.

    Thanks for your help in this matter.

    I can't get past your Step 1:uninstall WSS3.0. As indicated in my original
    post, I cannot install nor uninstall WSS 3.0. When I try your Step 1:, the
    item is on the menus, but it won't go to the Administration page.

    Thanks,
    Tony
     
    Terence Liu [MSFT], Jun 19, 2008
    #3
  4. Hello Tony,

    Thank you for your update.

    Since you unable to uninstall WSS 3.0 thru the normal method, we only need
    to manually uninstall WSS 3.0 thru the following steps:

    1. Disable and Stop the following services (If any):
    -Windows SharePoint Services Administration
    -Windows SharePoint Services Search
    -Windows SharePoint Services Timer
    -Windows SharePoint Services Tracing
    -Windows SharePoint Services VSS Writer

    2. Backup and then delete the following registry hives:
    HKLM\Software\Microsoft\Shared Tools\Web Server Extensions\12.0
    HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\WSS

    3. Delete the following folders:
    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12

    4. Now I would like to confirm whether you have WSUS 3.0 installed.

    Installing Windows SharePoint Services 3.0 on a Server Running Windows
    Small Business Server 2003
    http://www.microsoft.com/downloads/details.aspx?FamilyID=0daafc81-efff-4f5b-
    a28a-8265f1e99f5b&displaylang=en

    If we cannot resolve the issue after we perform the steps above, please
    help me collect some information for further investigation:

    1. Please capture screenshot on the error message and send the picture to
    me at

    2. Download the Setup Edition of MPS_Report tool from
    http://download.microsoft.com/download/b/b/1/bb139fcb-4aac-4fe5-a579-30b0bd9
    15706/MPSRPT_SETUPPerf.EXE, run it on the SBS Server. Email me the
    %COMPUTERNAME%_MPSReports_.CAB file which is under the
    %systemroot%\MPSReports\Setup\Lite\Cab directory.

    3. Provide me with the WSS installation log based on the following steps:
    a. Click Start, and then click Run.
    b. Type "%temp%" (without quotation marks), and then click OK.
    c. In the %temp% folder, look for a file or files with the name Microsoft
    Windows SharePoint Services 3.0 Setup(000n)_Task(0001).txt.

    4. Compress and email me with the C:\Program Files\Microsoft
    Integration\Windows Small Business Server 2003\Logs folder.

    I hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
     
    Terence Liu [MSFT], Jun 19, 2008
    #4
  5. Email from customer:
    =============================

    Hello Terence.

    Thanks for your continued help to resolve this problem.

    From your most recent instructions, I was able to perform steps 1 to 3. On
    step 4., I read the document your link pointed to and realized that WSS3.0
    needs WSS2.0 installed before installing WSS3.0. IF I am wrong about that
    please accept my apologies.

    I attempted to install WSS2.0 and received an error. I took screen shots
    and created all of the files and logs that you requested. They are
    attached.

    Please let me know if you need anything else. I am very anxious to resolve
    this problem.

    Thanks,
    Tony
     
    Terence Liu [MSFT], Jun 20, 2008
    #5
  6. Hello Tony,

    Thank you for your update.

    We do not need to have WSS 2.0 before we install the WSS 3.0. You can
    perform the step 1 to step 5 in the document. Please ignore the step 6 if
    you do not have WSS 2.0 before.

    Note: If you still want to install WSS 2.0 on the SBS 2003, please ensure
    you install it before you begin to perform WSS 3.0 installation.

    To completely remove WSS 2.0 on SBS, please perform the steps in the first
    part of the following KB:

    How to remove and how to install the Windows Small Business Server 2003
    SharePoint Services 2.0 companyweb Web site
    http://support.microsoft.com/kb/829114

    I hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
     
    Terence Liu [MSFT], Jun 20, 2008
    #6
  7. Email from customer:
    ==========================

    Hello Terence.

    Thank you very much for continuing to assist me in trying to determine what
    the problem is with my server.
    suggest you download and apply the WSS 3.0 sp1 directly.<<

    I attempted this step and received this error:



    again:<<

    I attempted this step and received this error:



    then try to install the WSS 3.0.<<

    When i attempt this step at the point where it says"Use the Windows Small
    Business Server Setup 2003 program to install the Intranet component" at
    step 5. there is no option to "Install". There is only "Remove" and "None".

    Thanks,
    Tony
     
    Terence Liu [MSFT], Jun 24, 2008
    #7
  8. Hello Tony,

    Thank you for your email.

    1. There is no option of "Install" when you try to install WSS 2.0 on SBS
    from the SBS Disk 3. I think you did not uninstall WSS 2.0 completely
    before. Please ensure you perform the steps: Rename the Sharepoint and
    companyweb folders and Delete the registry keys for the Intranet component.

    2. Meanwhile, please ensure you completely uninstall the MOSS 2007 before.
    The MOSS 2007 is later than WSS 2.0 and 3.0. You may get error when you
    install WSS 2.0 or 3.0 if you had installed MOSS 2007 before. For how to
    uninstall MOSS 2007, please try to get help in WSS newsgroup:
    http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=m
    icrosoft.public.sharepoint.setup_and_administration

    3. The WSS 3.0 sp1 installation error is pointing to the following KB:

    You receive an error message when you try to install a slipstream
    installation of Microsoft Search Server 2008 or SharePoint Server 2007 on a
    server that is running Windows SharePoint Services 3.0
    http://support.microsoft.com/kb/945967

    From the resolution of the KB, we know you need to uninstall the 2007
    Microsoft Office servers SP1 before you install the WSS 3.0.

    For more information about the 2007 Microsoft Office servers Service Pack
    1, click the following article number to view the article in the Microsoft
    Knowledge Base:
    Description of the 2007 Microsoft Office servers Service Pack 1 and the
    2007 Microsoft Office servers Language Pack Service Pack 1
    http://support.microsoft.com/kb/936984/

    I hope these steps will give you some help.

    Thanks and have a nice day!

    Best regards,

    Terence Liu (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    This newsgroup only focuses on SBS technical issues. If you have issues
    regarding other Microsoft products, you'd better post in the corresponding
    newsgroups so that they can be resolved in an efficient and timely manner.
    You can locate the newsgroup here:
    http://www.microsoft.com/communities/newsgroups/en-us/default.aspx

    When opening a new thread via the web interface, we recommend you check the
    "Notify me of replies" box to receive e-mail notifications when there are
    any updates in your thread. When responding to posts via your newsreader,
    please "Reply to Group" so that others may learn and benefit from your
    issue.

    Microsoft engineers can only focus on one issue per thread. Although we
    provide other information for your reference, we recommend you post
    different incidents in different threads to keep the thread clean. In doing
    so, it will ensure your issues are resolved in a timely manner.

    For urgent issues, you may want to contact Microsoft CSS directly. Please
    check http://support.microsoft.com for regional support phone numbers.

    Any input or comments in this thread are highly appreciated.
    =====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.

    --------------------
     
    Terence Liu [MSFT], Jun 24, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.