HP 7210 & HP 6L - TCP/IP Printing Problem - Windows Vista Ultimate

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by news.west.cox.net, May 28, 2007.

  1. I am desperately seeking help to resolve a printer problem that I have been
    having since I installed Microsoft Windows Vista Ultimate on May 18th. I
    have spent several hours trying to resolve this issue and can't seem to find
    a solution. I am hoping that someone on this group has a suggestion that I
    didn't try / think about.

    I have a home network setup with 2 desktop computers and 1 laptop. 1
    computer is running Windows Vista Ultimate (desktop), the other computer is
    running Vista Home Premium (desktop), the laptop is running Windows XP but
    is hardly used (old and ready for the trash). The router on the network is a
    DLINK DI-624 and we have two printers on the network. The one printer is a
    HP 7210, which has a network built into it. The other printer is a HP 6L and
    has a print server attached.

    My problem is: The computer I use (Vista Ultimate) can't print to either
    printer. When I do, it takes about 15-20 minutes to complete the job. It
    prints, say, one or two lines -- pauses for a minute or two -- prints
    another one or two lines and pauses. It loops like this until the job is
    complete. If I cancel the job from the queue, it takes about 5 minutes to
    cancel. If I print to the HP 6L -- it takes about 2 or 3 minutes for a 1
    page Word Document to print.

    The other computer (Vista Home Premium) has no isuses printing at all. It's
    fast, images look good, etc...

    If I take the printer off the network and plug it in via USB to the computer
    running Ultimate -- there is no problem. Prints fast and clears the queue.

    Things I have already tried without success:

    1) Uninstalled the printer and reinstalled it.
    2) Set the TCP Autotuninglevel to none via netsh
    3) Verified Driver settings between the two computers and they match.
    4) Checked Firewall / Router settings and all is correct. Disabled Firewall
    completely as well.
    5) Disabled UAC -- didn't work, installed UAC again.

    We even downloaded NetMon 3.0 from Microsoft and the only thing we noticed
    is when I print from the Ultimate computer to the HP 7210, I don't see a TCP
    packet with the FIN flag set, indicating the end of the communication. When
    I ran the NetMon 3.0 on the Home Premium Computer and send a document to the
    printer, I see the TCP packet with the FIN flag being sent to and
    acknowledged by the printer.

    I even went to Microsoft for help and spent three hours in a chat session.
    They had me delete my temporary files, the prefetch files, windows temp
    directory was cleared. In the end, they couldn't figure it out.

    The only other thing that sticks out is that the computer running Home
    Premium when I try to browse folders on the Ultimate computer it is very
    slow in copying (and some of the time freezes the Home Premium computer,
    requiring a alt-ctrl-del and kill the session.

    Any suggestions would be greatly appreciated. Please post to the group so
    that other people experiencing my issues can see your response as well.

    Thank you,
    Kevin
     
    news.west.cox.net, May 28, 2007
    #1
    1. Advertisements

  2. news.west.cox.net

    Kevin Guest

    This issue has been resolved by Microsoft's Research Team. Turned out to be
    my NIC card wasn't fully compatible with Vista. They changed the print stack
    a little bit and my NIC didn't support it.

    Went out to Bestbuy -- picked up a new card -- popped it in and printing has
    been restored.

    Thanks,
    Kevin
     
    Kevin, May 30, 2007
    #2
    1. Advertisements

  3. Alan Morris [MSFT], May 30, 2007
    #3
  4. news.west.cox.net

    huwyngr Guest

    Would you care to let us know what the incompatible with VISTA card was
    and what the one that worked is? <s>
     
    huwyngr, May 30, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.