hwo can i get jpg's to show on MCX

Discussion in 'Windows Media Center' started by cd12172, Jan 12, 2006.

  1. cd12172

    cd12172 Guest

    ..jpg files do not show up on xbox360 being used as an extender, but do back
    at the PC??

    My registry key for perceived type is correctly set to image. other image
    files do work, ie. gif/bmp on both XB360 and PC...

    Incidently, the Xbox can display jpg's when I connect to it as a PC, and
    skip the "Media Center" connection.

    I do have Office 2003, no photoshop. I think the issue may be related to
    the MCX logon account, but can not find a solution. So far the Ms support
    folks on the phone call every 5 days to ask if i plugged in the Xbox - not to
    knowledgable!

    Thanks in advance!
     
    cd12172, Jan 12, 2006
    #1
    1. Advertisements

  2. Do you have Content Type set to image?

    [HKEY_CLASSES_ROOT\.jpeg]

    "Content Type"="image/jpeg"
    "PerceivedType"="image"



    [HKEY_CLASSES_ROOT\.jpg]

    "Content Type"="image/jpg"
    "PerceivedType"="image"
     
    Richard Miller, Jan 12, 2006
    #2
    1. Advertisements

  3. cd12172

    cd12172 Guest

    Good thought, but I checked all of that. I find no differences in the keys
    for gif's which work, and jpg's that do not.

    The odd thing is it works on the PC, just not at the Xbox...

    Thanks,
    Chris


     
    cd12172, Jan 13, 2006
    #3
  4. Where are these JPEGs stored? I suspect that the MCX account may not have
    permissions to read them.

    To verify - copy (don't move) one of the files that doesn't show up to the
    Shared Pictures folder on your Media Center PC; does it display? If so, let
    me know if you'd like steps for resetting the security permissions on your
    pictures so that your MCX can see them.

    --
    This posting is provided "AS IS" with no warranties, and confers no rights.


     
    Todd Bowra [MSFT], Jan 16, 2006
    #4
  5. cd12172

    cd12172 Guest

    They are definitly in a shared place. I did make the suggested copy, no luck.

    For kicks, I changed the .ext to .GIF, and the file immeadiatly appeared in
    the "My Pictures" area on the MCX, though it was not readable.

    Not sure if you read the whole thread, but it is jpg's only on the MCX only
    that are an issue, and my registry looks fine for jpg files, i.e.
    perceivedtype=image...
    Any other ideas???

     
    cd12172, Jan 18, 2006
    #5
  6. cd12172

    cd12172 Guest

    OK, I finall dug into this. It was a registry issue, but not the commonly
    known one on the web.

    after typring assoc .jpg in a dos window, it was revealed that .jpg files
    are not associated with anything. Curious, because I tried changine the
    association a few times.

    The following link has the default registry keys for jpg's, which worked. I
    was sweating however, just importing keys off the web can be a bad pratcice,
    but all is OK.

    http://www.dougknox.com/xp/file_assoc.htm

    Thanks for the help anyway. Email me if you find others with the same
    issue, or rollup2 issues, I have had to solve them all!

     
    cd12172, Jan 18, 2006
    #6
  7. Thanks for the follow up. As a general rule, it's good to be wary of adding
    stuff to your registry that you found on the Internet, but Doug's a good guy
    so there's nothing to worry about in your case :)

    --
    This posting is provided "AS IS" with no warranties, and confers no rights.


     
    Todd Bowra [MSFT], Jan 19, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.