I can't install critical updates

Discussion in 'Windows Update' started by Maslow, Oct 30, 2008.

  1. Maslow

    Maslow Guest

    Hello !
    I don't speak English very well but I think you'll understand me.
    I couldn't install some critical Windows updates (such as KB958644,
    KB953155). However, I could install Windows Defender Updates or Silverlight.

    I already wrote to Microsoft Technical Support : they answered me twice.
    They sent me two files to install (FIX_WU_v.17.zip the first time, then
    Checksur the second time). I answered them that the two solutions didn't
    help me. Since, they didn't answer me anymore.

    So, I expose you my problem : my Windows Updates can search new updates, but
    the problem is that when I arrived at 98% of the installation, I had this
    code error : 800736B2 (unknown error). I run Vista Premium SP1.
    Thank you.
     
    Maslow, Oct 30, 2008
    #1
    1. Advertisements

  2. 800736B2 ERROR_SXS_INVALID_ACTCTXDATA_FORMAT
    The application binding data format is invalid.

    The issue may be caused by antivirus/security software.
    What is the installed AV/security suite/anti-malware and which firewall
    is being used ?
    Which country did you contact Support in and do you have a case number,
    Maslow ?


    MowGreen [MVP 2003-2009]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], Oct 30, 2008
    #2
    1. Advertisements

  3. Maslow

    Maslow Guest

    Thank you MowGreen for answering me.

    I'm from France and I think that Microsoft technical support is located in
    Swiss, or Luxembourg or Belgium. Anyway, the guy has a French name.
    I have Antivir and Windows Defender as antivirus and antimalwares
    residential softwares.
    Furthermore, I scan my computer from time to time with Malwarebytes and
    Spybot (theses two softwares are not residentials).
    I have Vista Premium Vista SP1 and use Windows Firewall (Inbound and
    Outbound : I created some outbound rules).

    Last news : Microsoft sent me a third mail and suggested me to install this
    file : "au_client_tool_v72.exe". I don't know exactly the contents of this
    file, but I think(I'm not sure) the guy installed me Windows Installer 3.1
    !!! Anyway, this third solution didn't work like the others.

    I don't know what you mean by "case number" but in alls objects of my
    emails, I've got this figure : SRX1082888031ID


     
    Maslow, Oct 30, 2008
    #3
  4. This *is* the case number: SRX1082888031ID

    I can't believe they sent you an older reset tool. Please download the
    latest one from here and *save* it:

    http://www.codeplex.com/aureset/Release/ProjectReleases.aspx?ReleaseId=17263

    Once the download completes, close the browser and all open programs.

    Before proceeding, what rules did you add to outbound filtering for the
    native Vista firewall ? Suggest you reset the firewall to it's Default
    settings for now.

    Next, *** temporarily disable AntiVir so that *none* of it's services
    nor processes are running. Consult the User Guide or Avira's web site if
    the page below does not accomplish that ***
    http://www.bleepingcomputer.com/forums/topic114351.html

    Now run au_check_v78_codeplex.exe and allow it time to complete it's
    operation. Restart the system after it's done.

    Can the system update now ?
    If not, has Malware Bytes ever detected any malware on the system ?


    MowGreen [MVP 2003-2008]
    ================
    *-343-* FDNY
    Never Forgotten
    ===============


     
    MowGreen [MVP], Oct 30, 2008
    #4
  5. Furthermore, I scan my computer from time to time with Malwarebytes and
    Is Spybot Tea Timer enabled? Was it ever enabled?
    --
    ~Robear Dyer (PA Bear)
    MS MVP-IE, Mail, Security, Windows Desktop Experience - since 2002
    AumHa VSOP & Admin http://aumha.net
    DTS-L http://dts-l.net/
     
    PA Bear [MS MVP], Oct 31, 2008
    #5
  6. Maslow

    Maslow Guest

    Thank you. I'll let you know soon.

    As regards the outbound rules of the firewall, I blocked all traffic and
    allow some : svhost.exe, helpPane.exe, services.exe, rundll.exe, wercon.exe,
    Internet Explorer, Firefox,...) and it works till now.

    As regards the reset tool that I suspected as an old version : I said that
    because they asked me to right click this file ("au-client_tool_v.72.exe)
    and choose "run in compatibility mode for XP SP2", Am I wrong ?



     
    Maslow, Oct 31, 2008
    #6
  7. Maslow

    Maslow Guest

    @ Robert Dyer : No it isn't

     
    Maslow, Oct 31, 2008
    #7
  8. Was it ever enabled?
     
    PA Bear [MS MVP], Oct 31, 2008
    #8
  9. Maslow

    Maslow Guest

    I'm afraid I don't really understand you.
    All that I can say is that in Spybot option, I noticed that "Resident
    tea-timer" and "Resident SDHelper" are uncheked.

     
    Maslow, Oct 31, 2008
    #9
  10. Has the Tea Timer option EVER been checked?
     
    PA Bear [MS MVP], Oct 31, 2008
    #10
  11. Maslow

    Maslow Guest

    Never

     
    Maslow, Oct 31, 2008
    #11
  12. Start a free Windows Update support incident request:
    https://support.microsoft.com/oas/default.aspx?gprid=6527

    Support for Windows Update:
    http://support.microsoft.com/gp/wusupport

    For more information about how to contact your local Microsoft subsidiary
    for security update support issues, visit the International Support Web
    site: http://support.microsoft.com/common/international.aspx

    For enterprise customers, support for security updates is available through
    your usual support contacts.
    --
    ~Robear Dyer (PA Bear)
    MS MVP-Windows (IE, OE, Security, Shell/User)
    AumHa VSOP & Admin; DTS-L.net
     
    PA Bear [MS MVP], Oct 31, 2008
    #12
  13. Maslow

    Maslow Guest

    @ MowGreen : I'm waiting for Microsoft last proposition tomorrow. If this
    last won't work, I'll download "au_check_v78_codeplex.exe" and follow your
    instruction.

     
    Maslow, Oct 31, 2008
    #13
  14. As regards the reset tool that I suspected as an old version : I said that because they asked me to
    Contrary to the advice they gave you, suggest you *right click*
    au_check_v78_codeplex.exe and choose 'Run as administrator'.
    It's designed to work with Vista.
    I *hope* you meant svchost.exe and NOT *svhost.exe*.
    Vista uses wuapp.exe and wuaucult.exe to update and they can't be
    blocked by the firewall. They're a process spawned from svchost.exe,
    specifically svchost.exe -k netsvcs. So, I doubt that you accidentally
    blocked the system from the update servers unless either the RPC or DCOM
    Server Process Launcher services are blocked.
    That's why I suggested resetting the firewall to it's Default settings
    so that we could eliminate the firewall as being the cause of the issue.

    BUT, you're saying that Windows Update worked previously with the
    firewall rules you created, correct ?


    MowGreen [MVP 2003-2009]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============



     
    MowGreen [MVP], Oct 31, 2008
    #14
  15. Maslow

    Maslow Guest

    Sorry, it is indeed *Svchost.exe*.
    Yes, I had no problems before even with theses rules.

     
    Maslow, Oct 31, 2008
    #15
  16. Maslow

    Maslow Guest

    I installed "au_check_v78" MowGreen but unfortunately It did'nt work for me
    ! I even desactivated all antivirus and antimalware and Firewall progams.
    Perhaps It's a good tool and may be I have corrupted files.
    I even tried to manually install the concerning file but it failed.
    Now, I'm really stuck !
    If someone has an idea to repair corrupted files without reinstalling
    Vista...


     
    Maslow, Nov 3, 2008
    #16
  17. The tool creates several log files in C:\aulogs [the logs are stored on
    the root drive, the drive where Windows is installed to. In most cases
    this is the C:\ drive. IF Windows is installed to a different
    drive/partition, then the logs will be located there]
    Since I'm not that familiar with the logs yet, please provide me with a
    list of their names and perhaps we can figure out just where the issue lies.
    As a last resort we can contact the tools author and send him the logs.

    MowGreen [MVP 2003-2009]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============

     
    MowGreen [MVP], Nov 3, 2008
    #17
  18. Maslow

    Maslow Guest

    I found 9 files with .txt extension and others with .log (checkSUR.log,
    WindowsUpdate.log, progress.log).
    And there is also an .htm file (download.htm). I clicked above and I got
    this text :
    "The following prerequisites may need to be installed/reinstalled for proper
    operation of Windows Update/Microsoft Update/ The Automatic Update Client
    For Vista:
    WindowsUpdateAgent30-x86.exe (direct link to the latest version of the
    Update Client)"

    What do you think, should I download this file ?


     
    Maslow, Nov 3, 2008
    #18
  19. Please provide a list of *all* .txt files and .log files.
    The tool attempts to install the WindowsUpdateAgent but, obviously,
    something went awry. Let's check the logs before attempting to run the
    tool once more, Maslow.

    MowGreen [MVP 2003-2009]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============


     
    MowGreen [MVP], Nov 3, 2008
    #19
  20. Maslow

    Maslow Guest

    1) Here are the list :

    Under "data.cab" :
    - MGAlog.txt
    - audcomlog.txt
    - Fileversions.txt
    - WinHTTP_log.txt
    - cci_XML_object_test.txt
    - WindowsUpdate.log
    - gpresult.txt
    - bitsqueue.txt
    - Descriptors.txt
    - CheckSUR.log

    Under "progress.CAB" :
    - _progress.log
    - DLLReg_output.txt

    2) I tried to install WindowsUpdateAgent but, as you said MowGreen, it
    didn't work (I've got the same code error : 800736B2)

    3) @ Master Blaster : Is this manipulation valid also for Vista ? For
    example, in C:\Windows\System 32, I have "wucltux.dll" instead of
    "wucltui.dll"


     
    Maslow, Nov 4, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.