IBM ThinkPad T43p -> keyboard and mouse not working

Discussion in 'Windows Vista Hardware' started by Johnny, Jun 17, 2006.

  1. Johnny

    Johnny Guest

    Hi all,

    after upgrading from XP to Vista Beta 2 I cannot login because neither
    keyboard nor Mouse (touchpad, trackball and external USB) are working on an
    IBM ThinkPad T43p (Notebook). The login screen appears, but I cannot type in
    a password nor can I move the mouse.
    The upgrade process itselfe finished without any problems. e.g. High
    Resolution Display was detected.
    (remark: on XP IBM Drivers and Applications for Keyboard and Mouse have been
    installed. Maybe these Apps are still started but not compatible with Vista?)

    What do you think, how can I fix this issue? Starting in safe mode doesn't
    help.

    Thanks for any response
    Johnny
     
    Johnny, Jun 17, 2006
    #1
    1. Advertisements

  2. Johnny

    Micah Guest

    Hey Johnny

    I'm also running a t43p, and it's running quite smoothly, and with a good
    rating too. Did you upgrade from XP or do a clean install? I did a clean
    install. This means removing even the rescue and recovery portion of the
    hardrive (the "predesktop" area). I then made a new partition of the whole
    drive. The reason I mention this is because I think your keyboard/mose are
    frozen because the IBM drivers for ultranav are totally incompatible with
    Vista, and cause it to freeze the entire mouse and keyboard. The only way to
    fix your problem is to rid yourself of the IBM mouse and keyboard drivers and
    use just standard ps2 mouse drivers and standard keyboard. There is
    probably some way to do this from the command line, but I don't know how.
    But I do know that until you uninstall the drivers for yourkeyboard and
    mouse, you will be able ot use Vista fine. When you upgrade from XP,
    however, it retains the IBM drivers. Also, if you install Vista without
    getting rid of the predesktop area of the hard drive, I think it finds hte
    IBM drivers and installs them, thus freezing the computer.

    - Micah
     
    Micah, Jun 18, 2006
    #2
    1. Advertisements

  3. Johnny

    Johnny Guest

    Hi Micah,

    thank you very much for your reply. What you mention is exactly what I also
    think that it is the problem.
    Yes, first I tried to upgrade an existing XP Installation (where all the
    ThinkPad Drivers where installed).

    Now I did a clean install and voila, its running fine.

    Conclusion: I was not able to fix the problem of an upgrade, so I installed
    it from the scratch by loosing my old (XP) Settings and Applications.

    Thanks again
    Johnny
     
    Johnny, Jun 18, 2006
    #3
  4. Johnny

    ANIMALCHIN Guest

    Hi, I have a T43p and there are certain things I can not get working.
    Did you guys get the finger print device to work?
    Also, the middle button on the mouse?
     
    ANIMALCHIN, Nov 22, 2006
    #4
  5. Johnny

    Kevin Young Guest

    Lenovo site indicates Vista drivers should be available in late November so
    hopefully we will see them on the Lenovo site this week.
     
    Kevin Young, Nov 25, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.