ie 7.0 fails to open wmp 11 for playback in Vista

Discussion in 'Internet Explorer' started by BerlinTop, Dec 31, 2008.

  1. Full ACK

    Matthias
     
    Matthias Berke, Jan 2, 2009
    #21
    1. Advertisements

  2. BerlinTop

    zachd [MSFT] Guest

    Yeah, I responded to that already last night with the post beginning "You're
    going down a failover path."

    Yes, it's possible, as you've already noticed it varies between system
    state. So it's still pretty primitive to knowingly leave your Unix system
    in a broken state. It's like driving with the emergency brake on: it might
    work, but ... why would you want to when you can take corrective action and
    make your life simpler?

    This is the most puzzling conversation I've had in years. Just fix your
    broken MIME type.


     
    zachd [MSFT], Jan 2, 2009
    #22
    1. Advertisements

  3. funktioniert wieder

    Deinstalliere NICHT-MS-Codepacks

    Prüfe ob diese Update für Vista WMP 11 hilft
    http://support.microsoft.com/kb/947403/de

    Matthias
     
    Matthias Berke, Jan 2, 2009
    #23
  4. BerlinTop

    BerlinTop Guest

    Wenn ich versuche, das update u installieren, bekomme ich die Meldung: "Das
    update gilt nicht für Ihr System"
     
    BerlinTop, Jan 3, 2009
    #24
  5. BerlinTop

    BerlinTop Guest

    I did you the "favour", and changed the mime-type. It turns out, this did not
    make my life simpler, but yours more complicated (sorry, you asked for it,
    don't blame me).

    Here is the telnet-log:
    HEAD /presentations/RNAi%20Animation.wmv HTTP/1.0
    HTTP/1.1 200 OK
    Date: Sat, 03 Jan 2009 09:32:44 GMT
    Server: Rapidsite/Apa/1.3.33 (Unix) FrontPage/5.0.2.2510 mod_ssl/2.8.22
    OpenSSL/
    0.9.8d
    Last-Modified: Fri, 02 Jan 2009 08:20:09 GMT
    ETag: "fbcb67-28d4f8-495dce39"
    Accept-Ranges: bytes
    Content-Length: 2675960
    Connection: close
    Content-Type: video/x-ms-wmv

    What is the result?
    - On the XP-machine: No change. IE calls WMP, playback starts
    - On the VISTA-machine, where it used to work before: No change. IE calls
    WMP, playback starts
    - On the VISTA-machine, where it did NOT work before: NO CHANGE. Still the
    same error message: Page cannot be displayed.

    Maybe, this convices you that mime-types are not the issue here.

    As I said before, I have other issues on that machine that IE does not open
    WMP to playback contents, which you refused to take into account. But you
    need to look at the whole picture, and stop riding on your mime types:
    - IE fails to call WMP to play radio stations that require the AAC-plugin
    (http://www.tuner2.com/wmp.html). Here I get the same error-message: page
    cannot be displayed. WMP itself plays the stations, when the URL is entered
    directly in WMP. So, the AAC plugin is installed correctly. Mime types are
    not the problem here, either.
    Some other strange things, which I discovered today after resetting IE which
    may be related to that:
    - IE upon start always tells me, it is not standard. I always tell him, to
    be standard, but the settings are not saved. Even, if I run it as Admin. The
    same is true for Outlook.
    - In my list of standard programs, I only have Outlook and windows search
    explorer. This is strange, and no way to change that (VISTA Ultimate)
    - When I try to change system standards to define standard applications,
    settings are not saved, either.

    So, not being a world expert on Vista, I assume that this issue is related
    to a misconfiguration of rights here on this machine, and has nothing to do
    with the web server. But this is just a guess.

    Now the ball is with you. Tell me anything you like, but don't tell me, I
    messed up a server, ok?

    Cheers

     
    BerlinTop, Jan 3, 2009
    #25
  6. BerlinTop

    zachd [MSFT] Guest

    I can't imagine how being able to address the more interesting areas of a
    problem makes things more complicated. It's called "removing noise" or
    "reducing complexity": you've simplified things. Thanks. =)
    Did you try the Set Program Defaults option I suggested?
    I don't know what issues with IE that you are talking about or referring to
    and am not interested in those personally. I know the player and multimedia
    darned well. I certainly don't know IE backwards and forwards.

    So we know that the clip plays in the player, which means that the player is
    working and networking is working. We know that a metadata hyperlink
    doesn't launch WMP for whatever reason.

    What do you think might be the cause of a hyperlink not launching the
    player? I've been trying to trudge onwards offering my own insight: what
    are you suspicious of here that you want to focus on? =)
     
    zachd [MSFT], Jan 3, 2009
    #26
  7. BerlinTop

    BerlinTop Guest

    I have no idea. I didn't write the code. I am just trying to use the software.
    But as I see, you are raising the white flag, let's wait and see, maybe
    others have a better idea.

    Cheers
     
    BerlinTop, Jan 3, 2009
    #27
  8. BerlinTop

    zachd [MSFT] Guest

    I'll quote myself here, as you also quoted me in your response:

    My later question as to what YOU thought this was was because of your
    obvious and complete disregard for anything I say. When I go to the doctor,
    I tend to try to learn. Since you are pretty obviously and delightfully
    utterly ignoring my suggestions, I can only presume that you have your own
    agenda here. I apologize for having other things to do with my life than
    try to provide technical advice to someone who isn't listening. =)

    I apologize: I know this area well, but I am not comfortable trying to
    bludgeon you into listening to me and pretty much begging you to attempt to
    try the utterly trivial things I've tried to politely suggest to you. Since
    you are incapable of listening to me, which is probably my own shortcoming
    for which I deeply apologize for, I will politely abandon this discussion.

    I would suggest that anyone with half a brain who attempts to try to get you
    to listen would be well suited to try the suggestion I made above. If they
    do not suggest this to you, they do not know this area at all and should not
    be listened to. =)

    I wish you the best of health in the New Year and apologize that we have
    such a complete inability to communicate.

    Best regards,
    -Zach
     
    zachd [MSFT], Jan 4, 2009
    #28
  9. BerlinTop

    BerlinTop Guest

    No, I do not ignore what you say. I simply overlooked your post that you are
    referring to:

    "Here's a link that is set correctly:
    http://zachd.com/pss/samples_content/Berlin.wmv
    That's your clip rehosted on a server that's configured correctly. Lemme
    know when we're done here and I'll delete that if you want."

    --> result: page cannot be displayed

    "Now, if this does work for you this indicates that your local MIME type
    association chain was reset at some point (which might be the case
    regardless). This can be most quickly be fixed by running:
    unregmp2.exe /SetWMPAsDefault
    from an elevated cmd.exe prompt."

    --> result: WMP is still not listed as standard in system settings

    Or for the novice, just use the Set
    Program Access and Computer Defaults option under the Default Programs tool
    to set WMP as the default. This should reset the association chain back
    correctly.

    --> tried this for about 25 times. no change
     
    BerlinTop, Jan 4, 2009
    #29

  10. Since these things work on your other Vista machine
    something that may be helpful and effective is capturing
    each attempt in a ProcMon trace and then comparing the two.
    (Typically having two otherwise identical traces to compare
    for differences is much easier to analyse without really
    understanding what either is telling you. <w>)

    You could use the same technique for trying to follow
    what is happening in your original problem scenario
    but that may be harder to follow because the activity
    probably will be more complex and harder to follow,
    no SetValue events to key on for example.

    FWIW I would think if those repair procedures you tried are complete
    the most likely cause for them not working would be insufficient permissions.
    ProcMon is often ideal for discovering such cases.


    Good luck

    Robert Aldwinckle
     
    Robert Aldwinckle, Jan 4, 2009
    #30
  11. BerlinTop

    BerlinTop Guest

    Thanks, great suggestion which leads away from guessing. I will look into
    that later (after having a first glance and discovering that this is quite
    some task... :).

    The problem must be related to WMP not being set to standard application. I
    copied the wmv to the desktop, and tried to open it different ways:
    - a double click opens the file
    - a right-click, and then "open with..." WMP - opens the file
    - a right click, and then "open with..." - "Standard application..."...WMP
    does NOT open the file.

    Let me see if I can find out why my system does not accept WMP as standard
    application.

    Cheers
     
    BerlinTop, Jan 4, 2009
    #31
  12. BerlinTop

    BerlinTop Guest

    Problem solved!

    The problem was a missing entry in the registry:

    [HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications]
    "Windows Media Player"="Software\Clients\Media\Windows Media
    Player\Capabilities"

    After adding this entry manually to the registry, the WMP was back to the
    entries of Standard Programs. Then it could be set as default program for
    media playback.

    This solved all media-playback trouble, when the media was called via IE.
    Now not only the file in question play back fine, also all AAC-plus radio
    stations started working again.

    To check for other media-files-playback, check:
    http://support.microsoft.com/kb/316992/en-us

    The problem possibly was caused by an installation of Nokia-Phone software
    that deleted all standard programs from the list.
     
    BerlinTop, Jan 5, 2009
    #32
  13. BerlinTop

    BerlinTop Guest

    Can you do me (and others) a favour, and mark the question as "solved"? I
    posted the solution today (1/5/2009)

    Cheers
     
    BerlinTop, Jan 5, 2009
    #33
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.