IE 7 can not open any webpage

Discussion in 'Internet Explorer' started by MegGeek, Jan 19, 2008.

  1. MegGeek

    MegGeek Guest

    Hi,

    My IE7 (on Windows Vista Home Basic) can not open any webpage since last
    couple of weeks.
    I get following error:
    ++++++++++++++++++++++++++++++++++++++
    "Internet Explorer cannot display the webpage.
    Most likely causes:
    You are not connected to the Internet.
    The website is encountering problems.
    There might be a typing error in the address.

    What you can try:
    Diagnose Connection Problems

    More information

    This problem can be caused by a variety of issues, including:

    Internet connectivity has been lost.
    The website is temporarily unavailable.
    The Domain Name Server (DNS) is not reachable.
    The Domain Name Server (DNS) does not have a listing for the website's
    domain.
    If this is an HTTPS (secure) address, click Tools, click Internet Options,
    click Advanced, and check to be sure the SSL and TLS protocols are enabled
    under the security section.


    Click Tools , and then click Work Offline.
    Click the Favorites Center button , click History, and then click the page
    you want to view. "
    ++++++++++++++++++++++++++++++++++++++

    The problem started when I installed google toolbar for IE7. The IE7
    already had yahoo toolbar installed. After that, IE7 failed to open any page.

    To solve the problem, I tried uninstalling both Yahoo toolbar & Google
    toolbar, but it did not work.

    Please help.
     
    MegGeek, Jan 19, 2008
    #1
    1. Advertisements

  2. Error message after you install a Windows Internet Explorer 7 update from
    Windows Update or from Microsoft Update: "Webpage cannot be displayed":
    http://support.microsoft.com/kb/942818

    If tweaking your third-party firewall's settings don't help, try the
    following:

    1. Disable your anti-virus application, any real-time protection provided by
    an anti-spyware application (except for Windows Defender; includes Spybot
    Tea Timer, SpySweeper Guards, AVG AS guard.exe, etc.), disable any
    third-party firewall AND enable the Windows Firewall.

    NB: You're "working without a net" now: Don't to ANYTHING else online (e.g.,
    browsing; reading email; chatting) except #4 below until your anti-virus
    application has been re-enabled! If you're running ZA Free firewall, you
    may need to uninstall it instead of disabling it.

    2. Uninstall "Security Update for Windows Internet Explorer 7 (KB942615)"
    via Add/Remove Programs (make sure Show Updates box is checked at top right)
    and reboot.

    3. Re-do #1 above.

    4. Go to http://windowsupdate.microsoft.com and install any Critical Updates
    offered. If "Root Certificates" update is listed in the Optional Updates
    category, you might install it, too, to take full advantage of IE7's
    additional security.

    5. Reboot > Make sure everything in #1 above is enabled again and, if
    applicable, disable the Windows Firewall and enable your third-party
    firewall.
     
    PA Bear [MS MVP], Jan 19, 2008
    #2
    1. Advertisements

  3. MegGeek

    MegGeek Guest

    "Tweaking" firewall doesn't help. I even tried uninstalling the firewall
    altogether (Zone Alarm) and then connecting to internet but it didn't fix the
    problem.

    Also, KB942818 is not installed on my machine, I checked the "Add/remove
    programs" utility.
     
    MegGeek, Feb 25, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.