IE 7 developing some weirdness - would appreciate any help.

Discussion in 'Internet Explorer' started by Dirty Dawg, Mar 13, 2009.

  1. Dirty Dawg

    Dirty Dawg Guest

    Until just recently IE 7 has been running awesome....speedy, etc., but now
    for some reason when initially opening the program, it sits there for like
    30 seconds or more just spinning like it does when it's searching/or having
    trouble connecting to a web page/Home page. I thought that perhaps there
    was a problem with the home page I had, so I set it up for a blank home
    page, but it still does it. I would greatly appreciate any help that
    anybody cares to give me.

    I'm running Vista Home Premium Sevice Pack 1.

    I also have a laptop that is running Vista Ultimate, but it is not doing
    this at the moment.

    Thanks in advance.
    Dirty Dawg, Mar 13, 2009
    1. Advertisements

  2. Dirty Dawg

    Leonard Grey Guest

    What process (see Task Manager) occupies most of the CPU resources while
    IE seems to be spinning its wheels?
    Leonard Grey, Mar 13, 2009
    1. Advertisements

  3. PA Bear [MS MVP], Mar 13, 2009
  4. Dirty Dawg

    Dirty Dawg Guest

    Hey, thanks for the reply. Since it would be impossible for me to look
    continually at all the processes at one time, I chose to look at the "System
    Idle" process under the CPU column during the boot up of Internet Explorer.
    It remained at around 98-99%. I'm assuming that that means there were no
    programs hogging/dragging down the CPU (I've got a quad core by the way).
    As I said, I'm assuming. If you know of something that I don't and you
    think it still has something to do with some process running, then please
    let me know. Or if you come up with something else that you can think of,
    then I would appreciate you passing that along as well.

    Thanks again.
    Dirty Dawg, Mar 13, 2009
  5. Dirty Dawg

    Dirty Dawg Guest

    Thanks for the reply. I've determined that it is one of the add ons in
    Internet Explorer thanks to your link. Thank you. I don't know which one
    yet, but I'll just add them in one by one until I find the culprit, then
    I'll come back and post which one it was in case someone else has the same
    Dirty Dawg, Mar 13, 2009
  6. Dirty Dawg

    Leonard Grey Guest

    To see which process is occupying most of the CPU resources while IE is
    dawdling: Open Task Manager (CTRL+ALT+DEL) to the Process tab and
    display the processes in order of decreasing CPU usage (click on the
    header of the CPU column.) Leave Task Manager open and park it in a
    corner of your monitor. By default it stays on top of other windows.

    You can glance at Task Manager at any time to see what process is using
    most of the CPU.
    Leonard Grey, Mar 13, 2009
  7. Dirty Dawg

    Dirty Dawg Guest

    Ok, I've determined which one it was. It is some sort of Java Helper add on
    called "Java (TM) Plug-In 2 SSV Helper". Since it is a helper file, I'm
    hoping that I can just uninstall it without any troubles rather than just
    leave it on the system and "disable" it. Thanks to PA Bear and Leonard Grey
    for your help.
    Dirty Dawg, Mar 13, 2009
  8. That Add-on is installed with Sun Java installation of JRE 6 Update 10,11,
    and 12.

    You might try uninstalling all Sun Java entries in Add||Remove programs, the
    go to the following site:

    Download and install the JRE 6 Update 12 package to see if your problem is

    Good luck,

    Donald Anadell
    Donald Anadell, Mar 13, 2009
  9. PA Bear [MS MVP], Mar 13, 2009
  10. Dirty Dawg

    Dirty Dawg Guest

    Thanks for the reply. I tried what you suggested and that add-on still
    makes Internet Explorer bog down for like 30 seconds (maybe a little less)
    when it is enabled. All I can do with it is enable or disable it, I cannot
    find it anywhere in the installed programs area to uninstall it. Which is
    kind of weird I think. Anyway, all I need to do is just keep it disabled
    and the 30 second delay disappears.
    Dirty Dawg, Mar 14, 2009
  11. Dirty Dawg

    Dirty Dawg Guest

    I took a look at the installed programs area and found out that there was
    like 6 different listings there for java...all of them were updates though.
    Listed similarly to "Java(TM) 6 Update 3"
    "Java(TM) 6 Update 4"

    Kind of like that .. and update 12 was one of them as well. I guess
    whenever I restarted and I got the update notification from Java, and I
    allowed it to download and install, it didn't uninstall the previous
    updates. As I mentioned in a reply to Donald Anadell's post, even after
    uninstalling all of the updates for java that was listed in installed
    programs area and downloading just the latest update and installing it, that
    one add-on still bogs down IE when starting up. I have to leave it disabled
    all the time. Also, I cannot find it listed anywhere in the installed
    programs listings in order to uninstall it. It is only listed in the add-on
    section of IE. Isn't that a little weird?

    ----- Original Message -----
    From: "PA Bear [MS MVP]" <>
    Newsgroups: microsoft.public.internetexplorer.general
    Sent: Friday, March 13, 2009 2:18 PM
    Subject: Re: IE 7 developing some weirdness - would appreciate any help.

    Dirty Dawg, Mar 14, 2009
  12. Start | Run | (type) services.msc | OK

    Scroll down to and double-click on Java Quick Starter | In Startup type,
    select Disabled (or Manual), then STOP the service.

    Any difference now?

    Actually, Java Quick Starter may be causing another Add-on grief and that
    one could be the troublemaker. See (ignore the
    reference to IE7 Beta).

    PA Bear [MS MVP], Mar 14, 2009
  13. Dirty Dawg

    Dirty Dawg Guest

    Thanks for the reply. I don't find that listed in the services.msc.
    Nothing is there that starts with a "J". The listings go from "IPsec Policy
    Agent" to "KtmRm for Distributed Transaction Coordinator". Just on the
    outside chance that it wasn't alphabetized in the listing like the others, I
    checked the whole list. It is not there.

    Dirty Dawg, Mar 14, 2009
  14. Others have reported this slow IE7 opening issue with the Sun Java
    Add-on(Java(tm) Plug-In 2 SSV Helper) enabled on both Windows Vista and
    Windows XP, see the following Thread in the Sun Forum:

    There was also a Bug Report(Bug ID: 6792558) submitted to Sun on 12-1-2009
    with regard to the issue:

    (Although the issuer of the Report is only claiming a 3-4 second delay in
    IE7 opening as apposed your 30 second delay claim.)
    The add-on is part and parcel of the Sun Java Runtime installation, it has
    no separate uninstall mechanism.
    Also see the latest reply from PA Bear in this thread.

    Good luck,

    Donald Anadell
    Donald Anadell, Mar 14, 2009
  15. In addition:

    The Bug ID: 6792558 states that in order to reproduce this bug you need to
    have a slower system:

    "For this test you NEED a slow PC (single core less than 1.8Ghz)"

    You didn't give much detail about the machine that is affected by this
    issue, nor much information about the machine that does not have the issue.

    With regard to your latest reply to PA Bear, if you don't see the Java Quick
    Starter service listed in the services.msc it means you have have it
    disabled. The Service is turned on and off using the Java Control Panel
    Control Panel||Java||Advanced(tab)||Miscellaneous

    To run the service you need to put a checkmark in the box next to "Java
    Quick Starter". This will turn the service on. You might try turning the
    service on using the method to see if it makes a difference in your loading

    Good luck,

    Donald Anadell
    Donald Anadell, Mar 14, 2009
  16. Dirty Dawg

    Dirty Dawg Guest

    Hey Donald, thanks for the reply. I went to the control panel java
    appelet/advanced/miscellaneous like you suggested and although there is a
    listing there for "Java Quick Starter", it is grayed out. I cannot put a
    checkmark there. At the present time I've tried it two ways, I've enabled
    the add-on in IE and looked to see if there is any difference in the "Java
    Quick Starter", and also tried it with the add-on disabled, and I get the
    same results. Grayed out. The system that I am currently having
    difficulty on is running Vista Home Premium 32b. It is a Intel Core 2 Quad
    CPU Q9300 @ 2.5GHz. It has 3 GB of memory. If there is anything else you
    may need to know that might help the troubleshooting, just let me know.

    I'm not going to worry about this too much since I can disable the add-on in
    IE and have the lag go away, but if you think that this could cause other
    problems down the road, then please let me know.
    Dirty Dawg, Mar 14, 2009
  17. Dirty Dawg

    Dirty Dawg Guest

    Oh crap, sorry I forgot to tell you about the other computer WITHOUT the
    same problem.

    It is a laptop running Vista Ultimate 64b, Intel Core 2 Duo CPU, T5550 @
    1.83GHz. It has 4GB of memory. Oh and both systems have Service Pack 1

    This is interesting. I checked the laptop in the same area Control
    Panel/Java/Advanced/Miscellaneous/Java Quick Starter, and it is also grayed
    out on that system. But there is no problems on that one. Also, I checked
    the "Java Helper" add-on to see if it was enabled, and it is, but still
    there is no problems on that machine....pretty weird if you ask me. Or is
    this type of thing typical???? Thanks for your time.
    Dirty Dawg, Mar 14, 2009
  18. Nothing wrong with the speed of your machine then. The fact that the "Java
    Quick Starter" is grayed out on your machine sounds more to me like you
    don't have the Sun JRE properly installed on your machine yet. So let's try
    one more time to get the Sun Java Runtime Environment installed properly.

    1. Use the following source to obtain the Setup file that installs Sun JRE
    on your machine:
    (Download the Sun JRE 6 Update 12 package and save it to your Desktop.)

    2. Make sure you have uninstalled all versions of Sun Java Runtime
    Environment from your machine, including the latest install you made.

    3. Disconnect from the Internet and temporarily disable any Real-Time
    Security application(s) you have running in the background.

    4. Right-click on the Sun JRE Update 12 setup file on your Desktop and run
    it as Administrator.

    Good luck,

    Donald Anadell
    Donald Anadell, Mar 14, 2009
  19. Dirty Dawg

    Dirty Dawg Guest

    Hello again, and thanks for the reply. I followed your instructions to the
    letter and it is still grayed out. I was on my laptop when I noticed your
    reply here, so I tried it on the laptop which has the 64b Vista Ultimate on
    it to see if I could get the grayed out problelm solved, but it didn't work.
    I really appreciate all your help, but it looks like this is just not going
    to work on my machines....don't know why, but since it is not stopping me
    from removing the lag in IE on my other machine (the laptop never had it),
    then I'm just going to forget about this (unless you know of any serious
    problems that this could cause down the road).

    Thanks to all that helped, I really appreciate it.
    Dirty Dawg, Mar 14, 2009
  20. Ok, I don't use the Vista Operating System here. So after a quick google
    search it appears that the "Java Quick Starter" Service that was implemented
    in JavaSE Update 10 is disable by default in Windows Vista, see the
    following Sun Java page for reference:

    "It is turned off in Windows Vista because Windows Vista offers its own
    preloading mechanisms."

    That would explain why it's grayed out in the Control Panel Applet on both
    your machines.

    So that brings us back to square one. Sorry, I'm out of ideas for
    troubleshooting your issue.

    Good luck,

    Donald Anadell
    Donald Anadell, Mar 14, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.