IE 7 Problem - Opera, Firefox, Safari does not have this problem

Discussion in 'Internet Explorer' started by Rev OOC, Aug 7, 2007.

  1. Rev OOC

    Rev OOC Guest

    Using Vista Ultimate ... Windows Media Player

    Specifically .. Opening IE 7 to http://beethoven.com and then clicking on
    "Play Live Radio" (Upper left), I get an error page "Internet Explorer
    cannot display the webpage" and it gives the 3 "Most likely causes". All
    three do not apply as...

    (1) I am connected to the internet (as I can connect to other web pages).
    (2) The website is NOT encountering problems (other browsers can connect)
    (3) There is no typing error in the address as I am following a link (that
    does work with other browsers).

    Below the "likely causes" is a "Diagnose" link and when I click on it, it
    reports "No problems found". Finally, a "More Information" link simply
    repeats what is above and is no help at all.

    I then opened up three other browsers that I occasionally use, Opera,
    Firefox, and Safari to the Beethoven.com page and clicked the link. All
    three opened Windows Media Player, and all three played the stream that IE 7
    refused to open.

    Just in case my IE 7 security setting were the problem, I opened "Internet
    Options", the "Security" Tab, and "Applied" "Default Level".

    Russ
     
    Rev OOC, Aug 7, 2007
    #1
    1. Advertisements

  2. Rev OOC

    Rob ^_^ Guest

    Hi Rev,

    This looks like the settings, though I have not tested this on Vista (XP
    pro, WMP)

    Open WMP and select the Tools>Options menu, select the Security tab,

    check the option "Do not prompt me before playing enhanced content that uses
    web pages"

    Save your changes and go back to beethoven.com and try again.

    Regards,
     
    Rob ^_^, Aug 7, 2007
    #2
    1. Advertisements

  3. Rev OOC

    Rev OOC Guest

    Thanks, Rob, but it wasn't it.

    The particular option you mentioned is not in the player that is included
    with Vista (v.11), but there are two options, one or both of which should
    take care of the situation. Both were checked. they are (1) "Run script
    commands and rich media streams when the player is in a web page" and (2)
    "Play enhanced content that uses web pages without prompting".

    And it seems fairly obvious that this is not the problem as Media Player
    does run with the other browsers. The problem is with IE 7, not with WMP.

    I also tried to run a different WMP stream from another web page, and it,
    too, failed in exactly the same way. But there was a difference. This second
    web page (http://paulharvey.com), also offered their stream via Quicktime
    (Ugh) and Flash Player (Ugh Ugh). Both those streams ran properly from the
    IE 7 web page.

    So there's a problem. i can work around the problem with the other browsers,
    but, frankly, I do not wish to do so. So I still need help.

    Rev
     
    Rev OOC, Aug 7, 2007
    #3
  4. Rev OOC

    Rob ^_^ Guest

    Hi Rev,

    I am not a Vista machine at the moment, but I am just about to do so. So I
    will have a look and test and get back to you shortly.

    Regards.
     
    Rob ^_^, Aug 8, 2007
    #4
  5. Rev OOC

    Rev OOC Guest

    Thanks, Rob. I'll be awaiting your reply.

    Rev

     
    Rev OOC, Aug 8, 2007
    #5

  6. Then break out that link and try doing something with it manually.
    E.g. try opening it explicitly from the Address bar or Run... dialog
    or manually open WMP (e.g. from the Start menu) and then in WMP
    use Ctrl-U and paste the URL into its Open URL dialog.

    http://www.beethoven.com/beethoven_ad.asx

    Hint: right-click, Copy Shortcut or get some context for doing a find in View Source.
    Then extract the link from there.


    Agreed. Instead of testing the problem link that procedure tests other links
    with which you may not have a problem.


    Once WMP is launched it appears that the browser's work is done
    for this link. So probably your only problem is that IE7 can't launch
    WMP, at least for this .asx file extension.

    In fact, telnet shows that the content-type is

    Content-Type: video/x-ms-asf

    which may be really what IE is trying to go by (and "sniffing" it to be sure.)
    So if your other browsers were going only by the file extension
    and that association is set up correctly you would have an explanation
    at least why they worked differently from IE.

    In case you want to try forcing IE to open by file extension too
    you can use the Security Settings Custom Level... dialog
    to do that (in the Miscellaneous section):

    Disable: Open files based on content, not file extension

    Hint: Alt-C then O, D, Space


    That is how to undo the above change. ; )


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Aug 10, 2007
    #6
  7. Rev OOC

    Rev OOC Guest

    Robert,

    Looks like you've really studied the underpinnings of IE.

    I tried your suggestions, and was easily able to open the link directly in
    WMP. But I knew that would work, the .asx file opened WMP in other browsers.

    One of the things I had tried prior to my first post was to actually paste
    the .asx file in the browser directly. I had the same exact results as when
    I clicked on the link ... the error page. By the way, there appears to be
    virtually no time between the click and the appearance of the error page. It
    appears that IE isn't even trying very hard.

    In the mean time, I've tried to open a few other .asx files (see, for
    example, the ones at http://paulharvey.com) and had the same result, so,
    while I haven't clicked on all .asx web streams, it appears that IE 7
    generally has a problem with them.

    Upon reading your reply, I went into Internet Options and made the change
    you suggested, that is to disable "Open files based on content ...". I
    closed IE 7 and reopened it. The problem was still there. I then rebooted,
    thinking that a reboot may have been necessary. The problem remained.

    Doing further research on the problem, I found several internet web page
    posts complaining of the same problem. One of them actually claimed a
    solution. Their solution did not work for me. Basically, their solution was
    to drill down to C: \Users \<User Name> \AppData \Local \Microsoft \Windows
    Media and change the name of folder "11.0" to something else. I changed the
    name to "Eleven.zero" and this did not work. In fact, when I went back to
    the folder to change it's name back, I found a new "11.0" along with the
    older folder "Eleven.zero".

    I also tried a couple of other things thinking they might help. I
    uninstalled "Haute Secure" and I reinabled UAC, which I had previously shut
    off. Neither of these actions helped.

    Thanks for your help, but I'm still looking for a solution.

    Rev
     
    Rev OOC, Aug 10, 2007
    #7
  8. ....

    Looks as if you have tried only two out of the three tests I mentioned:

    Hint: if you try starting it from the Run... dialog it might produce different
    symptoms because you would be asking explorer.exe to initiate it,
    not just iexplore.exe.

    In fact, when I try that (on XP) it still involves IE but the initial IE window
    quickly gets converted into a message window from WMP:
    <transcription>
    This enhanced content you are about to play use the following Web page.
    You should only open Web pages from sources that you trust.

    http://www.beethoven.com/nowplayingad.htm
    </transcription>

    WMP is still launched apart from that and starts playing
    (provided I'm not in a Work Offline state)
    but stops playing as soon as I reply No to the prompt
    about the Ad. With a Work Offline state I had to respond
    to both prompts in order to get the player going. YMMV.


    In case WMP is being chosen but just not launched for security/obscurity
    reasons you could check for that by running ProcMon to capture traces
    of your tests.


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Aug 12, 2007
    #8
  9. Rev OOC

    Rev OOC Guest

    Thanks, Robert.

    I have now tried opening http://beethoven.com/beethoven_ad.asx in "Run".
    Same result, the IE 7 error page.

    I also ran ProcMon (version 1.21) while running this test. Frankly, I'm over
    my head here. I don't know how to read the results, but I did run a "Find"
    on "wmp" and found it in serveral places. Virtually all the results were
    linked to either wmpnetwk.exe or iexplore.exe, but some had secondary links
    to various .dll files from WMP. It appeared that each instance the result
    was "Success".

    Perhaps you could give me a "hint' as to the use of ProcMon. While I do know
    a great deal about computers and the Windows Operating Systems (mostly from
    making bad mistakes), I was a Math Major back in 1963 when I learned Fortran
    IV (had access to an IBM 360 - 16Kb memory), and Computer Science was still
    a dream in the eye of most University Administrators.

    Rev
     
    Rev OOC, Aug 13, 2007
    #9

  10. Interesting! Unfortunately it looks as if you are going to have to find someone
    with Vista who doesn't have your problem symptom and willing to do the same
    test for you. Alternatively, if you can dual boot with a more basic system which
    doesn't have the problem symptom you could do your own baseline trace.

    FWIW I suspect that wmpnetwk.exe may be a Vista service.
    E.g. I see (on XP) most of what you are describing associated with a svchost.exe

    Or maybe not... E.g. perhaps it's due to a configuration option that you have
    set? ; ]

    http://www.microsoft.com/windows/windowsmedia/player/faq/sharing.mspx

    (Live Search for
    wmpnetwk site:microsoft.com
    )

    Check that you have the correct firewall settings for that option?
    Hint: Check: View All Answers and then do Ctrl-f (Find) for wmpnetwk
    Hmm... scroll ahead (or do some more finds for Vista) after that...


    Sorry, I don't know enough about WMP to be able to tell you what to look for
    especially because of that wmpnetwk.exe wrinkle. FWIW after all those
    wmp*.dll modules are checked and read in eventually iexplore.exe hands
    off to wmplayer.exe. I did see some security/obscurity zone checking
    going on in between those events; so, given Vista's preoccupation with such
    impediments that might be something worth checking for too. <eg>

    Oops. I guess that's the sort of thing I was thinking of when I said:

    I don't call it "security/obscurity" just because it sounds cynical... <eg>


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Aug 14, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.