IE 8 Menu Bar & Favorites Bar Black

Discussion in 'Internet Explorer' started by Bill Bradshaw, May 19, 2009.

  1. For some reason my menu bar and the favorites bar in IE 8 are black. I
    can not see the menu items but they are there and the pulldown menus are
    fine (black letters - gray background). Running WinXP Pro SP3 with the
    Windows Classic menus. How do I change the background color?
     
    Bill Bradshaw, May 19, 2009
    #1
    1. Advertisements


  2. Use Display Properties, Advanced Appearance, Menu, Color 1.
    You could also try 3D Objects, Color 1.

    Tip: press Win-D and right-click, Properties to start.


    ---
     
    Robert Aldwinckle, May 19, 2009
    #2
    1. Advertisements

  3. PA Bear [MS MVP], May 19, 2009
    #3
  4. Bill Bradshaw

    John Hansen Guest

    I change the Windows Theme and back to my own again.

    Problem is the black bar keeps coming back now and then after a boot.
    Is there a way of keeping that damn theme stick???

    /John
     
    John Hansen, May 19, 2009
    #4
  5. Bill Bradshaw

    John Hansen Guest

    I'm using built-in Windows Classic Style and still have the problem...

    /John
     
    John Hansen, May 20, 2009
    #5
  6. Bill Bradshaw

    rob^_^ Guest

    Hi John,

    You said "I change the Windows Theme and back to my own again"

    That is the problem.... there is something wrong with your custom theme...
    When windows starts it will apply only your custom theme settings, it won't
    first apply the Default Windows theme, then your custom theme.

    Make sure that your Custom theme has not been modified from a Vista Theme
    that you have downloaded to your XP machine. Somewhere in the .theme file
    there is an entry for a color attribute that is blank (""), which will get
    interpreted as being the color "black" = 0.

    Test if this is the case by changing your Theme to one of the Windows
    Standard Themes and then restarting your computer.

    If you are using themes downloaded from wincustomize.com or one of its
    affiliates, then the themes professionally produced by Stardoc Designs are
    the most stable. Some of the Themes downloaded from MS sites also suffer
    from this... make sure you only download/install themes suited to your
    windows version.

    The armature (freeware) themes are prone to being flakey as they do not
    include settings for all of the system metrics that theme files control. The
    same is true for Stardoc's Window Blinds WBA files.

    This is not really an IE issue. You may do better with support from
    wincustomize.com.

    Regards.
     
    rob^_^, May 20, 2009
    #6
  7. To avoid confusion, please begin a new thread about your specific problems &
    Windows version. State your IE version and full Windows version (e.g.,
    WinXP SP3; Vista SP2) in your first post.

    No-charge support for Internet Explorer 8 installation, set-up and usage
    (only) is available via the phone based on your locale through 31 December
    2009. Customers must be running Windows XP or Windows Vista in a non-domain
    environment.
    => US & CA Residents: 1-866-234-6020
    => Other locales: https://support.microsoft.com/oas/default.aspx?&prid=13043
     
    PA Bear [MS MVP], May 20, 2009
    #7
  8. Did not realize it was caused by a Window theme. Set the theme to
    Windows Classic and all is now right with the world. Over the last
    couple of days I had to reformat and reload WinXP so alot of things
    still need to be tweaked. Thanks to all for heading me in the right
    direction.
     
    Bill Bradshaw, May 20, 2009
    #8
  9. I started up IE 8 this morning and the black tool bars were back. I
    went into the themes and changed the theme from Windows Classic to
    Windows XP and the bars changed to gray with black lettering. I then
    changed the theme from Windows XP back to Windows Classic and the bars
    stayed gray with black lettering. There is some kind of bug here.
     
    Bill Bradshaw, May 20, 2009
    #9
  10. Bill Bradshaw

    John Hansen Guest

    I've used Windows as long as since Win95, and as far as I remember have
    never installed or used any theme other than the built-in themes, for sure
    not in Win XP which I use now. So I can't change back to a standard theme,
    I've never used anything else.

    Another strange thing happens every time when the black toolbar returns
    after a boot, the Sound scheme changes from my custom to the default scheme,
    so I have to change that also every time.

    I use WinXP SP3 & IE8.0.6001.18702. And if it means anything both in Danish.

    /John
     
    John Hansen, May 20, 2009
    #10
  11. Roger van Bracht, Jun 22, 2009
    #11
  12. Bill Bradshaw

    rob^_^ Guest

    Hi Roger,

    There's no byline on that article..... they are nearly right... not an IE8
    issue, but rather a Windows issue and the Advanced appearance dialog.

    I can't post pictures here but here is an extract from my own article.

    No third-party software is required to reproduce the issue as it is inherent
    in all Windows platforms supporting User Themes from the Control Panel. The
    common factor to reproduce the issue on all platforms is to choose either a
    Windows Classic or a Windows Standard desktop theme and to then change the
    background color of 3-D Objects to black and the font color of 3-D Objects
    to a contrasting color without changing the font color of Menus. Menus
    inherit the background color of 3-D Objects, but not the font color. By
    default Menu font colors are black, so if the background color of 3-D
    Objects is changed to black, Menus will inherit the black background color
    and retain the black (default).
    The sample screen shots were taken from a Vista x86 SP1 machine, with
    Stardocs Windows’ Blinds software installed and the custom Desktop theme
    “Space†installed.
    On an XP, Vista or Win7 machine open the Desktop Appearance dialog.

    And choose either a Windows Standard or a Windows Classic color scheme.
    Then click the ‘Advanced’ button to display the Advanced Appearance dialog.
    Select ‘3-D Objects’ from the ‘Item’ dropdown.


    Change the Background color of 3-D Objects to black (or any dark color) and
    the font color to white (or any contrasting color).

    Next select ‘Menus’ from the Item dropdown….

    Note that the background color of Menu items has inherited the background
    color of 3-D Objects, but the font color has remained the default black.
    Leave the Menu font color unchanged for the time being and click ‘OK’ to
    return to the ‘Appearance Settings’ dialog.

    Press the ‘Apply’ button to apply your theme changes to the current desktop
    and open applications.
    Open IE and observe the Menu Bar….


    I should have it posted on a publicly accessible site soon.

    So you should find that the fix is to open your Advanced Appearance dialog
    and change the font color from black to a contrasting color.

    If you have any third party theme software installed open mscofig and
    disable any startup items that will re-apply the custom theme the next time
    that Windows start. (You will notice that with theme software installed the
    desktop flickers a number of times and refreshes the Desktop icons a number
    of times indicating that another process is doing a global drawing update).

    Regards.
     
    rob^_^, Jun 22, 2009
    #12
  13. Bill Bradshaw

    rharrold Guest

    I have had the same, and apparent random problem, with black background
    toolbars on one of several pc's that are apparently configured the same
    except: the problem pc had 32 bit color, a personal picture displayed on the
    desktop with required a modified theme.

    I reset colors to 16 bit, theme to classic (which removed the personal
    picture displayed on my desktop.)

    I reset the desktop to show the personal picture, left the color density at
    16 bit and theme at classic.

    Problem gone.
     
    rharrold, Jun 27, 2009
    #13
  14. Bill Bradshaw

    wysiwally Guest

    ::I realize I'm in a Vista thread but I see the same exact problem of
    blacked out menu bar in IE8 here that I see and had with XP Pro. M
    relevent PC info: XP Pro, IE8, \"windows classic\" display theme, ATI
    video card

    I was able to find the culprit on my PC. It was a service provided by
    the ATI video card (Ati Hotkey Poller). By disabling this service the
    black menu bar seen in IE8 when using the \"Windows Classic style\"
    theme was fixed. And I mean fixed permanently, not just until I reboot

    Go to MSCONFIG, \"Services\" tab and uncheck the \"Ati
    Hotkey Poller\". There may be a place in the ATI software where you
    can disable the Ati Hotkey Poller but I haven't got that far in the
    troubleshoot process. I do know that it is the sole service
    resposible for the black menu issue in IE8 on my PC. If this works
    for you please post it to as many threads as you can so that word gets
    around. I spent hours with a good Microsoft support guy finding this
    and know there are many others with the same problem who can benefit
    from my good fortune. If you don't care about which display \"theme\"
    you use the \"Windows XP style\" theme doesn't have this bug, only the
    \"Windows Classic style\" theme does. (Display area from Control Panel)


    ::
     
    wysiwally, Jul 16, 2009
    #14
  15. Bill Bradshaw

    Splinterman Guest

     
    Splinterman, Jul 20, 2009
    #15
  16. Bill Bradshaw

    artoo20 Guest

    Found the easiest way to recover from this black menu bar bug.

    Click on Start button

    Log off from user name account.

    Log in again and menu bar will return to your original settings :)
     
    artoo20, Jul 29, 2009
    #16
  17. Bill Bradshaw

    AFM Guest

    My solution: MORE RAM
     
    AFM, Oct 23, 2009
    #17
  18. Bill Bradshaw

    fastfreddy Guest

    This is a copy and paste from another place and this FIXED my problem!

    I was able to find the culprit on my PC. It was a service provided by
    the ATI video card (Ati Hotkey Poller). By disabling this service the
    black menu bar seen in IE8 when using the "Windows Classic style"
    theme was fixed. Go to MSCONFIG, "Services" tab and uncheck the "Ati
    Hotkey Poller". There may be a place in the ATI software where you
    can disable the Ati Hotkey Poller but I haven't got that far in the
    troubleshoot process. I do know that it is the sole service
    resposible for the black menu issue in IE8 on my PC. If this works
    for you please post it to as many threads as you can so that word gets
    around. I spent hours with a good Microsoft support guy finding this
    and know there are many others with the same problem who can benefit
    from my good fortune. If you don't care about which display "theme"
    you use the "Windows XP style" theme doesn't have this bug, only the
    "Windows Classic style" theme does. (Display area from Control Panel)
     
    fastfreddy, Dec 12, 2009
    #18
  19. We shall alert the media...
     
    PA Bear [MS MVP], Dec 12, 2009
    #19
  20. Graham Hants UK

    I had the exact same prob (with the Black) Also running IE8 on Xp with
    Windows
    Classic display - I found by changing the display (in properties) to Xp and
    then back to classic, the problem cleared !

    Try it -
    Graham
     
    Graham Hants UK, Dec 18, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.