IE interprets Xml meta content of a Jpg image which resides within a Zip archive (IE bug?)

Discussion in 'Internet Explorer' started by style, Sep 3, 2007.

  1. style

    style Guest

    Hello everybody

    Here is my scenario: I created a Tiff file with Photoshop 9.0.2 (CS2) on a
    Mac computer. Photoshop automatically writes some xml content into the
    header of that Tiff file (meta data). If you open the Tiff in notepad, it
    looks like this:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN"
    "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>com.apple.print.PageFormat.PMHorizontalRes</key>
    .... etc.

    Then I used a library to programmatically convert that Tiff to a JPG file.
    The xml meta data is preserved thus the JPG file still includes the above
    xml content. Now I zipped the JPG and put it on a webserver.

    If I try to download this Zip file with IE (6, 7 - it doesn't matter),
    Internet Explorer seems to look into the Zip file and interpret the xml
    content. IE then does not ask the user whether he'd like to open or save the
    Zip file but instead it tries to display the xml content which results in a
    xml parsing error. Here is the sample link:

    http://www.mattenweg.ch/test.zip

    If you open the above link in Firefox you just get the save file dialog as
    expected. Could someone explain me what IE is doing here? Is this a bug? Is
    there any solution for this problem?

    I found out that if the JPG resides in a folder within the Zip archive, the
    Zip can be downloaded by IE too. Strange, isn't it?

    Thanks for any help

    Kind regards
    Thomas
     
    style, Sep 3, 2007
    #1
    1. Advertisements

  2. style

    Rob ^_^ Guest

    Hi Style,

    Tools>Internet Options - Security tab, Internet Zone, Custom button - "Open
    files based on content, not file extension"

    Regards.
     
    Rob ^_^, Sep 3, 2007
    #2
    1. Advertisements

  3. style

    style Guest

    Hey Rob

    Thanks a lot. What a pitty Internet Explorer doesn't use the other option as
    default.

    Anyway thank you for your help.
    Thomas
     
    style, Sep 3, 2007
    #3
  4. style

    Rob ^_^ Guest

    Glad to help. IE is a complicated beast for the best of us.
    Regards.
     
    Rob ^_^, Sep 3, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.