IE6 Over-active active content blocker

Discussion in 'Internet Explorer' started by saxonhawthorn, Jun 24, 2006.

  1. Running IE6 under XP Pro I continually get the message

    "To help protect your security, Internet Explorer has restricted this file
    from showing active content that could access your computer. Click here for
    options ..."

    This happens even when viewing pages I have just created on my own PC using
    site builder software, and when I have tried to set the security level to Low
    for local pages. Actually I have the impression that nothing I set in the
    site security options actually gets saved, and that the defaults invariably
    apply whatever I try to set, even though I am logged in with full
    administrator rights.

    I should be grateful for any assistance. Can anybody help please?
     
    saxonhawthorn, Jun 24, 2006
    #1
    1. Advertisements

  2. saxonhawthorn

    Don Varnau Guest

    Hi,
    You're encountering the "local machine zone lockdown" feature of [XP] SP2.
    http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2brows.mspx#EKQBG

    There are three workarounds for this:
    1. Rename each .HTM file to .HTA while it's still on your hard drive. HTA
    files aren't as restricted.
    2. Give each page the "Mark of the Web"
    http://msdn.microsoft.com/library/default.asp?url=/workshop/author/dhtml/overview/motw.asp
    3. Internet Options> Advanced> Security> check "Allow active content to run
    in files on My Computer ."
    You will, of course, be giving up some of the enhanced security of the XP
    SP2 update.
    http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2brows.mspx#EIAA

    If this is happening on webpages which you know to be safe, you could place
    that site in Trusted Sites.
    Internet Options> Security> Trusted Sites> Uncheck "Require server
    verification" and enter the site as (for example) *.amazon.com

    Hope this helps,
    Don
    [MS MVP- IE]
     
    Don Varnau, Jun 24, 2006
    #2
    1. Advertisements

  3. Thank you very much for your quick and helpful response. It's going to take
    me a short while to try these out, then I'll post the result.

     
    saxonhawthorn, Jun 24, 2006
    #3
  4. Yep, that worked!

    Thank you very much Don. I'm now a happy man again. :)



     
    saxonhawthorn, Jun 24, 2006
    #4
  5. saxonhawthorn

    Don Varnau Guest

    You're welcome. Thanks for reporting back.

    Don
    [MS MVP- IE]

     
    Don Varnau, Jun 24, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.