IE7 blank history

Discussion in 'Internet Explorer' started by Simpleuser, Apr 5, 2007.


  1. Have you checked the other desktop.ini in the History tree too?

    Have you looked at NTFS permissions for all those objects as well?
    E.g. currently some Vista users are having a problem with the permissions
    of the AntiPhishing directory. Perhaps that OS is messing up History
    objects in a similar way? E.g. if you didn't have write permission in the
    cloned directory (which I guess would have to include the desktop.ini)
    perhaps you would have a reason for it being 0 bytes (blank)?

    FWIW I'd try recreating the whole directory and monitor its recreation
    using ProcMon. I already made that suggestion somewhere in this thread
    but I don't know if the idea registered with either poster. ; )


    Robert
    ---
     
    Robert Aldwinckle, May 17, 2007
    #21
    1. Advertisements

  2. Simpleuser

    Trawler Guest

    Dear dean-dean

    My answers to your questions are in CAPS below.

    Thanks for your continued help.

    Best,

    Trawler

    Does it have a special icon (not
    Also, do you see a folder called "Low"? YES
     
    Trawler, May 17, 2007
    #22
    1. Advertisements

  3. Simpleuser

    dean-dean Guest

    Good job, Trawler.

    The reason Windows Explorer sometimes shows "greyed out" folders and files,
    is to show you that those folders and files are normally hidden. You have
    to do a few more steps, but don't give up hope.

    First, in Control Panel > Folder Options, on the View tab, do one more
    thing, besides what you have done in Folder Options so far. UNcheck "Hide
    extensions for known file types" (Apply, OK). That way you will be able to
    see what type of file that a file really is, by seeing its extension. For
    example, the file "desktop" will become "desktop.ini".

    I think the easiest way to go about this is for you to create a temporary
    New User on your computer (you can remove it when your History problem is
    fixed). On the Start Menu, click on your User picture, at the top of the
    menu on the right side. When the "User Accounts" window pops up, click on
    "Manage another account". Then click on "Create a new account". Make the
    new account an Administrator account. You can name the account anything you
    want, except "Will". Try "New" as the name. You don't need to make a
    password for the New account, since it's only temporary.

    Now Log off. Log on to the New account.

    In Control Panel >Folder Options, do this again: on the View tab, do three
    things. Choose to "Show hidden files and folders", UN-check "Hide protected
    operating system files (Recommended)", and UNcheck "Hide extensions for
    known file types" . (Apply, OK).

    Open Computer on your Start Menu, and navigate to

    C:\Users\Will\AppData\Local\Microsoft\Windows

    Right-click on the "History" folder, and choose Rename. Change the name to
    "OldHistory".

    Now Log Off from the New account, and Log on to Will. Type shell:history in
    the Start Menu like you did before. What do you see? Try Internet Explorer
    to see if the History pane is working. Go to a few sites. If is still not
    working, you may have to do only one more thing to fix it.
     
    dean-dean, May 17, 2007
    #23
  4. Simpleuser

    Trawler Guest

    Hey dean-dean

    Having followed your instructions the result of shell:history is:

    C:\Users\Will\AppData\Local\Microsoft\Windows\History

    So the folder name has not changed.

    In this History Folder there is a Folder called History.IE5 and a file
    called desktop.ini

    In History.IE5 there are two files: desktop.ini and index.dat

    Tried IE7 but still no history.

    (Incidentally, the history works fine in the new user account. But then I'm
    sure you aren't surprised to hear that's the case.)

    Trawler
     
    Trawler, May 17, 2007
    #24
  5. Simpleuser

    dean-dean Guest

    Hi Trawler,

    Yes, you're on the right track. When you logged on to your Will account,
    The System created a new History folder automatically when it couldn't find
    a folder called History. When you typed shell:history that confirmed it.
    In the folder "Windows", at this location:

    C:\Users\Will\AppData\Local\Microsoft\Windows

    you will see a new "History" folder (dated today) and a folder called
    "OldHistory".

    Things are going as I expected. There's a bug in Vista that you will now
    have to fix. Navigate to this folder, so that this is showing in your
    address bar:

    C:\Users\Will\AppData\Local\Microsoft\Windows\History\Low

    Right-click the file called "desktop.ini". Choose Copy (NOT Cut!). Now
    navigate back to this folder, so that this is showing in your address bar:

    C:\Users\Will\AppData\Local\Microsoft\Windows\History

    Right-click an empty spot in the window, and choose Paste. A dialog will
    pop up asking you what to do. Choose "Copy and Replace".

    Close Explorer. Log Off. Then Log back On to your Will account. Type
    shell:history. Now what do you see? Try Internet Explorer.

    Don't remove your New account just yet; I'll tell you how to do that when
    things are going okay.
     
    dean-dean, May 17, 2007
    #25
  6. Simpleuser

    Trawler Guest

    Hi again dean-dean

    You wrote:

    Navigate to this folder, so that this is showing in your address bar:
    C:\Users\Will\AppData\Local\Microsoft\Windows\History\Low

    Bu there is no 'Low' folder in 'History'. There is a 'Low' folder in
    OldHistory though. Did you mean me to navigate to that one instead?

    Trawler
     
    Trawler, May 17, 2007
    #26
  7. Simpleuser

    dean-dean Guest

    Hi Trawler,

    You might not have a "Low" folder if User Account Control (UAC) is turned
    off. You can do this:

    Go to the "History.IE5" folder, so that this is the location in your address
    bar:

    C:\Users\Will\AppData\Local\Microsoft\Windows\History\History.IE5

    Right-click on the file "desktop.ini". Choose Copy (not Cut).

    Then navigate to back to "History", so that this is the location in your
    address bar:

    C:\Users\Will\AppData\Local\Microsoft\Windows\History

    Right-click an empty spot in the "History" folder window, and choose Paste.
    A dialog will pop up asking you what to do. Choose "Copy and Replace".

    Close Explorer. Log Off. Then Log back On to your Will account. Type
    shell:history. Now what do you see? Try Internet Explorer.

    We'll get it right at some point soon...
     
    dean-dean, May 17, 2007
    #27
  8. Simpleuser

    Trawler Guest

    dean-dean you're a LEGEND!

    That's worked - I do now have a history.

    Thank you so much for your perseverance and time.

    Can we now just go through the deletion of User account and then we're done!

    Thank you again. I will rate these posts highly!

    Trawler
     
    Trawler, May 17, 2007
    #28
  9. Simpleuser

    dean-dean Guest

    Whew.

    Glad to hear things are working, Trawler.

    To remove the New Account, go to Control Panel > User Accounts > "Manage
    another account", when you're logged on to Will.

    You can also go to C:\Users\Will\AppData\Local\Microsoft\Windows,
    right-click on the "OldHistory" folder, and Delete it.

    Then, you may want to go to Control Panel > Folder Options, and, on the View
    tab, put a checkmark next to "Hide protected operating system files
    (Recommended)", and choose "Do not show hidden files and folders". (I
    would at least leave the other change you made, for "Hide extensions for
    known file types" as it is now, so that you can always see your file
    extensions. (Sometimes, it helps to know what kind of a file a file is, and
    it's icon is not always helpful).

    Happy Surfing!
     
    dean-dean, May 17, 2007
    #29
  10. Simpleuser

    dean-dean Guest

    Hi Trawler. To add to my previous post, there are a few more notes.

    In IE7 > Tools > Internet Options, on the General Tab, if you click on
    Settings under "Browsing History", you can specify the number of days to
    keep pages in your history, under the heading "History".

    Also, if you sort the History pane, by using the little down-arrow next to
    History at the top of the pane, and choose "By Date", you may see some
    entries that no longer work (they won't expand), because your History folder
    is brand new. Just right-click the entries and choose Delete. This will
    get your registry up to speed.

    If you haven't turned on "Hide protected operating system files" and
    switched to "Do not show hidden files and folders", yet, your History folder
    should show a special icon, when you go to
    C:\Users\Will\AppData\Local\Microsoft\Windows.

    Using shell:history should now show a Special View (you won't see files and
    folders any more, but rather Days listed that you can click on to show Sites
    (Internet Hosts), which you can then open to show all the particular
    addresses that you went to at that Site. Just one more way to view
    History...

    To delete a user account, open the User Accounts program, click the
    appropriate account name, and then click "Delete the account." Windows now
    asks you if you want to preserve the contents of this person's Documents
    folder. (I would say no). But If you did click the Keep Files button,
    you'll find a new folder, named with the same name as the dearly departed,
    on your Desktop. You can delete that folder if you don't want it.

    All-in-all, your problem should be solved. Somehow your old History folder
    became corrupt (and from what I saw from your detective work, in more ways
    than one), and System didn't repair it accurately. This can happen
    occasionally, but I wouldn't worry about it happening again, as it's kind of
    a rare occurrence.

    Take care.
     
    dean-dean, May 17, 2007
    #30
  11. Simpleuser

    Trawler Guest

    Hey dean-dean

    All of this is very helpful indeed - thank you so much.

    A couple of hitches:

    For some reason I can't delete the OldHistory folder - a dialogue box keeps
    popping up during the deletion process that says I need permission. I click
    OK and the box pops up again until I cancel it.

    Also, moving on to your last email, when I use shell:history there is a
    calendar icon displayed named today, but when I double click this there are
    no Internet hosts listed. However the urls are listing fine in the History
    listing accessed via IE7.

    I haven't switched off any of the folder options.

    Any thoughts? All of 'em are gratefully appreciated.

    Trawler
     
    Trawler, May 17, 2007
    #31
  12. Simpleuser

    dean-dean Guest

    Hi Trawler. As for deleting the Old History folder, try this:

    Go to Start, All Programs, Accessories, Command Prompt and right-click the
    Command Prompt icon. Choose Run as administrator. Copy and Paste the
    following into the prompt:

    takeown /f C:\Users\Will\AppData\Local\Microsoft\Windows\OldHistory

    Press Enter on your keyboard. Then Copy and Paste this at the prompt:

    icacls C:\Users\Will\AppData\Local\Microsoft\Windows\OldHistory /GRANT
    ADMINISTRATORS:F

    Press Enter on your keyboard. Close Command Prompt. Now try to delete
    OldHistory, using Explorer.

    As far as that Sites thing when you run shell:history, you will only see
    "Today" listed, but tomorrow you'll see two days listed, and so on, as your
    History gets older. That's odd that you are not seeing Internet Hosts
    folders when you click on "Today". Are you seeing a new view, with in the
    column heading "Internet Hosts", or is nothing happening when you click on a
    calendar icon? Log Off and then On again. Or reboot. Try opening IE7, go
    to several sites, and then in the History pane, click on the little
    down-arrow next to History at the top of the pane, and choose "By Date".
    Delete any entries that don't expand when you click on them. Then click on
    the little down-arrow again, and choose "By Site". Do Site folders appear,
    with the special clock/green arrow icon? Does "By Order Visited Today"
    work?

    We might have to look inside the contents of your desktop.ini, if it doesn't
    seem to straighten itself out...
     
    dean-dean, May 17, 2007
    #32
  13. Simpleuser

    Simpleuser Guest

    Hi Dean-Dean. Many thanks for the reply. I need to ask a couple of
    questions before following your instructions. The "desktop.ini" file in the
    "History" folder on the path
    "Users\Phillip\AppData\Local\Microsoft\Windows\History" is indeed blank but I
    get a flag "Access Denied" for the desktop.ini file when I double click on
    it. This History folder contains another folder "History.IE5" but and this
    is the one without the clock icon. The History folder also contains a folder
    "Low" which does have the clock icon. Incidentally, the fourth item in the
    History folder is a file called "DESKTOP (1).INI" -- I hope I won't confuse
    you by saying that the "desktop.ini" was last modified14/03/2007 and "DESKTOP
    (1).INI" was last modified 27/07/2000 or so neither appears to be in current
    use. I wonder if the very old one was wrongly transferred when I used to be
    Easy Transfer tool.
    Moving to the " Low" folder (with the clock icon) this also contains a
    "History.IE5" folder and the same pair of "desktop" files.
    The "History.IE5" folder on the path
    "Users\Phillip\AppData\Local\Microsoft\Windows\History" contains a folder
    "MSHist012007031520070316" the file "desktop.ini" and a file "index.dat",
    this last one being modified on today's date and I assume this is my current
    history file.
    The "History.IE5" folder on the path
    "Users\Phillip\AppData\Local\Microsoft\Windows\History\Low " only contains
    the "desktop.ini" and "index.dat" files -- and this index file was last
    modified 08/04/2007 so doesn't appear to be in use.
    I hope I have explained better this time where the clock icon appears as it
    seems that Internet Explorer looks where the clock icon is but my current
    history is in the other folder. I wanted to check with you first as it seems
    the clock icon is not quite where you expected it to be. I can see that the
    contents of the various " desktop.ini" files are different and didn't want to
    start shuffling them around before being clear which one goes where.
    Look forward to hearing from you, regards,
     
    Simpleuser, May 18, 2007
    #33
  14. Simpleuser

    dean-dean Guest

    Hi Simpleuser,

    It looks as though both your History and ~History folders have been on your
    computer for quite some time, and neither look to be in very good shape.
    Both have obvious desktop.ini problems (and you shouldn't be getting an
    "Access Denied" when double-clicking any of the desktop.ini's). Are you the
    only user on your computer, or is there another user's name that you can log
    on to? Also, do you have User Account Control turned on or off? (UAC is
    the creator of the Low folder in History).

    Basically, the System will create a brand new History folder automatically,
    which is what I think needs to be done, but you will have to be logged on to
    another Administrator Account to accomplish this end.

    If you have no other Administrative account that you can log on to, I think
    the easiest way to go about this is for you to create a temporary
    New user account on your computer (you can remove it when your History
    problem is fixed). On the Start Menu, click on your User picture, at the
    top of the menu on the right side. When the "User Accounts" window pops up,
    click on "Manage another account". Then click on "Create a new account".
    Make the new account an Administrator account. You can name the account
    anything you want, except "Phillip". Try "New" as the name. You don't need
    to make a password for the New account, since it's only temporary.

    Now Log off. Log on to the New account.

    In Control Panel > Folder Options, on the View tab, do three
    things. Choose to "Show hidden files and folders", UN-check "Hide protected
    operating system files (Recommended)", and UNcheck "Hide extensions for
    known file types" . (Apply, OK).

    Open Computer on your Start Menu, and navigate to:

    C:\Users\Phillip\AppData\Local\Microsoft\Windows

    Right-click on the "History" folder, and choose Rename. Change the name to
    "OldHistory".

    Now Log Off from the New account, and Log on to Phillip. Type shell:history
    in the Start Menu like you did before. What do you see? Try Internet
    Explorer to see if the History pane is working. Go to a few sites. If is
    still not working, you may have to do only one more thing to fix it.

    Keep the temporary New account until the History problem is fixed. I'll
    help you remove it when we get to that point.
     
    dean-dean, May 18, 2007
    #34
  15. Simpleuser

    WDB Guest

    I had the exact same problem as Trawler and your solution worked perfectly.
    Thanks much from all of us who like our "technology" to work!
     
    WDB, May 18, 2007
    #35
  16. Simpleuser

    Trawler Guest

    Hey dean-dean

    I followed you instructions but still can't delete OldHistory. I get the
    same dialogue box saying I need permission.

    Using shell:history I get an icon for Thursday and Today. If I double-click
    Thursday I do get a new view with the Internet Host heading - but only one
    site appears (of the 8 or so I can see in my IE7 history listing for
    Thursday) and this 'site' is in fact a World of Warcraft launcher site url,
    not a site I visited per se. If I double click on Today there are no sites
    listed at all.

    History within IE7 is still working. So I opened IE7, went to several
    sites, and then in the History pane, clicked on the little down-arrow next to
    History at the top of the pane, and chose "By Date". All entries expanded
    when clicked. Then I clicked on the little down-arrow again, and chose "By
    Site". Site folders with the special clock/green arrow icon appeared? "By
    Order Visited Today" also works, but icons appear with the explorer logo, not
    as folders.

    Perhaps we need to look at desktop.ini as you suggest?

    Best,

    Trawler
     
    Trawler, May 18, 2007
    #36
  17. Simpleuser

    Simpleuser Guest

    Hi Dean-Dean,
    Thanks again for your speedy reply -- and as before it is good news and bad
    news. I have followed your instructions which seemed to work fine but the
    bad news is that the history tab in IE7 is still blank. So I will wait for
    your instructions.
    Answering your other questions -- I am the only user of my PC which is just
    over two months old now, but it has been back to the vendor because of a
    problem with the DVD drive. I would expect the vendor has used IE7 to
    download bits of software so that would be the only other usage of IE7. As
    you have suspected I do have UAC turned off for now (if it is helpful in
    solving this problem I can turn it back on) because it stops the licence
    validation check that Photoshop carries out and otherwise I have to re-enter
    all the licence details every time I open the application -- it's a
    well-known problem with Photoshop and Vista.
    From what you have said, hopefully the problem is nearly fixed.
     
    Simpleuser, May 18, 2007
    #37
  18. Simpleuser

    Simpleuser Guest

    Hi Dean-Dean,
    I forgot you had asked about the results of "shell: history" -- the folder
    is there but empty.
     
    Simpleuser, May 18, 2007
    #38
  19. Simpleuser

    Simpleuser Guest

    Hi Dean-Dean,
    I forgot you had asked about the results of "shell: history" -- the folder
    is there but empty.
     
    Simpleuser, May 18, 2007
    #39
  20. Simpleuser

    Simpleuser Guest

    Hi again Dean-Dean,
    I hadn't realised that logging off and logging on again the preferences for
    folder views had been lost. Now I have reset it as you asked the "history"
    folder is not empty.
    It contains a desktop.ini file that is empty -- I have access to it. It
    also contains a folder "History.IE5" with the clock icon on it -- and in turn
    this folder contains another "desktop.ini" file with a small amount of
    information in it, and again I have access to that; and the folder also
    contains an "index.dat" file.
    Hopefully that is helpful.
     
    Simpleuser, May 18, 2007
    #40
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.