IE7 Explorer mode doesn't work on Win2k3 server

Discussion in 'Internet Explorer' started by Peter J. Dickason, MCSE, Jan 18, 2010.

  1. We're building a terminal server/Citrix farm consisting of 32 and 64 bit
    servers. We have also decided to make the jump from IE6 to IE7 thinking all
    the bugs have been worked out by now for TS. So we upgraded our servers and
    found that explorer mode no longer works. We use explorer mode to publish
    data folders and had to revert back to explorer.exe. The command line is
    C:\WINDOWS\ie7>iexplore.exe -e S:\ and it brings up page
    http://xn--mjrs5sloh/. What the heck is xn--mjrs5sloh?? Any ideas?

    Thanks
    Pete
     
    Peter J. Dickason, MCSE, Jan 18, 2010
    #1
    1. Advertisements

  2. Peter J. Dickason, MCSE

    Bob Campbell Guest

    No, I have no idea what xn--mjrs5sloh is. But why not jump to IE8 (while
    you're at it)?
     
    Bob Campbell, Jan 18, 2010
    #2
    1. Advertisements

  3. Update: We found no parameters work on these new servers. -k, -nohome,
    nothing. I'm convinced MS pushed out a cumulative update for IE which
    disabled command line parameters as a push to IE8 since this problem is
    identical on all 4 freshly built servers. ;)

    Going to IE8 is not an option. The entire company will be on this farm
    which consists of thousands of users so all websites must work. We're not
    convinced that all websites work with IE8 with everything we're reading. In
    any event there is nothing that IE8 gives over IE7 that would keep a user
    from doing his job. We're not happy about going back to IE6 but that's not
    out of the realm of possibliities. It's stable and it works.

    Thanks
    Pete
     
    Peter J. Dickason, MCSE, Jan 18, 2010
    #3
  4. Peter J. Dickason, MCSE

    rob^_^ Guest

    Hi Peter,

    Please post back with your IE versions (from help about menu) that you have
    upgraded to.

    How did you deploy these? Slipstream?

    I am very surprised that the IE command line parameters do not work on your
    systems. Perhaps you are pointing to the x64 version of IE? or the wrong
    path to iexplore.exe

    I can't remember if IE7 was/is compatible with Win2k3. Perhaps you are
    running it in enhanced security mode (Internet Security zone defaults to
    High). But that security enhancement only applies to later server versions(I
    think).

    Regards.
     
    rob^_^, Jan 18, 2010
    #4
  5. Peter J. Dickason, MCSE

    Dan Guest

    Some of the command line switches were dropped in IE7, -s being one of
    them - IE7 and 8 no longer have an "explorer" mode. However, I did test this
    switch with IE8 on XP (I don't have access to a TS setup so I can't confirm
    it works there too), and the -s switch causes Windows Explorer to be loaded
    with the specified location.

    As to xn--mjrs5sloh in the URL, that's odd. Are you sure you have -e S: in
    the command line when this occurs, and nothing else?

    -nohome is odd in that it does work, sort of - I get a blank tab with the
    title "Connecting", but IE8 itself is doing nothing. It's definitely not
    loading the home page though.
     
    Dan, Jan 19, 2010
    #5
  6. yes it looks like it is trying to translate any parameter into a webpage.

    -e causes http://xn--mjrt95e/

    -nohome causes http://xn--e-op7b75lxva/

    -s causes http://xn--17x/

    -byteme causes http://xn--e-424bk54ac7g/ :)
    I'm to the point where I'm uninstalling/reinstalling IE7. I'll provide an
    update.

    thanks
    Pete
     
    Peter J. Dickason, MCSE, Jan 19, 2010
    #6
  7. Hi Rob,

    C:\Windows\IE7\iexplore.exe 7.0.5730.13 64-bit edition (the version of
    the EXE is 6.0.3790.1830. This is where we run iexplore -e from)

    C:\Program Files\Internet Explorer\iexplore.exe 7.0.5730.13 64-bit
    edition (Version of EXE 7.0.6000.16945)

    C:\Program Files (x86)\Internet Explorer\iexplore.exe 7.0.5730.13
    (Version of EXE 7.0.6000.16945)
    Windows update, during installation. First pass told not to ask to install
    IE8 again. It then offers IE7.
    As noted above, to publish data folders we use iexplore.exe from
    C:\Windows\IE7 which is what we found documented what we should use.
    We disable IE ESC for all users on the terminal servers.
    We configuire a policy on the Terminal Server OU with the following
    settings.

    User \ Administrative Templates \ Windows Components \ Internet Explorer \
    Internet Control Panel \ Securty Page
    Intranet Sites: Include all local (intranet) sites not listed in other
    zones Enabled
    Intranet Sites: Include all network paths (UNCs)
    Enabled
    Intranet Sites: Include all sites that bypass the proxy server
    Enabled
    Use Pop-up blocker
    Disabled

    Intranet Zone security set to Medium-Low in IE Maintenance policy, not
    security page.

    Any ideas?

    Thanks again for your help.
    Pete
     
    Peter J. Dickason, MCSE, Jan 19, 2010
    #7
  8. Peter J. Dickason, MCSE

    Dan Guest

    That iexplore.exe is *not* IE7. The IE7 folder is the rollback folder for
    IE6 - this is where the old IE6 files are kept for when you uninstall IE7.
    This may explain why you're seeing it not working. It looks like what's
    occuring is that you're loading the IE6 executable but it's trying to call
    the IE7 DLLs, so you end up with the versions mixing and unexpected things
    happening.
    Where was this documented?

    The C:\Windows\IE7 folder should, from what I can tell, never be used. You
    should be using one of the other paths in Program Files, depending on
    whether you want 32-bit or 64-bit IE running.
     
    Dan, Jan 19, 2010
    #8
  9. Hi Dan,

    That's surprising. That's how Citrix tells you to publish a data folder
    since using explorer.exe is not supported.
    http://support.citrix.com/article/ctx922603 This has worked for years
    pre-IE7. The note in the document states to use C:\Windows\IE7. Are they
    wrong? Do I need to use Firefox as noted in
    http://support.citrix.com/article/CTX112195?


    Unfortunately we cannot open a data folder in IE running from one of these
    folders. It throws up an error. Which is why they state to use the one
    under \Windows\IE7.

    thanks
    Pete
     
    Peter J. Dickason, MCSE, Jan 19, 2010
    #9
  10. Peter J. Dickason, MCSE

    Dan Guest

    I would think it's wrong, yes. It looks like it's a kludge to work around
    issues with IE7, and somebody thought loading the IE6 exe from that backup
    folder was a way around it. Obviously it doesn't work correctly as you've
    discovered. It may have worked 18 months ago, but IE patches may have
    rendered that workaround useless as you are discovering.

    And as to "worked of year pre-IE7", how so? The IE7 folder doesn't exist
    until IE7 is installed, so could not possibly have worked if you only had
    IE6. If you really have been using this path for the past couple of years,
    then you've had IE7 installed a lot longer than you realise. I'm assuming
    that you meant you just used the path to IE6 before and have changed it to
    the new folder, but your reply is a little vague.
    I personally would try the full path to IE7 first. That article is about
    receiving an error message - until you try the full path, you don't know if
    you get that error message. Plus it also states that when you press OK the
    page is loaded as normal.

    Those documents are also both over 18 months old now.
    What's the error? The one in CTX112195?

    CTX112195 states that the other workaround is to uninstall IE7, so you're
    back to IE6 again. Why can't you do that?
     
    Dan, Jan 20, 2010
    #10
  11. We have not upgraded to IE7 until now. So what I meant was that in IE6 it
    worked fine from C:\Program Files\Internet Explorer\iexplore.exe -e.
    The program files path doesn't work because there is no more explorer mode
    in IE7, which is why they say to use the other folders. I have talked to
    others and the concensus is using explorer.exe is no longer a problem in
    Windows 2003. The /e switch will give me explorer mode so my command line
    of %Windir%\explorer.exe /e,U:\ works just fine. Thanks for all of your
    help.
    I think Citrix needs to update their documentation :)

    Thanks again
    Pete
     
    Peter J. Dickason, MCSE, Jan 20, 2010
    #11
  12. Peter J. Dickason, MCSE

    PhilD Guest

    Pete

    we have exactly the same problem but we had some servers using IE7 an
    windows explorer published as %windir%\ie7\iexplorer.exe -e y:\ an
    working for 6 server but 4 newer build is doesn't work. I got exactl
    the same error as yourself.
    the IE7 versions are the same but some updates are not which makes m
    think its windows update related.

    really weird

    Phi
     
    PhilD, Jan 20, 2010
    #12
  13. Yea we were quite taken aback as well since it worked fine on our test
    servers. As soon as we built the production ones using the same build
    process, it choked. I think the moral of this story is that IE can no
    longer be used to publish a data folder. But it sounds as if using
    explorer.exe is no longer a problem as it once was in previos versions of
    the OS.

    Pete
     
    Peter J. Dickason, MCSE, Jan 21, 2010
    #13
  14. Peter J. Dickason, MCSE

    tweast

    Joined:
    Jan 25, 2010
    Messages:
    1
    Likes Received:
    0
    I may have a breakthrough for you. We've been having this exact same problem in our Citrix farm with a new server image. Any time you try to use explorer mode (which has been working using the "%windir%\ie7\iexplore.exe -e" location, it pops up the xn--...... address. It's been plaguing me because I was beginning to think it was malware related. The research I've been doing leads me to believe it's not.

    Search wikipedia for "internationalized domain name" (I cannot post links because I'm new)


    I think the problem may have been caused by this Microsoft install:

    "Microsoft Internationalized Domain Names (IDN) Mitigation APIs 1.1" (Again, I'm new so can't post a link.)

    The problem now is that I can't figure out how to remove it. :confused:
     
    tweast, Jan 25, 2010
    #14
  15. Hello Peter,

    I have the same problem - do you have a solution for that?

    I figured out that when you start iexplore.exe from %windir%\ie7 the IE 7
    version starts and not the IE 6 version. Even though the version of the
    iexplore.exe in %windir%\ie7 is 6.00.3790.3959.

    I also figured out that when you install a clean windows server 2003 then
    ie7 and after that all updates incl. W2K3 SP2 it works.
    When you try an other sequence ex. W2K then SP2 and updates and after that
    ie7 starting IE in explorer mode fails.

    Any ideas?

    Thanks and regards
    Jan
     
    Jan-Hendrik Leuger, Feb 3, 2010
    #15
  16. Hi Jan,

    Yes our installation order was the OS/updates were first then IE7/updates.
    Not all in one. This was because Office 2007 broke IE 7 if IE7 was
    installed before O2k7 which was another headache for us, but I digress. We
    now just publish explorer.exe since there is now no good reason not to.
    We've talked to others and it works fine. Doesn't seem to be any issues
    publishing Explorer.exe like there were in Windows 2000. My understanding
    is there is no more 'explorer' mode in IE7, IE8, and so on that publishing
    explorer.exe is your only option in leu of a third party program. Hope
    this helps.

    Pete
     
    Peter J. Dickason, MCSE, Feb 3, 2010
    #16
  17. Peter J. Dickason, MCSE

    Dan Heim Guest

    If anyone ever figures out a fix for this, please post. We have (2)Win2003
    servers with IE7 and one of them works with explorer mode and one has the
    problem exactly as described in this thread.

    Dan H.
     
    Dan Heim, May 4, 2010
    #17
  18. Peter J. Dickason, MCSE

    rob^_^ Guest

    Hi,

    There is a setting on the Advanced tab of Internet Options in IE7 to "Open
    ftp sites in Explorer" (or something to that affect).

    Regards.
     
    rob^_^, May 4, 2010
    #18
  19. Peter J. Dickason, MCSE

    Trahsub Guest

    We have the same d$#% problem! Anyone find a solution?
     
    Trahsub, Jun 12, 2010
    #19
  20. I was forced to upgrade to IE7 on my Citrix Farm and lost my ability to Publish "Windows Explorer" using the -e explorer switch for IE 6. I haven't found a solution yet, I did find a thrid party "windowsxp" that works. Its not as nice as using IE6 with the -e switch. In a pinch its working though.

    http://www.explorerxp.com/

    Its easy to figure out how to set it up as a Published App.

    Kevin
     
    Kevin Hammill, Aug 9, 2010
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.