IE7 script blocking against local image

Discussion in 'Internet Explorer' started by N. Miller, Dec 22, 2006.

  1. N. Miller

    N. Miller Guest

    Just a minor annoyance, but I like to keep a local image as the browser
    start page. With MS Internet Explorer 7 the URL looks like this:

    | D:\Documents and Settings\Norman\My Documents\My Pictures\V-W-X-Y-Z\Yamaneko\Kabegami Koubou\Mana-musume Ito\maya23c_1024.png

    However, whenever I open IE7, the browser throws this informational warning
    at me:

    "To help protect your security, Internet Explorer has restricted this
    webpage from running scripts or ActiveX controls that could access your
    computer. Click here for options..."

    Click on the bar and I get a menu, including "Allow Blocked Content...".
    When I select that option, I briefly see the QuickTime logo, then the image
    displays. Assuming I _don't_ want IE7 to be the default image handler for
    ..png images, which option must I change in the Security setup for the zones?

    --
    Norman
    ~Shine, bright morning light,
    ~now in the air the spring is coming.
    ~Sweet, blowing wind,
    ~singing down the hills and valleys.
     
    N. Miller, Dec 22, 2006
    #1
    1. Advertisements

  2. N. Miller

    Don Varnau Guest

    Hi,
    I think you're encountering the "local machine zone lockdown" feature of
    [XP] SP2.
    http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2brows.mspx#EKQBG

    You might convert the PNG image to JPG or another format then allow IE to
    open it.
    Or try IrfanView or another image editor. QuickTime is being seen as active
    content.

    Or, Internet Options> Advanced> Security> check "Allow active content to run
    in files on My Computer ."
    You will, of course, be giving up some of the enhanced security of the XP
    SP2 update.
    http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2brows.mspx#EIAA

    Hope this helps,
    Don
    [MS MVP- IE]

    Pictures\V-W-X-Y-Z\Yamaneko\Kabegami Koubou\Mana-musume Ito\maya23c_1024.png
    zones?
    ..
     
    Don Varnau, Dec 22, 2006
    #2
    1. Advertisements

  3. N. Miller

    N. Miller Guest

    Interesting. I already had a .jpg equivalent, so I just changed which file
    to load. I still get the annoying warning, but the image does load. IE7 is
    not my default browser, just necessary for accessing Windows Updates. I
    guess it is a sign of the inherent insecurity of this browser that you can't
    run local files without a lockdown.

    --
    Norman
    ~Shine, bright morning light,
    ~now in the air the spring is coming.
    ~Sweet, blowing wind,
    ~singing down the hills and valleys.
     
    N. Miller, Dec 22, 2006
    #3
  4. N. Miller

    Don Varnau Guest

    Don Varnau, Dec 23, 2006
    #4
  5. N. Miller

    Don Varnau Guest

    Hi,
    Then try unchecking "Allow active content to run in files on My Computer ."
    If QuickTime isn't involved, you shouldn't need to have that checked.

    Or, more convoluted... Create a webpage which displays the JPG. Name it
    "whatever.hta" instead of "whatever.htm." HTA files aren't as restricted and
    shouldn't trigger a warning.

    Don
    [MS MVP- IE]
     
    Don Varnau, Dec 23, 2006
    #5
  6. If by chance you have the Google Toolbar installed, see:
    http://groups.google.com/group/micr...d1ac22a79?lnk=gst&q=undocumented&rnum=1&hl=en

     
    Code-Curious Mom, Dec 27, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.