[IE7] "Show image download placeholders" option has no effect

Discussion in 'Internet Explorer' started by Patrick Philippot, Jul 19, 2008.

  1. Hi,

    It seems that IE7 totally ignores the value of the "Show image download
    placeholders" option. I have unchecked this option and IE still displays
    the ugly box with the red X when the referenced image file is missing
    instead of only displaying the text specified in the "alt" attribute.

    Firefox doesn't have this problem. It behaves as expected and only
    displays the replacement text in that case. For an example, look at this
    page in both IE7 and Firefox:

    http://www.lightcrafts.com/forums/index.php

    Regards.
     
    Patrick Philippot, Jul 19, 2008
    #1
    1. Advertisements

  2. Patrick Philippot

    rob^_^ Guest

    Hi Patrick,

    That is because the missing picture is not a picture (image file).

    Right click on the place holder and select properties. You will see that it
    is looking for http://www.lightcrafts.com/forums/images/misc/thin_header.gif

    Copy and past the above url into your browser address bar and press enter.
    Ha... WTF?

    What you are seeing is not a image place holder, but a blocked activeX
    placeholder. Image placeholders have a multi-colored box inside a square.
    ActiveX placeholders have a red X inside a square.

    You can see this yourself if you uncheck 'Show Pictures' on the Advanced tab
    of Internet Options and then refresh (Ctrl+F5) the page. Image placeholders
    will be substituted for the blocked images. The placeholder on the top Left
    hand side remains a red X.

    Regards.
     
    rob^_^, Jul 19, 2008
    #2
    1. Advertisements

  3. Hi Rob,

    Thanks for answering.
    How could one (or IE7) determine this since the file is missing anyway?
    I already did that. This just brought me to an error page that told me
    that the document was missing.
    I do not agree. I just made a test with an HTML document containing
    images. I have deleted one of the images referenced by an IMG tag in the
    HTML source file. IE7 still displayed the box with the red cross. No
    ActiveX Control involved in this page.
    This applies only when you have unchecked "Show Pictures". Otherwise,
    when an image is missing, you get the box with the red cross. But
    normally, when the above mentioned option is unchecked, you should get
    the replacement text only, as in Firefox.

    Cheers.
     
    Patrick Philippot, Jul 19, 2008
    #3
  4. Patrick Philippot

    Paul Hilling Guest

    Correct me for being silly, but last time I looked a .gif file is an image
    file.
     
    Paul Hilling, Jul 19, 2008
    #4

  5. Works for me. (Unchecking Show Pictures and leaving Show Image Placeholders
    checked and then doing a _reshow_ of that page.)

    Reshow: overload About:Blank and then Go Back to the problem page.

    Even works with an F5 Refresh after that. Fiddler2 shows that the images
    are not tested, even though the problem one can't possibly be cached.

    Even works with a Ctrl-F5 Refresh!

    BTW I think what one problem is that instead of giving an HTTP 404 error response
    for a non-existent image the server is sending back its own "friendly" error _page_
    --which has its own missing image (Site logo), also not given an HTTP 404,
    hence also given a Red-X for invalid content (instead of a Red-X for HTTP 404).


    In fact, the only option combination which seems questionable is
    having both unchecked. E.g. then I still get an image placeholder _and_
    I can still right-click on one and use its Show Picture command.
    I think I might have expected no images and no placeholders
    with that combination.

    Hmm... here's a bizarre case: after both have been off, switch Show Pictures
    only back on. I then get (temporarily) no images and no placeholders. YMMV.
    BTW this is while Work Offline is set, so its only using the cache to show
    the images. Then I guess if you really wanted to see both no images and
    no placeholders this would be a way to do it... <eg>

    In any case, this proves that Show Image Download Placeholders certainly
    does have an effect (when used in combination with Show Pictures
    unchecked, as it was designed.)


    FYI

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jul 19, 2008
    #5
  6. Patrick Philippot

    rob^_^ Guest

    Hi,

    I see a placeholder with a red X on the top left hand side with the caption
    Light Crafts Forums... the page is in the Internet Zone where I have 'Open
    files based on content not extension' enabled, all Multimedia options on the
    Advanced tab are enabled.

    I think ActiveX is the wrong description, the site is written in Python.
    Right-clicking on the placeholder and selecting Properties shows the
    following url
    http://www.lightcrafts.com/forums/images/misc/thin_header.gif (note: not
    clicking the placeholder)

    Here is the top of the source for that 'gif' url

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta name="keywords"
    content=
    "photo editing, lightzone, lightcrafts, photoshop, lightroom,
    aperture, bibble, ansel adams, photo, color correction, exposure, SLR,
    photographer, photo, foto" />
    <meta http-equiv="content-type"
    content="text/html; charset=utf-8" />
    <meta name="robots"
    content="all" />
    <meta name="generator"
    content="RapidWeaver" />
    <meta name="generatorversion"
    content="3.6.7 (2691)" />
    <link rel="icon"
    href="http://www.lightcrafts.com/favicon.ico"
    type="image/x-icon" />
    <link rel="shortcut icon"
    href="http://www.lightcrafts.com/favicon.ico"
    type="image/x-icon" />

    <title>Light Crafts :: Error occurred</title>
    <link rel="stylesheet"
    type="text/css"
    media="screen"
    href="../rw_common/themes/LC%20small/styles.css" />
    <!-- <link rel="stylesheet" type="text/css" media="print"
    href="%pathto(print.css)%" /> -->
    <!-- <link rel="stylesheet" type="text/css" media="handheld"
    href="%pathto(handheld.css)%" /> -->
    <link rel="stylesheet"
    type="text/css"
    media="screen"
    href=
    "../rw_common/themes/LC%20small/css/sidebar/hide.css" />
    <link rel="stylesheet"
    type="text/css"
    media="screen"
    href=
    "../rw_common/themes/LC%20small/css/header/image3.css" />
    <link rel="stylesheet"


    ---------------------------------------------------------------------

    Note there are no Body tags and also there is raw Python code! Looks like it
    is used as a tracking component. Perhaps Privacy settings may be effecting
    how it is desplayed.

    But Oh well.... IE is doing the right thing by its Advanced settings.

    Regards.




     
    rob^_^, Jul 19, 2008
    #6
  7. OK. Thanks to all. Not a big deal after all. I have asked the webmaster
    of this site to have a look.
     
    Patrick Philippot, Jul 20, 2008
    #7
  8. Patrick Philippot

    Leonard Grey Guest

    A tip: When you snip previous posts in a thread, no one remembers what
    you're talking about.
     
    Leonard Grey, Jul 20, 2008
    #8
  9. Hi,

    Thanks, I usually do this but this was a general and possibly final
    append to this thread. No need to quote everything.
     
    Patrick Philippot, Jul 21, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.