IE7 Vista Business MHT files do not open

Discussion in 'Internet Explorer' started by Mombo, Dec 12, 2007.

  1. Mombo

    Mombo Guest

    IE7 does not display MHT files anymore, it use to work flawlessly with double
    click, now I get "Address Not Valid" error, I did do a Windows Update today,
    I wonder it the IE7 security update rollup caused this? KB942615

    Anybody having the same issue? I have not tried it offline.
     
    Mombo, Dec 12, 2007
    #1
    1. Advertisements

  2. Mombo

    PA Bear Guest

    Where does the MHT file reside?
     
    PA Bear, Dec 12, 2007
    #2
    1. Advertisements

  3. Mombo

    Mombo Guest

    http://support.microsoft.com/kb/891019/en-us the bug is back, and the
    symtoms are worse than XP.

    It resides several folders deep on my secondary internal hard drive, if I
    copy it to my desktop, it works just fine. Spaces in the directory path are
    being incorrectly converted to %20 :-((

    mhtml:file://B:\MP3\#Convert\Ernest%20Tubb%20-%20Walking%20The%20Floor%20Over%20You%208CD\Recording%20List\01%20-%20Ernest%20Tubb.mht
     
    Mombo, Dec 12, 2007
    #3

  4. That's not what I read in that article. I think that spaces in the URL should
    be translated that way. I suspect the article is referrring to other file references
    *inside* the .mht document.


    Before suspecting the %20 I would suspect that the # needs a similar
    treatment. E.g. try using %23 instead of that character when entering
    that URL in the Address bar to see if the whole thing then works as expected.


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Dec 14, 2007
    #4
  5. Mombo

    Mombo Guest

    If I copy the file to the desktop, It works fine with correct file path shown.

    Here is an example if a MHT file is on the desktop as compared to a deeper
    file path.

    "C:\Users\Administrator\Desktop\Reply.mht" completely different compared to
    the one below.

    Its a Vista Bug for sure, it use to work with no problems, no matter where
    the MHT was located.
     
    Mombo, Dec 14, 2007
    #5

  6. The # that I was remarking on is in the original path.
    So if you copy the file to the Desktop you won't have a # to deal with
    (if that is the problem.)


    So what happens if you rename that file to Test#.mht
    and then try to open it from the IE Address bar? ; )


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Dec 15, 2007
    #6
  7. Mombo

    Mombo Guest

    Ahhhh, you are a genius, it was the # that caused it, I use this to keep a
    specific folder at the top, what other character can I use that will not
    interfere?

    Many Thanks Robert!
     
    Mombo, Dec 15, 2007
    #7

  8. 0 would work for sure. It looks as if ! doesn't have the same problem
    that # causes. So you could try it too.

    BTW did you try using the %23 encoding for #?
    I tried renaming a file to contain that # character and found that
    the Address bar would only accept that substitution after getting
    a message about an Address error but then it wouldn't completely render
    the file. Probably it's a generalization of the original error with spaces
    that they didn't fix because instead of fixing the problem (special characters
    being used in a file:/// URL) they fixed the symptom (spaces being used
    in a file:/// URL)... ; ]

    Ok. I just tested a filename with a bang (!) in it too.
    That one is interesting. It works provided you only use it in a
    Windows path and filename. As soon as you try and use it in
    a file:/// URL it causes an error *and* you can't correct the error
    by coding the bang as %21. More signs that the fix was a fix of
    a symptom and not a complete fix of a problem area?
    Hmm... or maybe an undocumented "feechur"?
    I just looked at the Title bar for my last test.
    The windows path and filename (with the bang) stays in the Address bar
    unchanged. The file renders. (BTW this file doesn't have any graphics
    in it to cause extra complications about addressing them.) The title bar
    shows what was rendered--mhtml:file://... with the bang replaced by an
    underscore! Tests with filenames with # in them don't get that far... ; )


    Good luck

    Robert
    ---
     
    Robert Aldwinckle, Dec 16, 2007
    #8
  9. Mombo

    Mombo Guest

    No,I did not try the %23, off topic here, but is there a way to edit any of
    my posts here? Or are they carved in granite on this forum.

    Bang head here > # :p

    I tell you, If I did not run Windows, I would be the most bored person in
    the world. :))

    Thanks again Robert.



     
    Mombo, Dec 16, 2007
    #9

  10. You are using a web interface to NNTP, so you can't edit posts there any
    more than you can edit any posts to USENET. If you think you could clarify
    a point you could post a reply to a post.


    You're welcome. Happy to help.


    Robert
    ---

     
    Robert Aldwinckle, Dec 16, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.