IE8 on Windows 7 can create new Windows or new Tabs

Discussion in 'Internet Explorer' started by Peter S., Mar 1, 2010.

  1. Peter S.

    Peter S. Guest

    Okay, I have been running Windows 7 since December and last week I noticed I
    had problems opening a new window or new tab in IE8. I have tried EVERYTHING.
    I registered dll's, reset the browser, deactivated/uninstalled IE8, shut off
    protected mode, messed with security zones you name it. I have been scouring
    the web for an answer. I enabled script debugging and saw that the site(s)
    were trying to do a window.open and the error that came back was no such
    interface supported.

    What can I do to fix this? It is inhibiting me from logging onto websites
    that I use at work that need to open a new window. Right now I had to use
    Chrome to even log this newgroup message! I would love to have a sure fire
    method or at least the ability to do a solid reinstall on Windows 7 of ie8
    which currently does not seem available. I see folks switching over to all
    sorts of other browsers because of this. Is Microsoft uncaring about losing
    the browser war? I am surprised this problem hasn't been put to rest!
     
    Peter S., Mar 1, 2010
    #1
    1. Advertisements

  2. Peter S.

    Leonard Grey Guest

    If you've already tried "EVERYTHING" what more do you expect from us?

    Especially when all you can say about your situation is "I had problems
    opening a new window or new tab," leaving us to guess what problems
    you're having.

    Perhaps a good place for you to start would be to try to remember what
    you did to your computer "last week" that might be causing your problem.
     
    Leonard Grey, Mar 1, 2010
    #2
    1. Advertisements

  3. Peter S.

    Don Varnau Guest

    Hi,
    If you've reset IE settings to default, then JavaScript should be able to
    open a new window or tab.

    If the IE pop-up blocker is turned off, a browser add-on or third-party
    program must be causing the problem.

    Add-ons...
    For troubleshooting information see:
    IEBlog Troubleshooting and Internet Explorer’s (No Add-ons) Mode:
    http://blogs.msdn.com/ie/archive/2006/07/25/678113.aspx
    Hint: A number of third-party toolbars have a pop-up blocker (Google, Yahoo,
    Earthlink, among others)

    Third-party programs...
    929135- How to troubleshoot a problem by performing a clean boot in Windows
    Vista or in Windows 7: http://support.microsoft.com/default.aspx/kb/929135

    Hope this helps,
    Don
     
    Don Varnau, Mar 1, 2010
    #3
  4. Is it a Windows 7 64-bit computer?
     
    PA Bear [MS MVP], Mar 1, 2010
    #4
  5. Peter S.

    Peter S. Guest

    Thanks for the response, no it is a 32 bit installation of Windows 7
    professional. I have no clue what I installed recently that would cause a
    problem. I did de-install and re-install SQL Server 2008 professional
    recently but I can't believe that would be related. BTW, I also tried IE with
    no add-ons and that didn't work.

    I did find one KB that suggested I register Shdocvw.dll (among other dll's)
    and that failed with entry-point dllregisterserver not found.

    BTW, trying "everything" means I looked at a bunch of newgroups throughtout
    the web. I feel posting in the Microsoft communities is a cut above that
    first tier of research.
     
    Peter S., Mar 2, 2010
    #5
  6. Peter S.

    Peter S. Guest

    Thanks for the reply, I tried running with no add-ons and that didn't seem to
    help. I got pop up blocker turned off as well. I did notice that if a right
    click on a link and try to open new window, nothing happens. If I right click
    on that same link and open new tab. A new tab opens and it just sits there
    connecting. The new tab doesn't have the link information of the link I
    clicked on but rather the contents of the last tab
     
    Peter S., Mar 2, 2010
    #6
  7. Peter S.

    Peter S. Guest

    More information, I did a clean boot and that did not fix it. I also tried
    running IE with no-add-ons. Any other suggestions would be greatly
    appreciated and I would gladly try.

    P.S. When I right click on a link to open a tab I see it says "connecting"
    and it just stays there trying to connect and the link information in the
    toolbar does NOT reflect the new link. Like I mentioned, I have to run Chrome
    to post this reply. It's a huge pain because I need IE for Outlook browser
    mail and web based applications like Eclipse and AthenaNet that their main
    staple is to spawn a new window after successfully logging in....
     
    Peter S., Mar 2, 2010
    #7
  8. What anti-virus application or security suite is installed and is your
    subscription current? What anti-spyware applications (other than Defender)?
    What third-party firewall (if any)?

    Has a(another) Norton or McAfee application ever been installed on the
    computer (e.g., a free-trial version that came preinstalled when you bought
    it)?
     
    PA Bear [MS MVP], Mar 2, 2010
    #8
  9. Peter S.

    rob^_^ Guest

    Hi Peter,

    Try adding those sites that require a login to your Trusted Sites list and
    ensure that your IE Security Zone settings are at the recommended default
    levels.

    Tools>Internet Options - Security tab, click the "Reset all zones to
    default" button.

    By default, for security reasons, IE blocks navigation to zones of a higher
    security risk. You are probably logging on at a secure https and then being
    redirected to a http page.

    Regards.
     
    rob^_^, Mar 2, 2010
    #9
  10. Peter S.

    Don Varnau Guest

    Don Varnau, Mar 2, 2010
    #10
  11. Peter S.

    Peter S. Guest

    FYI, I tried (this is something that I was asked to do before by a vendor)
    to add the site to the trusted zone and that didn't work. However I did run
    the script that was suggested:

    http://iefaq.info/index.php?action=artikel&cat=42&id=133&artlang=en

    At first it didn't help but then I decided to reboot and all of a sudden
    everything worked! I am psyched! I even get to reply to this using IE :) I
    have seen these larger size scripts in posts all over the web but didn't want
    to run them because I was concerned I would make things worse. However I felt
    comfortable running this one because it was posted in the Microsoft forum and
    it worked! Many thanks!!!!
     
    Peter S., Mar 2, 2010
    #11
  12. Peter S.

    Peter S. Guest

    One suggestion I would have is why couldn't the IE reset command also
    perform some of the repair methods found on that IE8 repair site?? Seems like
    a must addition to me. Not alot of folks are savvy enough in trying all these
    troubleshooting methods or obscure repairs, they are likely just to give up
    and go to the path of least resistance.
     
    Peter S., Mar 2, 2010
    #12
  13. IN RE our IE MVP colleague Kai Schaetzl's IE Repair scripts at
    http://iefaq.info/index.php?action=artikel&cat=42&id=133&artlang=en

    Tell you the truth, we've been lobbying the IE team (and MS Fix It team)
    about this but we've not gained much traction yet. Methinks it boils down
    to a few niggling questions:

    1. How many users have encountered such issues (i.e., how big of a demand is
    there for a fix)?

    2. Why have so many Windows 7 (32-bit & 64-bit, but primarily 64-bit) users
    encountered this problem and why are they usually & only encountering it a
    month or two into using their new computers?

    IN RE #1: Yes, there have been an ever-growing number of posts in the forums
    & newsgroups about the problem but that's not necessarily a good way to
    determine the scope of the problem: The vast majority of users are NOT
    having these problems and they do NOT tend to post or contact MS Support
    about something that's working properly.

    IN RE #2: First, you've got to consider the fact that (IMHO) the bulk of
    people buying 64-bit computers (which doesn't include you) haven't the
    faintest clue as to the differences between Windows (and IE) 32-bit and
    64-bit. With all due respect, this means they're facing a fairly steep
    learning curve so you've got to take the "cluelessness factor" into
    consideration.

    Second, I personally & professionally suspect one or more third-party
    applications are causing the bulk of these problems and at the top of my
    little list are preinstalled anti-virus/internet security applications
    (usually Norton or McAfee), most of which are two-month free trials. Hence,
    the questions I posed to you in my previous reply, especially considering
    the fact that you encountered the problem two months into owning your
    computer.

    Norton and McAfee applications are notorious for not uninstalling or
    upgrading cleanly. So even if you've uninstalled the free trial or
    purchased the application (which is, in essence, an upgrade), the
    "leftovers" may be in play here unless you run a specific Norton or McAfee
    utility after uninstalling the free trial or prior to upgrading.

    All of that being said, let me repost the questions I put to you in my
    previous reply:

    What anti-virus application or security suite is installed and is your
    subscription current? What anti-spyware applications (other than Defender)?
    What third-party firewall (if any)?

    Has a(another) Norton or McAfee application ever been installed on the
    computer (e.g., a free-trial version that came preinstalled when you bought
    it)?
     
    PA Bear [MS MVP], Mar 2, 2010
    #13
  14. Peter S.

    Peter S. Guest

    First thanks about the frank discussion. IMHO I think folks are giving up and
    going to other browsers. I actually wouldn't have put this enormous effort in
    if it weren't for the fact that there were some work functions that required
    IE. Alot of these things (I forgot to mention I also tried SFC /scannow) are
    extremely time consuming and unless you have a vested incentive to fix the
    behavior why not fire up another browser? Don't shoot the messenger, it's
    just my personal opinion.

    As for anti-virus software I run CA E-trust (per employer) and because I
    wasn't too confident with that I also installed Microsoft Security
    Essentials. They had been on my computer for at least a month without
    experiencing this issue. Also since this is a work laptop I am very
    meticulous about what I install. Like I said the only thing I did recently
    was deinstall and reinstall SQL Server 2008 Developer....
     
    Peter S., Mar 2, 2010
    #14
  15. Peter S.

    Peter S. Guest

    BTW, to be specific Norton or McAfee have never ever been installed on this
    machine. It's my laptop so I am certainly in control of what is on this
    machine.
     
    Peter S., Mar 2, 2010
    #15
  16. As for anti-virus software I run CA E-trust (per employer) and because I
    You should NEVER have more than one (1) anti-virus application installed and
    loading at boot. Uninstall one of them now!

    I suspect that having both of these installed & running in the background
    had caused your problem, Peter.
     
    PA Bear [MS MVP], Mar 2, 2010
    #16
  17. Peter S.

    Peter S. Guest

    I never had a problem with that environment and this issue is recent. Also
    it did not effect the other browsers, both Chrome and FireFox.... Why would
    it not effect those as well? What would the IE script fix that would be
    caused by competing AV software and why doesn't Security Essentials detect
    that another AV product is installed and decline to install?
     
    Peter S., Mar 2, 2010
    #17
  18. I never had a problem with that environment

    Until now.
    Neither Chrome nor FF are part & parcel of your Operating System.
    The things that were broken by having two AV apps installed, obviously.
    I'm not sure any application would be able to do that unless you're trying
    to install the same application and version. AFAIK, no AV app or security
    application will do that.

    IIRC, the standard MSE installation process will at least warn you to
    uninstall possibly-conflicting security software. If you chose to ignore
    the prompt, you suffer the consequences...just as you do when you click on
    links to "See the dancing pigs!" or when you open spam emails & click on a
    link in it or open its attachment.

    /Caveat emptor/.
     
    PA Bear [MS MVP], Mar 2, 2010
    #18
  19. Peter S.

    Don Varnau Guest

    You're welcome. Glad that Kai's script worked for you.

    Don


    rest!
     
    Don Varnau, Mar 3, 2010
    #19
  20. Peter S.

    Phillip Guest

    I have went to the link and tried to run the cmd script as administrator as
    it says but it keep giving me the following message:

    IEREREG Version 1.07 for IE8 27.03.2009
    by Kai Schaetzl http://iefaq.info
    installs and registers (if suitable) all DLLs known to be used by IE8.
    should only take a few seconds, but please be patient

    registering IE files
    registering system files
    correcting bugs in the registry
    ERROR: Access is denied.
    all tasks have been finished

    Press any key to continue . . .

    Access denied? Have any ideas why this wouldn't run? I have windows 7 with
    the pre-installed i.e.8 and keep having he same problems with new tabs or
    windows not connecting, they open up but never connect or time-out.
     
    Phillip, Mar 11, 2010
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.