Iexplore problem clicking link, not all, just one.

Discussion in 'Internet Explorer' started by It's Only Me, Dec 15, 2005.

  1. It's Only Me

    It's Only Me Guest

    I know there is a fix for this, but where to find it again, I do not know.
    Please bear with me.

    On a web page there is a picture to click on and it opens a new page. Since
    installing ie fixes, this no longer happens. The link referred to in the
    picture goes into the address bar but with extra characters in front of it.
    If I remove the extra characters, the web page loads as normal. I found a
    fix a few weeks back on another newsgroup where I had to remove either an
    entry of change a value in the registry to fix this problem. I have recently
    reformatted and reinstalled XP Pro SP2 and have all updates. Now the problem
    is back with clicking this link. It is not a major problem, just a pain in
    the proverbial ass to take out the extra characters. I have the proper link
    saved as a favorite, but I just want to be able to click on the link again.

    Thanks in advance,

    Larry
     
    It's Only Me, Dec 15, 2005
    #1
    1. Advertisements

  2. It's Only Me

    Alan Edwards Guest

    Alan Edwards, Dec 15, 2005
    #2
    1. Advertisements

  3. It's Only Me

    It's Only Me Guest

    I didn't post on this topic originally. I came across it by accident in an
    unrelated thread somewhere and it cured the problem that I have.

    Larry
     
    It's Only Me, Dec 15, 2005
    #3
  4. It's Only Me

    Alan Edwards Guest

    You can still use Google Groups to search for the post.

    ....Alan
     
    Alan Edwards, Dec 15, 2005
    #4
  5. It's Only Me

    It's Only Me Guest

    That would be perfect if I knew the title of the post.
     
    It's Only Me, Dec 16, 2005
    #5
  6. It's Only Me

    Alan Edwards Guest

    Search by keywords in the content. You don't need to know the title.

    ....Alan
     
    Alan Edwards, Dec 16, 2005
    #6
  7. It's Only Me

    It's Only Me Guest

    I have hunted till my fingers are sore and still can't find the answer. Any
    other help or suggestions please.
     
    It's Only Me, Dec 20, 2005
    #7
  8. It's Only Me

    PA Bear Guest

    X-post to IE6 Browser.
    What web page, please?
    Can't help you there. My CrystalBall© is in the shop for polishing.
    Please state the version of MSHTML.DLL found in C:\Windows\System 32.
     
    PA Bear, Dec 20, 2005
    #8
  9. It's Only Me

    It's Only Me Guest

    MSHTML.DLL version 6.0.2900.2802

    The website is secure and for work purposes. I dont think they'd like me
    giving the necessary password info so you can simulate the experience,
    sorry. Hope the Crystal Ball comes back well polished.

    Larry
     
    It's Only Me, Dec 20, 2005
    #9
  10. It's Only Me

    PA Bear Guest

    OK, thanks. (Long story...)

    The fix might be:

    ActiveX controls may not load as expected in Internet Explorer due to
    defense in depth changes introduced in cumulative security update 896688
    (MS05-052)
    http://support.microsoft.com/Default.aspx?kbid=909889

    A Web page that contains a custom ActiveX control may not load as expected
    in Internet Explorer due to defense in depth changes introduced in
    cumulative security update 896688 (MS05-052)
    http://support.microsoft.com/Default.aspx?kbid=909738

    The fix involving the Registry and OLE32.DLL is available at

    - http://patch-info.de/IE/Downloads/OLEfix.zip, and

    - http://www.dougknox.com/xp/utils/kb896688_fix.zip (a small VB app that
    checks the 4 values and offers a repair option if any of them are
    incorrect).

    Also see http://snipurl.com/kxyk (GIFs or pages created in Quark)
     
    PA Bear, Dec 20, 2005
    #10
  11. It's Only Me

    Alan Edwards Guest

    This is all I found but it does not mention removing an entry or
    changing the Registry:

    Title Bar Truncation
    Title bar may contain garbage characters
    Title bar truncated to 1 character.

    Do you have the Google Desktop bar installed?
    If so, try uninstalling/reinstalling it.
    It has been reported to sometimes produce truncation of the title bar
    text.

    ....Alan
    --
    Alan Edwards, MS MVP Windows - Internet Explorer
    http://dts-l.org/index.html


    On Thu, 15 Dec 2005 10:29:01 +0200, "It's Only Me" <no
     
    Alan Edwards, Dec 20, 2005
    #11
  12. It's Only Me

    It's Only Me Guest

    Thanks for the reply, but unfortunately the articles and patches don't help
    with my problem. I just tried the same page on Firefox and the link from the
    picture works fine, but!!!! I don't want to have Sun Java. It makes the
    windows that I use too small to work on and installs on Internet Explorer
    too. Is there a way to install Microsoft VM in firefox?????
     
    It's Only Me, Dec 21, 2005
    #12
  13. It's Only Me

    It's Only Me Guest

    This is the result of clicking the link:

    "Please try the following:

    a.. Open the rh633788: home
    page, and then look for links to the information you want.

    b.. If you typed the page address in the Address bar, make sure that it is
    spelled correctly."

    If I take out the first part of the link until
    wizard.....rh633788:Ge-di8-2SQ5c7iziTejSiA@... it loads the correct page.
    The extra characters are added because of some "fix" that microsoft put out
    a few years ago. As I said in my post, I found the other fix in a newsgroup
    a few weeks ago which involved a registry edit. It worked perfectly for this
    problem but I forget where I found the information for the registry edit.

    Larry
     
    It's Only Me, Dec 21, 2005
    #13
  14. It's Only Me

    PA Bear Guest

    Is the page Java-dependent?
    If the machine has always been running WinXP SP2, you can't even install MS
    JavaVM in IE. See:

    Where to gete Java
    http://inetexplorer.mvps.org/archive/answers_9.htm
     
    PA Bear, Dec 21, 2005
    #14
  15. It's Only Me

    PA Bear Guest

    Sorry & we hear you. Again, no one here can help you with that.
     
    PA Bear, Dec 21, 2005
    #15
  16. ....

    The a.. and b.. suggest that these were bullets on the screen.
    So I'm assuming that this example is what you are seeing on the screen only.


    Take out from where? From what you copied from the screen?
    OR from what you get (e.g.) by doing right-click, Copy Shortcut?


    Please be more specific or provide a better example.
    What extra characters? (See below.)


    Can you provide a more explicit example? E.g. the only sense that I can
    see the first example as being a link is by the @ which would make it look
    like a mailto: URL. OR the prefix rh633788: could conceivably be a site
    specific protocol that you have (e.g. in the same way that NNTP URLs have a prefix of and often have an @ in them as part of their
    Message-ID.)

    Maximize the window and hover the mouse over the link what do you see
    in the maximized Status bar? Right-click Properties on the link and
    doubleclick somewhere in the Address (URL) portion; then press Ctrl-a
    and Ctrl-c; paste that into a reply. Is that the same value that you see
    in the Status bar when hovering over the link? Click on the link and copy
    the new URL from the Address bar. Is that the same URL that you are getting
    with the other two diagnostics? If not what _exactly_ is the difference?

    BTW to be doubly certain that the link you are going to click is going to take
    you to where you think, you could also do View Source (Alt-V,c) and find the
    actual HTML tag which is both showing you what you are clicking on and
    what it will be trying to open. In addition, in case scripting is at work while
    you are using your mouse on the link you could try using your Tab key
    instead and changing your Security settings temporarily to disable Active Scripting
    or set it to Prompt. Etc.

    I'm wondering if IE might be now trying to protect you from the type of
    confusion about these things that "phishing" sites exploit.
    In that case perhaps your "fix" was actually hack to disable such protection.


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Dec 21, 2005
    #16
  17. It's Only Me

    It's Only Me Guest

    This is the link as it should be:
    https://wizard.avisweb.com/wc-cgi/c...&port=4270&URL=tok/startses.html&sfile=ses-01

    This is the link that shows after I click on the graphic which is supposed
    to open the programme that I work with:
    https://rh633788:eHFVbLZuHUHkm4TIbM....html&wcBase=https://wizard2.avisweb.com:443/

    The pages will not show correctly, because I have the access codes to get
    into the site, but I suppose you'll get my drift. If I remove this part of
    the new link: https://rh633788:eHFVbLZuHUHkm4TIbM3mng@ I can get into the
    site OK. There IS an MSKB article that explains this and contains a registry
    edit to fix it.
     
    It's Only Me, Dec 22, 2005
    #17
  18. It's Only Me

    It's Only Me Guest

    At last I found the answer!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    http://support.microsoft.com/?kbid=834489 explains the behaviour and how to
    disable it with a registry edit. Thankyou to those who tried to assist.

    Have a very Merry Christmas and a Peaceful and prosperous New Year.

    Larry
     
    It's Only Me, Dec 22, 2005
    #18

  19. Thank you. That is much clearer.

    The problem is the example is trying to make use of a non-standard
    URL syntax for encoding authentication with the URL.
    (There is a similar standard for it in FTP URL syntax but not for HTTP.)


    Yes, except as I mentioned I don't think it is correct to call it a "fix".

    <title>KB834489 - A security update is available that modifies the default
    behavior of Internet Explorer for handling user information in HTTP and in
    HTTPS URLs</title>



    HTH

    Robert
    ---
     
    Robert Aldwinckle, Dec 22, 2005
    #19
  20. It's Only Me

    It's Only Me Guest

    Thankyou for your time and input, Robert. Have a great Christmas and new
    Year.
     
    It's Only Me, Dec 22, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.