Index doesn't find my files, although the location is indexed

Discussion in 'Windows Vista Performance' started by Beowulf Agat, Aug 13, 2007.

  1. Beowulf Agat

    Beowulf Agat Guest

    I have Vista ultimate on a laptop with 2 hard drives. I keep all my user
    files on D:, which is indexed. When I search for a file that I know is there
    it doesn't show up in the search results. I have tried moving the entire
    index to D: and I have tried rebuilding the index several times without any
    improvement. Why won't the index search through D:?
     
    Beowulf Agat, Aug 13, 2007
    #1
    1. Advertisements

  2. Beowulf Agat

    John Hanley Guest

    Did you try "Advanced Search" within your D: drive, and using "Include
    non-indexed, hidden, and system files"?" This might reveal the file if, for
    example, it has simply not yet made it into the index. At any rate, might
    give some clues as to what is going on.
     
    John Hanley, Aug 13, 2007
    #2
    1. Advertisements

  3. Beowulf Agat

    Beowulf Agat Guest

    Standard search as well as advanced search will find the files, although when
    I just hit the windows button and type a few letters of the filename I will
    not find the file in question. I might add that I had no problems like this
    on my other laptop with only 1 hard drive and all my user files were under
    users/documents etc. It seems that files on D: are either ignored by the
    idex, or they are way down in the list and therefore not shown in the search
    result.
    Also, if I open a file located in one of the indexed folders on D: it will
    be found by the indexed next time i search.
     
    Beowulf Agat, Aug 13, 2007
    #3
  4. Beowulf Agat

    Kurt Herman Guest

    Make sure you take "ownership" of the files (security tab in properties for
    the drive or folder).
    Index search will only return files that the current user "owns". Wouldn't
    be very secure if it did. :)

    Kurt
     
    Kurt Herman, Aug 13, 2007
    #4
  5. The Start Menu search doesn't search for exactly the same things as the full
    Search window.

    If you right-click on the Start Button, select Properties and then
    Customize, and scroll down under Search Files you can select either "Search
    entire index" or "Search this users files". If you select "Search entire
    index" you might get the behavior you want.
     
    Dave Wood [MS], Aug 13, 2007
    #5
  6. Beowulf Agat

    Beowulf Agat Guest

    Thanks for help and suggestions.
    I am owner of the files.

    "The Start Menu search doesn't search for exactly the same things as the full
    Search window."

    But on my other computer where all files are in the "my docs" folder my
    files pop up directly.

    Any more suggestions? Also, is there a way to change the priority of the
    serach results in the start menu search so that files are always listed
    before outlook messages?
     
    Beowulf Agat, Aug 15, 2007
    #6
  7. Right. The Start Menu search I think searches just "Documents" for the
    current user {c:\users\<username>} by default. The Search explorer searches
    all indexed location by default. So I think that would explain why something
    in Documents would appear in the start menu, but something on some other
    folder on another drive would not. Is that not the behavior you are seeing?
     
    Dave Wood [MS], Aug 15, 2007
    #7
  8. Beowulf Agat

    Beowulf Agat Guest

    I get all kinds of hits in the start menu search, emails and such, but not
    the file I'm actually after. I would like the start menu search to display
    files and folders only and not outlook items.
     
    Beowulf Agat, Aug 17, 2007
    #8
  9. This is all customizable by right-clicking on the start button, selecting
    "personalize", and then "customize". There are options to turn off "Search
    communications" {e-mail}, and then "Search entire index" or "Search this
    user's files".

    Dave
     
    Dave Wood [MS], Aug 17, 2007
    #9
  10. Beowulf Agat

    Beowulf Agat Guest

    Hi Dave,
    thanks for the tip. I checked "search entire index" and now it works as I
    want it to.
     
    Beowulf Agat, Aug 19, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.