install failed,rollback failed

Discussion in 'Windows Vista Installation' started by jds, Sep 14, 2006.

  1. jds

    jds Guest

    I installed RC1 with online updates on my dell 700m laptop and it got all the
    way through to completing install, then I guess it tried to load Aero or
    something and just went blank. I forced a reboot and it said rolling back to
    previous operating system. I then gave it another try without online
    updates. This did almost the same thing, took a bit longer ( about 2 hours)
    and then the display went blank again. Forced reboot after about 12 hours of
    waiting, tried to rollback and failed. Now I have a cmd prompt and nothing
    else. It appears that the rollback was removed (windows.old not there?) and
    that the install log shows it copied stuff from $windows~bt to \windows so
    i'm guessing I have no way to rollback. I fooled with bcdedit and got it to
    try to load into the /windows dir but it still thinks it is in an install and
    tells me to reboot and reinstall. There is no option to continue the install
    which was an upgrade, and the upgrade option is gone for me now. should I
    just buy a notebook ide adapter and pull any files off that drive and give up
    on the possibility of the upgrade/install completing? Is there a registry
    key somewhere that i can set so it thinks the install is complete?
     
    jds, Sep 14, 2006
    #1
    1. Advertisements

  2. jds

    jds Guest

    Ok, well i figured out that I could go into \$Windows.BT\Sources and run
    setup.exe which looked like it was continuing the install however now I no
    longer can boot into the "Windows Setup Rollback" which was setup to use the
    winload.exe in the $Windows.BT.

    Does anyone know what the BCD boot looks like for the setup routine? if I
    boot to the Vista one it just loads the OS and says in need to reboot to
    complete the install, but that is a loop.

    I also found a UnattendGC dir in the panther dir which says that setup.exe
    has a false flag

    Windeploy.exe launched with command-line []...
    Setup has not completed, adding pending reboot.
    Found no unattend file.
    Found generalization state [0x7], setup.exe completion flag [False] -->
    launching setup.exe
    Launching c:\windows\system32\oobe\setup.exe
    setup.exe failed returning exit code [0x1f]
    Failure occured during online installation. Online installation cannot
    complete at this time.
    Flusing registry....
    flush took blabla
    WinDeploy.exe exited with code [0x800004005]

    Is this a path problem? my BCD has the path as X:

    Any ideas or guesses are welcome. It seems to be close to installed,
    however it can't get past that false flag.
     
    jds, Sep 15, 2006
    #2
    1. Advertisements

  3. jds

    jds Guest

    I also found a \windows\Setup\State dir with a State.ini that says:

    ImageState=Image_State_Specialize_Reseal_to_OOBE

    i moved this to state.ini.old and it was recreated...
     
    jds, Sep 15, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.