Installation Error: Visual C++ Runtime Linrary Runtime Error

Discussion in 'Windows Vista Installation' started by John Westlake, Jun 11, 2006.

  1. When ever I try to instal Vista, I get to the checking compatability stage on
    upgrade.

    And then it comes up with the message:

    "Runtime Error!

    Program C:|$WINDOWS.~BT\Sources\setup.exe

    abnormal program termination"

    Screenshot: http://img96.imageshack.us/img96/8246/untitled3my2.png
     
    John Westlake, Jun 11, 2006
    #1
    1. Advertisements

  2. John Westlake

    zyklonia Guest

    I have the same issue when running from Windows. When I boot from the CD-ROM
    it worked, although I couldn't install it anyway because it doesn't find my
    harddrive (promise fastrack 150 controller).
     
    zyklonia, Jun 11, 2006
    #2
    1. Advertisements

  3. The problemr is I can't put it on DVD becuase I don't have a burner. Unless I
    can boot it from the virtual drive. Does anyone know how to the fix the
    problem?
     
    John Westlake, Jun 11, 2006
    #3
  4. John Westlake

    Dannn78 Guest

    Hi, I'm having the exact same problem. Have tried a registry cleaner,
    uncheked debugging in internet explorer and still no success. Does anybody
    have any other suggestions?
     
    Dannn78, Jun 11, 2006
    #4
  5. Your post gave me a brilliant idea. I ran PCTools Registry Mechanic, and
    after it fixing over 1300 problems for me, the Vista Install started working
    perfectly
     
    John Westlake, Jun 11, 2006
    #5
  6. John Westlake

    scooteroz Guest

     
    scooteroz, Jun 12, 2006
    #6
  7. John Westlake

    scooteroz Guest

    Hi there I had this problem and after reading all the posts I was about to
    give up. Anyway here is what I did.

    Remove Norton Internet Security

    That when the problem started. As other posts will tell you this is due to a
    poor uninstall.

    I then removed all remaining directories and registry entries

    STILL no Joy

    I then looked at the following file
    C:\$windows.~bt\sources\panther\setupact.log and it looked like it was still
    finding some Norton stuff. I couldn't work this out anyway I finaly figured
    it out.

    There were STILL some orphan short cuts in my Start Programs list ie if I
    clicked on Start then All Programs there were still some references to Norton
    even though I had removed everything I could find etc.

    This solved the runtime error problem.

    The real bummer is once I sorted that out I got a file transerf error at 80%
    AFTER I deleted the download :( So I need to download etc and burn slowly the
    DVD.

    Anyway hope the above helps and dont delete the download untill its installed.
     
    scooteroz, Jun 12, 2006
    #7
  8. John Westlake

    dschoen Guest

    I uninstalled Norton, I used the fix shown in a another post. I ran
    registry Mechanic and I still get the same runtime error message.
     
    dschoen, Jun 13, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.