Internal clock set to UTC time

Discussion in 'Windows Vista General Discussion' started by Tieum, Nov 25, 2007.

  1. Tieum

    Tieum Guest

    Hello,

    How can I tell Vista that my ccomputer's internal clock is set to UTC.
    Vista does not seem to understand this and whenever I start Vista the
    time is completely wrong.

    Thanks,

    Tieum
     
    Tieum, Nov 25, 2007
    #1
    1. Advertisements

  2. Tieum

    Dwarf Guest

    Hi Tieum,

    Do you have any other symptoms? Is the date correct? If the date is wrong as
    well and you have to reset this, then it could be that the battery on the
    motherboard needs replacing. This is usually a lithium button cell, type
    CR2032.
    Dwarf
     
    Dwarf, Nov 25, 2007
    #2
    1. Advertisements

  3. Tieum

    Rick Rogers Guest

    Hi,

    Enter the system BIOS when you first boot, see if the time is correct.
    Vista, like any version of Windows, gets the initial time from the BIOS when
    it's started, then uses its own mechanism going forward. If it's initially
    incorrect, then it is likely not correct in the BIOS. Either the settings
    are incorrect, or the CMOS battery needs to be replaced.
     
    Rick Rogers, Nov 25, 2007
    #3
  4. Tieum

    Tieum Guest

    My BIOS shows the correct UTC time (i.e right now Nov 25 07 23:08). My
    linux OS correctly sets the time to 6:08 PM (since I am in the Eastern
    timezone) but Vista sticks to 11:08 PM.
     
    Tieum, Nov 25, 2007
    #4
  5. Tieum

    Dwarf Guest

    Hi Tieum

    You need to reset the time in your BIOS to YOUR local time, in your case UTC
    -5 hours. I am assuming that you can connect to the Internet with both Vista
    and Linux. If this is the case, and you have your system set up to update its
    time from the Internet, then it is possible that Linux does this at start up
    whereas Vista only does this once a week by default. If your BIOS fails to
    keep the correct time, then you should replace the battery.
    Dwarf
     
    Dwarf, Nov 26, 2007
    #5
  6. Tieum

    ray Guest

    I think you'll need to set your internal clock to local time. MS is too
    dumb to let you use UTC.
     
    ray, Nov 26, 2007
    #6
  7. Tieum

    Bill Yanaire Guest

    Wow - I'm surprised you didn't tell him to install Ubuntu!
     
    Bill Yanaire, Nov 26, 2007
    #7
  8. Tieum

    roy69 Guest

    Two things to try,
    1st have you had any checksum errors with the post screen? If so like
    was said in the post above change your battery.
    2nd is to cheat and change the timezone to one that matches your actual
    time.

    Hope this helps


    --
    roy69

    - Core 2 Quad Q6600
    - Abit IP35 Pro
    - 4 x 1GB OcUK PC2-6400 C5 800 MHZ Duel Channel
    - Leadtek GeForce 8800 GTS 640MB GDDR3
    - CiBox TFT 22" Widescreen LCD Panel. 1680 x 1050
    - Creative X-Fi 7.1 PCI-E
    - Antec 900 Ultimate Gaming Case
    - Creative Inspire 7.1 T7900 Speakers
     
    roy69, Nov 26, 2007
    #8
  9. Tieum

    Tieum Guest

    Hi,

    My PC keeps the "correct" time no battery problems.

    SO from what I read here it looks like Microsoft choosed to be different
    from other OS by keeping local time in the computer instead of UTC.
    That's bad news as it causes confusion when using DST but knowing how
    Microsoft do care about those kind of thing my grand-grand-children will
    probably be dead before they even think of cahnging it :-(

    Regarding the Ubuntu stuff I already tried it and no thanks I keep my
    Fedora ;-)

    Thanks all for your help,


    Tieum.
     
    Tieum, Nov 27, 2007
    #9
  10. Tieum

    ray Guest

    That would be one option - at least Linux is intelligent enough to be able
    to deal with a UTC clock OR local.
     
    ray, Nov 28, 2007
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.