Internet Explorer blocked?

Discussion in 'Internet Explorer' started by Jo-Anne, Jul 17, 2009.

  1. Jo-Anne

    Jo-Anne Guest

    My computer runs WinXP SP3, and I use IE7. I'm freelancing for a textbook
    publisher that has asked me to look at some manuscript files online at an
    ftp site. In IE, I typed in ftp.publishername.com and hit ENTER. I could see
    the opening page, but in the middle of it was a Windows Security Alert. It
    said:

    To help protect your computer, Windows Firewall has blocked some features of
    this program.
    Do you want to keep blocking this program?
    Name: Internet Explorer
    Publisher: Microsoft Corporation

    My choices are to keep blocking, unblock, and ask me later.

    The last part says: "Windows Firewall has blocked this program from
    accepting connections from the Internet or a network. If you recognize the
    program or trust the publisher, you can unblock it."

    Can I assume that it's OK to unblock the program? Could someone help me
    understand why I received this Security Alert? I read what Microsoft said
    about when it's OK to unblock a program, but I don't see why IE was blocked
    in the first place. Is there something about ftp that's the issue?

    Thank you!

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #1
    1. Advertisements

    1. Advertisements

  2. Jo-Anne

    Terry R. Guest

    The date and time was Thursday, July 16, 2009 8:51:51 PM , and on a
    whim, Jo-Anne pounded out on the keyboard:
    Hi Jo-Anne,

    You will have to unblock it if you want to access the file since you're
    using FTP (File Transfer Protocol).


    Terry R.
     
    Terry R., Jul 17, 2009
    #3
  3. Jo-Anne

    Jo-Anne Guest

    Eeeep! Thank you, Robear. I now sorta see what's going on--but as you know,
    I'm VERY reluctant to mess with the registry. Since this issue is unlikely
    to occur often, will unblocking make it work, as Terry suggested?

    Thank you again,

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #4
  4. Jo-Anne

    Jo-Anne Guest

    Thank you, Terry!

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #5
  5. Just copy/paste the FTP address into a Windows Explorer Address bar.
     
    PA Bear [MS MVP], Jul 17, 2009
    #6
  6. Jo-Anne

    VanguardLH Guest

    FTP = File Transfer Protocol

    The client and server communicate over port 21. Since the client
    initiates the connection to port 21 at the server, its outbound
    connection is allowed by the firewall and any further communications
    over that connection are allowed. However, when a file transfer is
    requested, the server sends the file's bytes back to the client over
    port 20. That looks to the firewall like an unsolicited inbound
    connection attempt by the server. If you want to get the file, you'll
    need to allow IE to complete the FTP request on port 20. The control
    commands between client and server are over port 21. The data transfer
    from the server is on port 20.

    http://en.wikipedia.org/wiki/Ftp
     
    VanguardLH, Jul 17, 2009
    #7
  7. Jo-Anne

    Jo-Anne Guest

    Thank you, Robear! I did what you said--and after unlocking the toolbars I
    managed to get the Address bar to show up in Windows Explorer. However, when
    I typed in the publisher's ftp address, I got the same security alert that I
    had gotten earlier in IE. I clicked the X in the upper right-hand corner,
    and the box disappeared and I had all the files I was supposed to see. I
    logged in as I was told and tried to open one of the files in Microsoft
    Word. It opened, but once again I got the security alert notice, this time
    for Word. I was able to see the document anyway, but it's odd to keep
    getting this message.

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #8
  8. Jo-Anne

    Jo-Anne Guest

    Thank you, VanguardLH! In the end, does this mean I have to keep telling the
    Security Alert box to unblock?

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #9
  9. Jo-Anne

    VanguardLH Guest

    http://www.wilderssecurity.com/pics/WF-SecAlert.gif

    If you Block, it keeps getting blocked. If you Unblock, it remains
    unblocked. If you elect Ask Me Later, the connection gets blocked plus
    you will be asked again when that program tries to connect again.

    If you select Block or Unblock and later want to change your choice, you
    will have to go into the Exceptions for the Windows Firewall and either
    edit those exceptions or delete them and answer the prompt next time (to
    chose the other action).
     
    VanguardLH, Jul 17, 2009
    #10
  10. Have you ever encountered such FTP issues before?

    Start | Settings | Control Panel | Windows Firewall | Exceptions | Programs
    and Services: Are both Internet Explorer and Windows Explorer listed here
    _and_ checked?

    Reference:

    Troubleshooting Windows Firewall settings in Windows XP Service Pack 2 [and
    SP3] for advanced users:
    http://support.microsoft.com/kb/875357

    PS: Go to Windows Update website | select CUSTOM and scan | Install any
    critical security updates offered. If a Root Certificates update is listed
    in the Optional Updates category, install it to take full advantage of IE7's
    enhanced security.

    NB: DO NOT INSTALL IE8! Uncheck it & hide it instead.
     
    PA Bear [MS MVP], Jul 17, 2009
    #11
  11. Jo-Anne

    Jo-Anne Guest

    Thank you, Robear! Responses to your questions and comments follow:

    * I've never dealt with FTP before this project, so I haven't encountered
    such issues before.

    * I opened Windows Firewall and found neither Internet Explorer nor Windows
    Explorer listed as exceptions. I was able to add Internet Explorer (but is
    it safe to always keep it checked--or should I check it only when I need to
    for FTP files?) but couldn't find Windows Explorer in the list of programs
    that I could click on to make it an exception.

    * I've been keeping up-to-date on Microsoft updates on all the patch
    Tuesdays, including the one this week--and, thanks to what you told me a
    while back, I also check for Root Certificate updates each time. (There used
    to be some regularly, but I haven't seen any for a while.)

    * I have Automatic Updates configured just to notify me; I then go to
    Microsoft Update and use the Custom installation of updates. When IE8 was
    offered, I hid that update notice and have not installed the program.

    Thank you again!

    Jo-Anne

     
    Jo-Anne, Jul 17, 2009
    #12
  12. Jo-Anne

    Jo-Anne Guest

    Thank you, Vanguard! Interestingly, I chose Ask Me Later one time, and I was
    able to get the files. Another time I X'd the notice box and was able to get
    the files. If I have to keep using the FTP files, I'll decide eventually
    which way to go--with unblocking or adding to the Firewall exceptions, as
    Robear noted.

    Thank you again!

    Jo-Anne
     
    Jo-Anne, Jul 17, 2009
    #13
  13. * I opened Windows Firewall and found neither Internet Explorer nor
    I've had IE & Windows Explorer checked here for as long as I can remember
    and haven't had a lick of problems. AFAIK, both were listed & checked ever
    since I installed SP2 in Aug-04.

    QED: Did adding IE correct/resolve the behavior?
    Start | Settings | Control Panel | Windows Firewall | Exceptions | Programs
    and Services | click on Add Program button & select Windows Explorer or
    browse to & select C:\WINDOWS\explorer.exe.


     
    PA Bear [MS MVP], Jul 17, 2009
    #14
  14. Jo-Anne

    Jo-Anne Guest

    Thank you, Robear! Adding Internet Explorer to the Firewall exceptions
    solved the first part of the problem. I was able to get to the files without
    a warning.

    However, when I went to open one of them in Microsoft Word, I got the same
    security alert as before about Microsoft Word. The alert was in a separate
    window, which meant that I was able to see the file anyway--but does this
    mean that for smoother running, I need to add Word to the Firewall
    exceptions? And if so, is that safe to do? (Word isn't listed in Add
    Programs in the Firewall, so I'd need to browse to it--as I would to get
    Windows Explorer.)

    Thank you again!

    Jo-Anne

     
    Jo-Anne, Jul 17, 2009
    #15
  15. Did you save the download to your desktop before attempting to open it in
    Word? If not, please do so.

     
    PA Bear [MS MVP], Jul 17, 2009
    #16
  16. Jo-Anne

    Jo-Anne Guest

    I wasn't sure what you meant by saving the download to the Desktop, but
    here's what I did. The download appeared in My Network Places as a folder,
    so I "cut" it from that spot and pasted it at the Desktop. (But a copy was
    also left at My Network Places even after I cut it from there.)

    Anyway, what happens now is that if I double-click on the folder on the
    Desktop, I get the Windows Security Alert for Windows Explorer (I didn't yet
    add Windows Explorer to the Firewall exceptions). If, however, I
    double-click on the same folder in My Network Places, it proceeds as it
    should--until it gets the Security Alert for Microsoft Word.

    Did I do what you intended?

    Jo-Anne

     
    Jo-Anne, Jul 17, 2009
    #17
  17. Right-click on the saved file (wherever it's located) | Properties | At the
    bottom of the General tab, click the Unblock button (if found).

     
    PA Bear [MS MVP], Jul 17, 2009
    #18
  18. Jo-Anne

    Jo-Anne Guest

    No Unblock button in Properties for the folders or the files. Properties
    shows, across, Permissions: Read, Write, Execute; and, down, Owner, Group,
    All Users. (Looks like only owners can write, but everyone else can read and
    execute.)

     
    Jo-Anne, Jul 17, 2009
    #19

  19. What about the file you copied it from? Also are we sure that this is a copy
    and not a shortcut to the original file? ; )


    ---


     
    Robert Aldwinckle, Jul 18, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.