Is it possible to send alt-tab (etc.) to host Windows?

Discussion in 'Virtual PC' started by Peter D. Jørgensen, Jul 30, 2009.

  1. I rarely switch between the apps in my Virtual PC, so I would really like
    alt-tab to switch between apps in my host Windows, and not in the virtual
    Windows. Both Windows versions are XP Pro. Currently I have to press host
    key+hown arrow first, but I keep forgetting that...

    Is there anyway to change this?

    Thanks in advance
    Peter
     
    Peter D. Jørgensen, Jul 30, 2009
    #1
    1. Advertisements

  2. Peter D. Jørgensen

    Robert Comer Guest

    <Ctrl><Alt><Tab> brings up the hosts's <Alt><Tab>, but you have to
    hit the enter key after selecting the proper app to switch to it.
     
    Robert Comer, Jul 30, 2009
    #2
    1. Advertisements

  3. Thanks, but not in my Virtual PC. :-(
    I'm using Virtual PC 2007, build 6.0.156.0 with the the VM additions version
    13.803.0.0.

    Any hints?

    /Peter
     
    Peter D. Jørgensen, Jul 30, 2009
    #3
  4. Peter D. Jørgensen

    Robert Comer Guest

    Thanks, but not in my Virtual PC. :-(
    That really should work as it forces the host to handle the request,
    the version of VPC should have nothing to do with it.

    It works here whether the VM is in windowed or full screen, so I don't
    know what the problem might be.
     
    Robert Comer, Jul 30, 2009
    #4
  5. Peter D. Jørgensen

    SaGS Guest

    There's a setting in VPC console/ 'File'/ 'Options'/ select 'Keyboard' at
    left and then 'Allow Windows key combinations': 'On host operating system'
    or 'In full-screen mode on guest operating system'. Note: that controls more
    than Alt+Tab (Win key and maybe others too). I'm using VPC version
    6.0.210.0.
     
    SaGS, Jul 30, 2009
    #5
  6. Peter D. Jørgensen

    Robert Comer Guest

    There's a setting in VPC console/ 'File'/ 'Options'/ select 'Keyboard' at
    Good point, I don't usually use it that way as it's a global setting,
    but it will do what the OP wanted better than what I suggested.
     
    Robert Comer, Jul 30, 2009
    #6
  7. Perfect! This was exactly the setting I was looking for.
    Thanks.

    /Peter
     
    Peter D. Jørgensen, Jul 31, 2009
    #7
  8. Well, now I have been using it for some days and it is not without problems.
    It turns out that it now sometimes suddenly disables the keyboard entirely
    in my VPC.
    I can then bring it back to life by changing the setting to "On guest
    operating system" - Press Ok - change the setting to "On host operating
    system" and press Ok.

    So this setting is not perfect, but it works most of the time :)

    /Peter
     
    Peter D. Jørgensen, Aug 5, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.