Is Rome Total War compatible with Vista?

Discussion in 'Windows Vista Games' started by This is so annoying....., Mar 6, 2007.

  1. One question real quick - my friend wants to know if Rome Total War is
    compatible with Vista. Is it? Thanks all
     
    This is so annoying....., Mar 6, 2007
    #1
    1. Advertisements

  2. This is so annoying.....

    Richard XXII Guest

    Soryy can't be sure--BUT Medieval Total War 2 works in Vista 32bit, quite
    well also. Not sure how much changed between RTW and MTW2 but it's worth a
    shot installing--I'd almost bet money it will work fine.
    Good Luck
     
    Richard XXII, Mar 7, 2007
    #2
    1. Advertisements

  3. Thanks. I guess the only way to test it for real is to have him bring his CD
    to me and test it on my Vista. He wants to know whether to get a new comp
    with Vista or XP, and he kinda bases his life around this game (not really,
    but close to it) lol. Thanks for the help
     
    This is so annoying....., Mar 7, 2007
    #3
  4. This is so annoying.....

    David N Guest

    I have Rome Total War, with the latest game patches, and it plays just fine.
    I haven't had an issue yet with this game. Warcraft 3 on the other hand, is
    giving me poor results. The video display lags like crazy.
     
    David N, Mar 7, 2007
    #4
  5. This is so annoying.....

    Richard XXII Guest

    You can try running older games in compatibility mode for winxp or even
    98/me in some cases. It could make the difference.
    Good Luck
     
    Richard XXII, Mar 7, 2007
    #5
  6. This is so annoying.....

    David N Guest

    The story campaigns work just fine for me in Warcraft 3. The lag issue is
    from the skirmish/custom maps. My video card is not the greatest. It is a
    Mobility Radeon 9600/9700, with 128mb, and the latest Ati drivers. I will
    try the running the compatibility mode as Richard XXII advised.
     
    David N, Mar 7, 2007
    #6
  7. This is so annoying.....

    kryddstark Guest

    I can't even get post installation when trying to install my Rome on
    Vista. It keeps telling me that certain graphics files are not present
    on the installation disks and I can not get past it. Any hints?
     
    kryddstark, Apr 21, 2009
    #7
  8. This is so annoying.....

    Joe Guest

    Install DirectX updates (DXWebsetup.exe, you can get it from
    microsoft.com/directx)
    update vidoe drivers
    update audio drivers

    Post system specs?

    can't give accurate hints with vague information.
     
    Joe, Apr 23, 2009
    #8
  9. This is so annoying.....

    kryddstark Guest

    Ok, updated to Direct X 9.0 and checked that the sound and graphic
    drivers were current.

    System runs Windows Vista Home Premium.
    2.39 GHz Intel Core 2 Quad CPU
    4 GB Ram
    NVIDIA GeForce 8600 GTS

    I bought it from Dell in October of 2007.

    Lets see if it works now
     
    kryddstark, May 5, 2009
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.