Issues migrating 2003 SBS -> 2008 SBS

Discussion in 'Windows Small Business Server' started by Freaky, Sep 28, 2009.

  1. Freaky

    Freaky Guest

    Hi there,

    we're running into some issues with the migration from 2003 SBS to the
    2008 version.

    You can see a screenshot of the error here:
    http://yfrog.com/0oimg00004200909271437j

    First of all, I don't know if the warning on the domain/forest
    functional level is always there. You seem to be able to acknowledge
    this and the continue. Both the AD tools and the SBS BPA acknowledge it
    is on 2003 functional level (for both domain and forest).

    The error on Exchange is what stuns us though. SP2 has been on it for
    years. Last week we updated it to native mode for the upcoming
    migration. According to ESM it is in native mode and thus there are also
    no buttons anymore to put it in native mode.

    SBS BPA reports Exchange 2003 has SP2 installed, but reports it is
    running in mixed mode.

    The 2008 migration tool, as you can see in the error image, reports SP2
    is not installed.

    I tried to reinstall SP2 but this gave an error that IMFv1 would still
    be installed. As I didn't see in add/remove programs I looked up the
    manual removal process. I could remove the ContentFilterVersion registry
    key from the registry (which had 0x0 as value) and rename the
    contentfilter.dll (both from my head names might differ a little).
    However, the folder I was supposed to rename, called MSCFV1 did not
    exist. There was (and still is) a MSCFV2 folder, which surprises me as
    the installer said IMFv2 comes with SP2 and can not be installed if
    IMFv1 is installed, but apparently it was installed already.

    Reinstalling Exchange 2003 SP2 however hasn't changed anything. ESM
    still reports it's in native mode and at SP2. BPA still says SP2 is
    installed but that it's still in mixed mode and the migration tools
    still say SP2 is not installed.

    This server has Trend Micro anti-virus. It did include the messaging
    agent (a/v in exchange). I have removed that part of Trend Micro from
    the server, but it doesn't seem to make any difference.

    Any ideas?

    TIA
     
    Freaky, Sep 28, 2009
    #1
    1. Advertisements

  2. Les Connor [SBS MVP], Sep 28, 2009
    #2
    1. Advertisements

  3. Freaky

    Freaky Guest

    Afraid not. Sourcetool has been run and I don't get the errors on the 21
    days grace period nor that the scheme hasn't been updated.

    Thanks tho'
     
    Freaky, Sep 29, 2009
    #3
  4. Freaky

    Freaky Guest

    SOLVED! :)
    Credits to sharedit, who posted this on experts-exchange.com:

    ------------------------------------------------------------------------
    Ok, problem solved. Im going to include as much information as
    possible, so that others may benefit.

    The problem was the site uses a class B network, SBS 2008 assumes a Class C.

    I called microsoft, and worked with them, but had I known you could
    access a command prompt on the destination server by hitting shift +f10
    this would have been very easily solved.

    the sbs 2008 would install fine until the wizard page confirming source
    name, domain name, dest name, admin account/pwd, etc. At this point I
    would get the error: Cannot find the Source Server Verify that the
    Source Server name is correct,
    and then try again

    In troubleshooting, I could take the network cable and put it in the
    second nic and it would then go on to the next step. That is where I
    would get the next set of errors.

    source server does not meet minimum requirements for migration

    if the domain/forest functional level is not windows server 2003 you
    will encounter setup errors
    you must raise the functional level of the Active directory domain and
    forest on the source server. & Source server does not meet service
    pack requirements. you must first install service pack 2 for exchange
    server 2003. for instructions see....

    Solution:
    At the first error, shift + f10 will bring up a command prompt.
    from there you can test with ping (IP, fqdn, netbios), Ipconfig, to find
    out what is actually not working or configured incorrectly.

    to get to the SBS setup log.
    go to C:\Program Files\Windows Small Business Server\Logs\SBSSetup.log
    the command "notepad SBSSetup.log" will open it in notepad. you'll get
    alot of info from this, this is where I noticed the Mask it was
    assigning was incorrect.

    the command "control" will open up the control pannel. From here you
    can configure many things(duh), you can enable Remote connections an RDP
    to the server if youd like (assign an admin pwd first). What I did was
    change the subnet mask to its correct /16. and tryed again. At this
    point the Install continued without a problem.

    with the incorect mask I was able to ping the source from the
    destination by IP and Fqdn but not name. after the change and IPconfig
    /flushdns i was able to ping all 3.

    This was a very simple solution, i was completely frustrated/embaraced
    that I found no reference to the shift +f10 for the command prompt on
    the destination server durring my searching. it made troubleshooting
    the destination server like a pc and not just a Wizard screen that you
    cannot advance past.
     
    Freaky, Nov 9, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.